Sign in to follow this  
Goatman24

Strange ATC headphone problem

Recommended Posts

When using FSX I like to use a second sound card so that I can receive the ATC from a headset. I'm having an issue where the sound card used for the headset will automatically turn off reverting the sound of ATC back to my surround speakers. I've trouble shooted this to no avail including trying another headset, changing from a usb sound card to a PCIE sound card, removing most of my unnecessary usb components and still the same issue. 

 

I can recreate the issue easily by spinning my Saitek trim wheel though I think my Saitek yoke has caused the issue on occasion also. When I walk in front of my system it does the same thing even if the program is paused. I can hear the sound of a usb device being unplugged then reconnected. At least that's what it sounds like. 

 

I'm at a total loss as to what is causing this and open to any suggestions for things I can try. 

 

Thanks

 

System specs:

Rosewill THOR V2 Gaming ATX Full Tower Computer Case

ASUS Maximus VII Hero Socket LGA 1150 motherboard

Intel Core i7-4790K Haswell Quad-Core 4.0 GHz LGA 1150 Processor (Not over clocked)

8GB Ram 

850W Thermaltake Toughpower Power Supply

Intel Solid State Drive 335 Series - 240 GB

Corsair H-80 High-Performance Hydro CPU Cooler

Go-Flight TQ-6 Throttle Quadrants

Saitek Trim Wheel

Saitek Pro-Flight Yoke

Saitek Switch Panel

USB Pulse Generator Model 2120 (For switches/buttons)

CH-Pro Pedals

Triple-Head-ToGo

2- AL2216W ACER Monitors 

1- NEC old monitor (For controls)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have the card with the headphones set in FSX->Settings->Sound->Voice?

 

N99WB

Share this post


Link to post
Share on other sites

If you set "sounds" and "voice" to your headphones, does it still flip?

 

N99WB

Share this post


Link to post
Share on other sites

Yes it did. I just pulled all unnecessary usb devices out. cut all scenery settings in half and started it up. My Saitek yoke was not recognized to I double checked to make sure I didnt' pull it out by accident and I hadn't. When I unplugged it and replugged it in, it worked. Flew a short while and it disconnected again this time turning back on right away but flipping the headphones sound to default. Then tried all sound to the headphones and got the same thing.

 

I think it's the Saitek Yoke and trim. These seem to be the two culprits.

 

I had gotten rid of my old Saitek throttles a long time ago because of known bad potentiometers. I'm thinking what ever they are using on the yoke and trim is probably not good and causing the issue. Unfortunately, I have my dash built out of Corian and around two Saitek flight yokes. Arrrggghh. Looks like I'm gonna have to spend some more money and time on swapping these out. Btw, the other Saitek yoke quit working a while back as well.

 

I'm going to consider this the problem at this point and consider it solved until I can try another yoke to verify it.

 

Thanks for your help N99WB. Much appreciated.  

Share this post


Link to post
Share on other sites

Saitek yokes, joysticks and rudder pedals are notorious for borking other USB devices, if the Saitek unit is unplugged while the computer is on. It's apparently a feature in their magical device drivers.

Share this post


Link to post
Share on other sites

First off, I apologize for posting a hardware problem in this forum, I just noticed that your not supposed to. 

 

Today I almost purchased another flight yoke when someone suggested the following:

Look at the OS power options in the system settings (or use the start menu search tool and search for Power Options. These settings are used to set 'rules' on how the OS reacts to certain background events and there is a specific section regarding what actions the OS takes when it 'detects' (or a better descriptive word would be 'thinks') that the system is idle, including USB ports. Check and the current settings and change as follows:

1. Click Change plan setting.
2. Click Change advanced power setting.
3. Find USB settings and open.
4. Find USB selective suspend setting and change it to disabled.

If the option is already set to disabled, select enabled and then disabled again
.

 

This took care of it I hope. I've just taken one complete flight from Dillingham Field on Oahu Hawaii to Honolulu Intl. and no issues. 

 

Sorry again for posting in the wrong area. Just getting back to flight simming again after being away a while. 

 

Thanks for all the input. 

Mitch

Share this post


Link to post
Share on other sites

Sorry, I spoke too soon on this. 

 

After plugging all back in and cranking up my settings again, i could still get the issues although it seems to be less frequent. I'm back to leaning towards thinking it's Saitek. Just want to try everything else out first because of the cost of upgrading my yoke. 

 

I've also noticed that my yoke onscreen looks like it's flickering a lot as if it's not sure where it should be. 

 

If a moderator wants to move this post to the proper forum please do.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this