Sign in to follow this  
flyforever

nvidia inspector fps limiter questions

Recommended Posts

My assumption regarding external fps limiters is that they would prevent fps from going past the set limit. In my case, no matter what number I set it at, with fsx internal fps set to unlimited), the fps number always spikes above the set limit number. I have tried it with vsync on or off and various refresh rates. Nothing.

The only thing that works is fsx internal fps limiter. So what am I doing wrong. One more thing, N inspector frame limiter starts at 29, yet it has a 1/3 refresh rate option. My monitor is 60 hz, and I should be able to set my number to 20 with 1/3 refresh.

Some clarification would be appreciated.

 

A 3 step guide would be helpful.

 

My system is running at 4.5 ghz and a gtx 1060, with no add ons. I should be able to experiment with an external frame limiter and see steady numbers--- not numbers jumping all over the place.

 

tony

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I use 1/3 refresh rate as well. In NI I set it to 1/3 vsync. In FSX I set it to 20.

 

Some will say set it to u limited but that doesn't work.

Share this post


Link to post
Share on other sites

Actually, I am using an I5-2500K Overclocked to 4.5ghz and a gtx 1060. Win 7 64 is the OS. I am quite happy about the system's performance and how FSX runs. I am simply curious to know what's what with FSX internal fps slider and and Nvidia external frame limiter. It would seem to me that only one of the two is needed, but not both.

If you use the external limiters, the fps number does not stay at the set number unless I have the same number set in FSX.

tony

Share this post


Link to post
Share on other sites

Are using the FSX internal frame rate display? It tends to be erratic and jump alot, although if you set NVIDIA Inspector to cap frame rates it should be decently stable around the rate set. Try measuring frame rate with an external software, like Fraps. See what happens.

 

Also make sure you're actually setting up NVIDIA Inspector correctly. Make sure click apply settings before you close it etc in order to rule that out. There are lots of guides out there if you haven't already checked them out.

 

Andre

Share this post


Link to post
Share on other sites

It's kind of already been answered.

 

Don't set NI to limit FPS. Use the vsync on whatever it is then use the FSX slider to the same FPS as the vsync.

Share this post


Link to post
Share on other sites

If you download and install RivaTuner it will allow you to control the framerate outside the sim.  You can set the sim framerate to unlimited and then set the framerate limit you wish to keep in RivaTuner.  I have been using it for some time and it works very well.  Just google "rivatuner".

 

Regards,

 

Danny

Share this post


Link to post
Share on other sites

I realky don't know why it's so hard. Set NI to whatever vsync you want. DOnt touch the FS limiter in NI and then set yiur FSX FPS slider to the correct FPS for the vsync chosen.

 

Example : 60 hz monitor and 1/2 vsync in NI. FSX FPS slider : 30

1/3 vysnc FSX FPS : 20.

 

Setting NI limited will cause the FPS to bounce around all over the place and will be less smooth.

Share this post


Link to post
Share on other sites

Setting NI limited will cause the FPS to bounce around all over the place and will be less smooth.

I found the opposite. If I use the internal FSX limiter at 30 FPS, I get variations from about 25-33 FPS, if I use the NI limiter, it stays at about 30 plus or minus 1 or 2. Both FPS limiters give me equally smooth graphics.

Share this post


Link to post
Share on other sites

I found the opposite. If I use the internal FSX limiter at 30 FPS, I get variations from about 25-33 FPS, if I use the NI limiter, it stays at about 30 plus or minus 1 or 2. Both FPS limiters give me equally smooth graphics.

Is that using vsync as well? The key is getting pretty close to the locked figure - say 30 if using 1/2 vs - but if it dips, it seems smoother then not using Internal limiter.

 

 

But different systems, different settings etc etc etc etc .

Share this post


Link to post
Share on other sites

Is that using vsync as well? The key is getting pretty close to the locked figure - say 30 if using 1/2 vs - but if it dips, it seems smoother then not using Internal limiter.

I use adaptive 1/2 vsync with unlimited FPS in FSX.

Share this post


Link to post
Share on other sites

It's best not to use the Inspector limiter at all. It is kind of "weak", and still allows for spiking as you mentioned. 

 

 

The best thing to do is using the internal limiter, which downside is that is supresses your FPS. So as long as you cannot maintain a stable FPS number (20 FPS for 1/3 refresh rate) it will not be smooth. 

 

One advice: on a few add-on planes such as the PMDG planes, you can get away with not using any FPS limiter whatsoever, and VSync 1/2 refresh rate should still be 100% smooth, as long as you can maintain a stable 30 FPS. One requirement is however to set the refresh rate of the displays to either 15 or 30 in the CDU, otherwise you might get stuttering.

 

Unfortunately in the default planes and planes you can achieve high FPS with, FPS is going to spike a lot because it is very eager to go high. These are the situations in which you are definitely going to need the internal limiter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this