john1383

new error message?

Recommended Posts

Dave,

 

Whenever I try a direct flight (IFR) of about 40miles from EGPF to EGPH at 5000ft, not using SIDs or STARs but choosing runway 6 as the destination runway, about halfway through the flight I get a screen message containing the following (I took a screen shot but can't add it for some reason)

 

Systen nullReference exception@object reference not set to an instance of an object.

at P2A_2016.controller.a(approachplan A_0,STARPLAN A_1)

atP2A_2016.controller.setupvectoredapproach(string&trtn,string& SugRes)

at P2A_2016.controller.setupILSApproach(string& Trtn, string& SugRes,Runway RWY,Boolean Vectors,Boolean StartApproachNow)

 

The flight can continue normally after the message, and P2A seems to work OK as well.

 

In the config menu "Flt Pln", the only boxes ticked are

 

Force pilot runway selection.and the two ATC ignores boxes.

 

altitude lead time is 40secs and vector leg is 7.

 

Any clues?!

 

John

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

John,

This is a bug which should be fixed in the next update.

 

Thanks for the report,

Dave

Share this post


Link to post
Share on other sites

Dave,

 

Just tried the same flight using 2.2.0.3 and the same message appeared again,part way through the flight.

 

Maybe this update is not the one you meant, perhaps the next one?

 

Doesn't seem to affect the operation of P2A though.

 

John

Share this post


Link to post
Share on other sites

John,

I flew this yesterday several times without problem.  I did find that the setting of 7NM for vector leg length.  Suggest you reduce it to 4 for jets and 2 for Prop aircraft.

 

I'll see if I can replicate the issue in 2203.  I thought I had it fixed.

 

Sorry,

Dave

Share this post


Link to post
Share on other sites

Well, I flew it again and I was able to get a different error when getting a new frequency assignment.  It's possible that your error was related to being switched to Approach Control about half way through the short flight.

 

The fix will be in 2204.

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

Thanks for all your efforts Dave. I will do the changes as you suggest to see if they help my particular problem, and await 2004!

 

John

Share this post


Link to post
Share on other sites

For some reason I had mistakenly not actually installed version 2203, when I thought I had so that is why I continued to get that error message. Sorry for the misinformation and perhaps wasting your time.

However now I find in this same short IFR flight, ATC has started repeating instructions over and over, culminating with P2A stopping working altogether. This has not happened to me before with P2A.

 

Perhaps the flight is too short for a meaningful appraisal, normally it would be a VFR flight.

I will try a longer one later.

Share this post


Link to post
Share on other sites

I tried my normal 150 mile test IFR flight, EGNT to EGPH at 6000ft, and unfortunately ATC stopped talking to me halfway through. Just navigated and landed myself.

All was fine until the communication ceased..

 

Something has changed for the worse as I usually complete this flight without drama!

Share this post


Link to post
Share on other sites

If you have the log file, I can look at it and see what happened.

If you were using the co-pilot, he sometimes doesn't do the frequency change correctly, which then seems like communications has stopped.

I'll PM instructions on finding the log file.

 

Thanks,

Dave

Share this post


Link to post
Share on other sites

All is well now thanks Dave. Mainly my fault I expect!

Thanks for checking the log file.

 

John

Share this post


Link to post
Share on other sites

I am a new user running p2a 2212 and I am having problems with co-pilot not changing the frequencies at all.  Was working for a while and then quits.

I cannot figure out how to attach the log file so I will send via email.

Share this post


Link to post
Share on other sites

Be sure to have the copilot Respond to Radio option checked to ensure all the readbacks are done properly.

Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now