Sign in to follow this  
eric_jeppesen

P3D black screen in start-up menu

Recommended Posts

ALSO black screen in gaming!

 

Hi,

 

Today when I completed my PMDG777 flight and exit P3D normally and I launch P3D again, the picture with Prepar3D icon shows in middle normally. BUT after few sec it was black screen, no start-up menu.

And then click my mouse at black screen, Win10's warning sounded. When I tap ESC, exit menu window showed.

Then I try to load a flight in exit menu window, loading window showed. When it was completed, black screen, sound only. To push my yoke's throttle, engine's sound changed.

 

I don't know how to fix my problem and my PMDG747v3 has not deactivated, I really can't reinstall P3D.

Could someone help? Thx a lot.

 

Eric

 

P.S. I apologize that I've post one same as this: http://www.avsim.com/topic/504746-p3d-black-screen-in-start-up-menu/ 

P.S.2 This problem came up suddenly and nothing else I had done before black screen.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I agree with Richie.  I don't think PMDG aircraft can be treated like default aircraft as PMDG aircraft have to initialize.  I've heard of other reports where some will save a flight and then click on the saved flight and will have problems. 

 

I deleted the duplicate post.  Thanks for bringing to my attention.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

You didn't make a PMDG aircraft your default aircraft at load up did you?

 

 

I agree with Richie.  I don't think PMDG aircraft can be treated like default aircraft as PMDG aircraft have to initialize.  I've heard of other reports where some will save a flight and then click on the saved flight and will have problems. 

 

I deleted the duplicate post.  Thanks for bringing to my attention.

 

Best regards,

Jim

 

Hi,

 

Thanks for your reply!

 

PMDG aircraft can be treated like default aircraft that's mean I shouldn't select PMDG aircraft in start-up menu? Just select a default in P3D such as F22 and change vehicle as PMDG?

 

But thanks to Jim's CTD guide, I deleted dll.xml and then everything worked fine, it's return to normal. Anyway, thank you all, Jim and Richie.  :wink:

 

Eric

 

P.S. I think it's FSDT's Addon Manager's issue, now I'm trying to fix it.

Share this post


Link to post
Share on other sites

It is the stupid fsdt addon manager.

I am having same issue p3d v3.4

Hf3 has worked fine initial startup and flight i them exit and i get ctd

Then i retry to load sim i get black screen and ctd

 

Ive tried deleting cfg shader etc etc etc

Nothing worked

I then ran addon manager and viola worked.

 

I ran a few tests and all have les back to.the addon manager beig the culprit

 

Hope the fix this asap

Cheers

Mike

Share this post


Link to post
Share on other sites

It is the stupid fsdt addon manager.

I am having same issue p3d v3.4

Hf3 has worked fine initial startup and flight i them exit and i get ctd

Then i retry to load sim i get black screen and ctd

 

Ive tried deleting cfg shader etc etc etc

Nothing worked

I then ran addon manager and viola worked.

 

I ran a few tests and all have les back to.the addon manager beig the culprit

 

Hope the fix this asap

Cheers

Mike

 

Hi Mike,

 

Thanks for your reply and FSDT Addon Manager is really annoyed. I just installed their airports in states but no GSX, cuz I heard GSX can make CTD more easily. BUT all of FSDT's services are aim to GSX no matter if you install it.

Same as yours, I hope FSDT fix it ASAP.

 

Eric

Share this post


Link to post
Share on other sites

A lot of people are having a problem with the FSDT Addon Manager.  They update it frequently to be compatible.  I just reinstalled every FSDT airport and FlightBeam airport and had no problems so it is hard for me to determine what others who are having issues are doing wrong.  I do know Microsoft has made their Windows 10 more secure with their free anti-virus and anti-malware programs and you might want to look there to see if anything was placed into quarantine.  They like to identify .dll's they don't like and they want to protect you from evil people even though you, the owner of your PC, knows exactly what they are downloading and installing on their computer system.  Of course, if you have another anti-virus program running that program could be doing the same thing. 

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Well I don't know if this was my problem but reinstalling GSX fixed things for me. One moment P3D was working fine and closed fine. The next time I ran it I also got a black screen after the initial blue opening box. Restarting did not fix it. As per advice here, I re-ran the installer for GSX and P3D started up OK.

 

I also noticed that Bit Defender, 2 weeks back, 'attacked' my installation of SODE and deleted whatever it felt it needed to in the folder. Really makes me want to trash antivirus altogether! I now have half my PC on the exclude list anyway!!!

 

So somewhere between Bit Defender and FSDT there is an outright conspiracy on the go to destroy my P3D installation. Damn annoying!

 

EDIT: Also check that you are using the lastest version of FSUIPC. Latest version is compatible with HF3 and is 4.962. Unfortunately on the download page it just shows 4.96. It leaves off the critical last digit. Previous version was 4.961 and this is not compatible with the latest HF3 and can also leave you with a black screen on start.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this