Recommended Posts

FS++ support. 

In case you were not aware and being that understand you have PF3 voice interface improvements in the pipeline, there has just been an update to PF3 which has introduced a change to enable the PF3 FO voice to be muted when using VR software to communicate (eg MCE). 

On reading the following it would seem there may be a change in relation to the ptt button sequence, which may effect how MCE handles things. 

From the PF3 user guide:

18.2.2 Switching  between  using  VR  and  your  VCP  for  ATC  communication Unlike  the  previous  method  with  this  one  you  should  not  set  the  pilots  voice to  None  and  if  you  do  this  method  simply  doesn't  work.  So  please  ensure  you have  a  pilots  voice  selected  on  the  Options  #1  page. Next  you  must  set  your  VCP  mode  to  either  0  (zero)  or  1.  Again  if  you  don't this  method  will  not  work From  the  Options  #1  page  please  set  your  PTT  pause  interval  to  a  value greater  than  zero.  You  might  have  to  experiment  with  the  value  used  here. Select  the  Auto  Mute  option  which  you  will  find  on  the  Options  #1  page  just to  the  right  of  the  VCP  mode  selection  options.

Now,  if  you  want  to  speak  to  ATC  directly  you  should  hit  the  PTT  key  followed immediately  after  with  the  relevant  ATC  communications  hotkey.  You  will  not hear  your  VCP  talking  to  ATC  provided  you  complete  the  keying  sequence before  the  PTT  pause  interval  expires. If  you  then  decide  you  would  like  your  VCP  to  chat  with  ATC  you  simply  use the  relevant  hotkey  without  using  the  PTT  key,  in  which  case  you  will  hear your  VCP  chatting  to  ATC. 

Don't know if this effects anything in MCE when it comms to using the MCE ptt button fo communicate with PF3 ATC? 

Cheers, 

Stuart

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

No it shouldn't do anything to MCE.

It just mutes the selected pilot's voice in PF3 when the PTT button (the assigned MCE button should be assigned to the PF3 PTT hotkey via FSUIPC) is pressed.

I am yet to test the new version of PF3 but if it works how it is supposed to, that finally is what I was missing so long. Now you can switch between talking to ATC yourself and having your FO talk to ATC (using voxkey commands) anytime within one session (without hearing the FO's voice after your own spoken ATC transmission).

That is a massive enhancement of the MCE+PF3 experience!

What remains as a task for an upcoming MCE FO-ATC interaction is to integrate the appropriate commands to the FO into MCE (without the need of creating an own voxkey profile for that) and to solve the problem of two different voices of the FO (one PF3-voice and one MCE-voice - a solution for that would be if PF3 would also work with TTS voices, so you could choose the same TTS voice for both programs; but that would be up to PF3 of course).

 

Share this post


Link to post
Share on other sites

Stuart or Ralf, I have a question for either one of you.  When I went to update PF3 it said I was about to deactivate PF3 on this computer and would be unable to reinstall it.  Before I do anything I just want to be sure I'll be able to get the update installed on the same computer. It says to select option 2 then deactivate.  I don't get a "select option #2". Don't want to deactivate without knowing what I'm doing.  Sorry, I'm just no good with computers.  Thanks for your help.  Appreciate it.

Rodger

Share this post


Link to post
Share on other sites
2 hours ago, C130FE said:

Stuart or Ralf, I have a question for either one of you.  When I went to update PF3 it said I was about to deactivate PF3 on this computer and would be unable to reinstall it.  Before I do anything I just want to be sure I'll be able to get the update installed on the same computer. It says to select option 2 then deactivate.  I don't get a "select option #2". Don't want to deactivate without knowing what I'm doing.  Sorry, I'm just no good with computers.  Thanks for your help.  Appreciate it.

Rodger

I just did what all the popup windows told me to, including deactivating and reactivating the software. All worked fine.

Share this post


Link to post
Share on other sites
11 hours ago, RALF9636 said:

I just did what all the popup windows told me to, including deactivating and reactivating the software. All worked fine.

Ok, thanks Ralf.

Share this post


Link to post
Share on other sites

Anybody running MCE successfully with the newest version of PF3 (3.3.0)?

I have the problem that MCE does not recognize any of my ATC commands to PF3 anymore. The only command that is recognized is "say again for ...". That one works exactly as it should so that proves that my installation (in particular the PTT button) basically is working fine. But no other spoken ATC requests are understood anymore. Manually pressing the PF3 hotkeys works fine. All other MCE commands (outside ATC) are working fine.

So I'd like to know if anything is going wrong on my end or if the latest PF3 update included some changes that broke the MCE compatibility.

 

Share this post


Link to post
Share on other sites
2 hours ago, RALF9636 said:

Anybody running MCE successfully with the newest version of PF3 (3.3.0)?

I have the problem that MCE does not recognize any of my ATC commands to PF3 anymore. The only command that is recognized is "say again for ...". That one works exactly as it should so that proves that my installation (in particular the PTT button) basically is working fine. But no other spoken ATC requests are understood anymore. Manually pressing the PF3 hotkeys works fine. All other MCE commands (outside ATC) are working fine.

So I'd like to know if anything is going wrong on my end or if the latest PF3 update included some changes that broke the MCE compatibility.

 

DISREGARD.

Problem solved after a reboot. Working fine now, also the new Auto-Mute Feature of PF3 (activate it directly in the PF3.ini file!) seems to work, but I still have to find the appropriate PTT pause interval setting in PF3.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now