Sign in to follow this  
Bob New

Flying on x plane 10

Recommended Posts

Hi had x plane 10 now for quite a few months flying all types of aircraft but find that after a few take off and climbing the aircraft loses control and nose dives to ground. Being a retired real time pilot  with saitek pro 52 controls can't seem to correct, am using iMac computer and flying new beta x plane 11 demo which I intend buying soon it flies perfectly also in 10 have not managed to get ground support services to work. Having used right back to micro soft flight sim me 2000 with box load of add ins such as 727 professional flown all over the world  plus combat seemed more user friendly.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Bob New - I moved your post to this forum as you will probably get more help here than in the Welcome forum.  This forum is populated by some very knowledgeable X-Plane pilots. I'm sure they will be happy to help. And, welcome to Avsim.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I believe that the X-Plane 11 demo only allows you to fly for 10 or 15 minutes and then you lose control of the airplane.

Share this post


Link to post
Share on other sites
21 hours ago, Bob New said:

Hi had x plane 10 now for quite a few months flying all types of aircraft but find that after a few take off and climbing the aircraft loses control and nose dives to ground.

That's not normal behavior.  Does this happen with default aircraft?  You also mentioned that you can't "get ground support services to work" which is not a standard feature in XP10, so I'm assuming you're using third-party add-ons.  Try running the sim "clean" and see if you're still having problems.

Share this post


Link to post
Share on other sites

Hi guys thanks for coming back,  Mountain Man thanks for advice yes it was with default aircraft, Hi bobterri have now installed x plane 11 so see how I get on with that, you are the only two guys who i have had contact with on avsim nobody else replies to all my questions, thank you once again.

Share this post


Link to post
Share on other sites

I suppose it's worth asking if you're using a legitimate copy of X-Plane 10, because that sounds like a classic anti-piracy measure.

If your software is legit, and since it seems to happen with all aircraft, the next suspect would be your flight controller.  Perhaps it's calibrated incorrectly or malfunctioning, or there's a problem with the drivers.

Finally, it could be your flying technique.  For instance, if you're taking off with flaps extended and forget to retract them before increasing your speed, bad things can happen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this