Recommended Posts

@Keven Menard I am on v0.1.710

Hat switch panning of views has some awkward changes.

I have assigned the 4 joystick (Warthog) hat switch keys for panning-up-down-left-right in CP.

There is no axis or keys for it assigned in P3D Controls settings.

When I move in default P3D external (Outside - Spot) view when I pan UP or DOWN the view RESETS to rear (6 o'clock position) and then moves up or down.

Any left or right movement moves it left or right BUT with the slightest click of UP or DOWN it goes back to 6 o' clock lateral position.

In VC cockpit view when I make any view move with the hat switch there is a stutter / jitter (whatever its called) the first millisecond with a flash like view of the main front view and THEN it pans.

Any move of pan with hat switch produces this flash.

I have tried transitions etc. but it does not change.

When I make changes between preset cameras with the assigned joystick keys this flash view does does not take place.

It only happens when I pan around with the

Any clues ?

If the above descriptions don't help I can produce short video's of it.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Make sure your HAT controls aren't assigned in the P3D controls, FSUIPC or anything else that controls the view by any other means. It's the only thing that can produce that effect. 

Share this post


Link to post
Share on other sites

Ahhh found it!

There was no P3D or FSUIPC axis assignment BUT in CHASEPLANE's Tilt and Pan Control Assignments I had both the 4 POV BUTTONS of the HAT switch assigned as they should be but also the 2 Tilt and Pan axis assigned.

I deleted the 2 Chaseplane Tilt and Pan axis assignments and this cured the problem.

Thanks.

Share this post


Link to post
Share on other sites
On 22.4.2017 at 11:26 AM, Kyprianos Biris said:

@Keven Menard I am on v0.1.710

In VC cockpit view when I make any view move with the hat switch there is a stutter / jitter (whatever its called) the first millisecond with a flash like view of the main front view and THEN it pans.

Any move of pan with hat switch produces this flash.

I have the same "stutter flash" the first millisecond in zooming!

(Win10-64, P3D v4.1, ChasePlane last Beta 0.4)

ChasePlane1.JPG

Share this post


Link to post
Share on other sites

Check that you don't have anything assigned to those buttons in the P3D controls.

Share this post


Link to post
Share on other sites

 

On 11/18/2017 at 1:00 PM, Raller said:

I have the same "stutter flash" the first millisecond in zooming!

(Win10-64, P3D v4.1, ChasePlane last Beta 0.4)

ChasePlane1.JPG

This is exactly my case. I have the controls as same as the image. However, the stutters flash are always there and I don't know how to solve it. I haven't got any extra controls assigned neither in P3D V4 neither FSUIPC control assignments. It's really weird and irritates me.

Any possible help?

Share this post


Link to post
Share on other sites

2uqdd80.jpg

In addition, this window appears everytime I close CP. Is it normal? Does it happen to other users? Thanks for everything.

Share this post


Link to post
Share on other sites
3 hours ago, samgamyi24 said:

 

This is exactly my case. I have the controls as same as the image. However, the stutters flash are always there and I don't know how to solve it. I haven't got any extra controls assigned neither in P3D V4 neither FSUIPC control assignments. It's really weird and irritates me.

Any possible help?

Both or you with this issue, can you provide a video of the issue?

Share this post


Link to post
Share on other sites
Posted (edited)

There you have the issue in a little video Keven 😉 https://youtu.be/xMZCzQZHQpY

PS: I have deactivated all the stuff you mentioned before (the hat switch key and revised the key mappings in FSUIPC and P3D V4 itself). In addition, I have enabled the advance mode as it is the unique mode who provokes this issue.

PS 2: Before this problem, I used to leave Chase Plane default (with advanced features ON)

Edited by samgamyi24

Share this post


Link to post
Share on other sites

Do you have Game Mode enabled for P3D? If so, does disabling it fix the issue?

Share this post


Link to post
Share on other sites

I confirm that game mode is deactivated on my PC. It could be the graphics card? I have the GTX 1050 TI 

Share this post


Link to post
Share on other sites

Hi,

Does disabling the "Inject movements direct to memory" in Preferences > Camera and let me know if it fixes the stutters

Regards,
Keven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now