usairways56

CPU Time Jumping & Stutters

Recommended Posts

Hey everyone, I've been flying XP10 and 11 for a few months now. My specs are in my signature. I am running the plugin called XP11 Settings Tool so that I can take out things I dont care about like car traffic for better performance.

I get great FPS in XP especially with the plugin, which cuts my CPU and GPU times about in half as opposed to normal settings just based on the XP sliders. But my CPU time spikes every few seconds which I have read is related to loading scenery. It will rest around .12 +/- a couple hundredths, but as soon as I move like on a takeoff roll, it will jump up regularly about .05-.06 roughly and causes a noticeable stutter. This happens in all planes and at all locations, default and payware. I have made sure to also change graphics settings so that GPU closely mimics CPU time in most situations.

Lowering my Number of World Objects slider does not change the jumping, and neither did uninstalling the plugin (in fact it got worse).

Does anyone have any initial thoughts as to how to reduce the CPU time jumping? Thanks in advance

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If it happens every few seconds, I doubt it's related to scenery loading. Go to settings, then "Data Output", and check the "Data Graph Window" (second column) for the "Frame rate" entry (first row).

Then, when running X-Plane, you can select the menu "Developer"->"Show Data Output Graph" and you'll have a real time graph showing your FPS.

At this point, to track down the source of the stutters, you could start by setting ALL graphics options to minimum and then fly around a little and see if the FPS is smooth or if there are the stutters you're experienced. Then you could try raising the graphic options one by one, one step at a time, and repeat the experiment to see if there's some specific setting that produces those stutters.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

In addition to Murmur's good advice above, I'd suggest deleting this file:

/Output/preferences/X-Plane.prf

X-Plane will rebuild it with default settings the next time you launch the program. It won't change your controller settings, that's in another file. Then try sneaking up on settings starting with the minimum, as suggested above. 

P.S. my personal view is that it's better to use the built-in settings menu instead of a plugin like XP11 Settings Tool that targets individual settings "under the hood." I know it's tempting to isolate one thing like number of cars that you may not care about. But the new XP11 settings menu is intended to link features in a way that optimizes frame rate, while avoiding interactions that aren't easy to understand for the end-user, and that harm the frame rate. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Honestly, the advanced settings tool from the org, is a hit or miss, when it comes to improving performance.  Sticking with the core settings in XP, and adjusting those, should net the user the performance they're after.  My rig is a laptop, with hardware not too far off from the OP and I actually have to FORCE my sim to give me bad frames, meaning that If I adjust settings like reflections or objects max, shadows on scenery ticked, things like that, then my frames go down, but otherwise, maintaining conservative settings, nets me acceptable frames.

suspect (and I'm not pointing fingers or assuming) that many people migrating from FSX, tend to believe that with their copious RAM and beefy gpus, that XP will be a complete departure from FSX, when setting the sim at high settings, but that isn't always going to be the case.  While XP did improve my sim experience, from the heady days of P3D and FSX, I still have to maintain a reasonable level of visuals, in order to hit a reasonable performance target.  There are no magic bullets for XP, nor is there hard data that everyone can set their watch by (i.e. config tweaks), so the simplification of the UI settings menu was a "middle of the road" approach by LR, to create an average performance tweak, in of itself.

There are some aspects of the visuals that I would love to see more of, and whether that happens or not, it's not a deal breaker for continual use of a great sim.  Everyone's tastes are different when it comes to what they want to see, how they want the sim to perform, or what specific aspect of the simulator will satisfy their need.  Using these "snake oil" plugins can be more trouble than their worth, as opposed to good old fashioned knowledge gained from documentation, other users, developers, etc.

12 hours ago, usairways56 said:

Lowering my Number of World Objects slider does not change the jumping, and neither did uninstalling the plugin (in fact it got worse).

Of course.  When you "uninstalled" the plugin, did you get rid of the subsequent Lua script too?

It would also help if the OP indicated whether they are using all default scenery, or if they have custom airports, custom ortho, World2XP, etc. installed, which can make a difference on performance as well.  3rd party aircraft vs. default can have an effect too.  Basically, several other variables can be in play here, so another great way to troubleshoot is to load up XP with all default everything and then run a test flight to measure performance.

Share this post


Link to post
Share on other sites

Thanks for the replies everyone. I did delete the settings file, as well as completely removed FlywithLUA, then started at a default airport, default plane, with sliders all to the left.

I worked the settings all back up to what I had previously, then even higher too, with it being smooth as silk and to my liking in fps. Then I started testing each addon plane at default airports, then finally at payware ones. I found it still perfectly smooth with great fps.

Finally I reenabled my orthophotos, and there we go - those stutters came back, though somewhat diminished. So I found the culprit. I can live without the orthophotos, but dang those really made flying look amazing near the airports. 

Thanks for your help again everyone. I get so caught up in tweaking as a former FSXer, that sometimes it takes a fresh perspective to get things back running well

Share this post


Link to post
Share on other sites

Maybe there's some other thing you can do to eliminate stutters even with orthophotos. What Zoom Level are you using for Orthophotos? Is hyperthreading activated on your CPU? Is "threaded optimization" ON or OFF in nvidia control panel? Have you tried experimenting with orthophotos starting from minimum rendering settings and going up?

 

Share this post


Link to post
Share on other sites
57 minutes ago, Murmur said:

Maybe there's some other thing you can do to eliminate stutters even with orthophotos. What Zoom Level are you using for Orthophotos? Is hyperthreading activated on your CPU? Is "threaded optimization" ON or OFF in nvidia control panel? Have you tried experimenting with orthophotos starting from minimum rendering settings and going up?

 

Hopefully there is, I'll have to test things out further. From memory, I think the base level was ZL15, and I increased it in the immediate vicinity of airports - though stutters remain regardless of what ZL I'm flying over.

No hyperthreading on my computer with it being an i5, and yes threaded optimization is OFF. 

I haven't tried starting from scratch with orthophotos on, but now that I know they're part of the issue I can try that soon. I could very well be wrong but a hunch of mine is that maybe the 6gb of VRAM is being stretched

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now