sfgiants13

Jumpy FPS in V4

Recommended Posts

Has anyone noticed that with vsync on the FPS are quite jumpy compared to V3?  Before it would stay within a frame or two and be smooth, but in V4 it can jump around as much as 5 FPS in either direction and causes stutters when it does that.  But, when I lock it at 25 FPS (my monitor refresh rate), if it can hold 25 FPS it is pinned at exactly 25 the entire time.  In big cities with addon airports it does tend to drop but I'm still playing with my settings to try to have it pegged at 25 even in the most demanding situations.

 

I'm still trying to get it perfectly smooth but since most of my addons aren't compatible yet I've got plenty of time to tinker with it.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Same issue stutters and slide within 5 min i dont wth is going.on

Ran same.settings in v3.4 and.ran smooth as butter 30htz 4k

Vsync on tripple bufferon unlimited fps

Am 116

 

On a high end system

Share this post


Link to post

What anti-aliasing are you running?  I had to drop down to 2xSSAA on my 980 Ti... 4x or 8x was too much - that level of SSAA cut fps almost in half and led to stutters.  V4 is very demanding on the GPU and especially video memory.  The good news is that even 2xSSAA plus FXAA ON looks much better than the highest anti-aliasing settings on v3.

Also, Speedtrees and terrain and vegetation shadows are big performance drags as well.  And I tested other affinity mask settings and they are not necessary - the default seems much more effective in managing threads on a multi-core system.

 

Share this post


Link to post

I was using 4x SSAA which put my GPU at 100% usage which would explain the stutters.  4x eliminates about all of the shimmering and I thought my 1060 could handle it but I was wrong.  I'm also using a 4k monitor.  By dialing it down to 2k and cutting some traffic, shadows, and water detail I was able to bring down the GPU usage to where it had less stuttering but it's not quite there.  What are some GPU intensive settings I could drop further?  2x just has too much shimmering for me but I may not have a choice.

Share this post


Link to post
17 minutes ago, sfgiants13 said:

I was using 4x SSAA which put my GPU at 100% usage which would explain the stutters.  4x eliminates about all of the shimmering and I thought my 1060 could handle it but I was wrong.  I'm also using a 4k monitor.  By dialing it down to 2k and cutting some traffic, shadows, and water detail I was able to bring down the GPU usage to where it had less stuttering but it's not quite there.  What are some GPU intensive settings I could drop further?  2x just has too much shimmering for me but I may not have a choice.

You might want to try 4x MSAA or 8x MSAA. Works very well on my sim. The results are almost same.

Share this post


Link to post

Same problem, mini stutters no matter what settings.

Share this post


Link to post

Same issue also. Really disappointed. In V3 I refresh at 30Hz, vsync on, frames unlimited. This gives me a very smooth stutter free flight. Frame rate barely nudges of 30.

With these settings the stuttering on V4 is dreadful. As Warbirds said lowering the settings does not resolve this. My frame rate counter can go down to 20 and up to 40. Locking the frame rate at 30 helps but it is still not as smooth as  V3. My GPU is just idling along as is the CPU. 

6700K @ 4.7, 32GB Ram, 1080ti.

I would like to think there is a solution for this.

Share this post


Link to post

Try changing your refresh rate in  Nvidia control panel. I tried everything and nothing worked so I started to think it might have something to do with refresh rate. I changed mine from 60 to 59 and it really helped with the stutters. 

Share this post


Link to post
9 hours ago, Harvgordon said:

You might want to try 4x MSAA or 8x MSAA. Works very well on my sim. The results are almost same.

I get the same performance issues on 8x and 4x MSAA while it helps with the stutters the shimmering is as bad as V3.  2x SSAA is similar.  I'll keep trying to find a balance in the settings.  If not, I'll have to live with the shimmering until I can get a better video card.

Share this post


Link to post

There's no reason to run Vsync unless your FPS is higher than your refresh rate.  There's no reason to lower refresh rate to match FPS either.  Most people have 60Hz refresh rates and < 60 FPS.  Just leave Vsync off.  Problem solved.  

Share this post


Link to post

Sure, I have had Vsnyc on and off and a hundred other settings but in the end setting the global refresh rate to 59 solved my stutters. Confused why so many of you are reluctant to try it as it is very simple to do and might help you. 

Share this post


Link to post
2 minutes ago, warbirds said:

Sure, I have had Vsnyc on and off and a hundred other settings but in the end setting the global refresh rate to 59 solved my stutters. Confused why so many of you are reluctant to try it as it is very simple to do and might help you. 

Frame time is determined by the rendering engine, it is a byproduct of processing, not display.  All your monitor does is show the picture the computer feeds it.  Lowering refresh rate from 60 to 59 will not solve long frame times aka micro-stutter.  What you observe is either placebo or you've made additional changes and are attributing the results to the wrong variable.  

Share this post


Link to post
10 hours ago, sfgiants13 said:

I was using 4x SSAA which put my GPU at 100% usage which would explain the stutters.  4x eliminates about all of the shimmering and I thought my 1060 could handle it but I was wrong.  I'm also using a 4k monitor.  By dialing it down to 2k and cutting some traffic, shadows, and water detail I was able to bring down the GPU usage to where it had less stuttering but it's not quite there.  What are some GPU intensive settings I could drop further?  2x just has too much shimmering for me but I may not have a choice.

The Speedtrees are huge performance drags, and IMO frankly not very attractive either.  I had low fps and stuttering on one flight, and I hadn't realized that the settings profile that I had loaded still had the dynamic tress to ON - as soon as I turned them off everything smoothed out.

If you don't like the 2xSSAA alone, you can also try setting FXAA to ON for additional AA smoothing - does not appear to have a performance hit.

Having said all that, I can still get occasional stutters here and there - but light-years better than v3.  I should also say I have a 144Hz G-Sync monitor, which I am sure affects what is going on for me.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now