Recommended Posts

My system recently updated to the Windows 10 creators update. Since then, I have received an error, starting FSX, stating that Flight Simulator has detected a problem with a third-party software program, identified as fsinsider.dll. It crashes if I allow it to run, but MCE won't run without it. I did try uninstall/reinstall for Multi Crew, as well as updating to the most recent version, but that has not fixed the issue. I am running Windows 10 Home with FSX SP2. Any ideas on how to get MCE to work in spite of this? Thank you.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Curlyhair, 

Check this post of mine (second reply in topic), maybe that will help? 

Stuart

Share this post


Link to post
Share on other sites

Hi CurlyHair,

  This is not going to be a great deal of help, but yesterday i downloaded the latest MCE and ended up getting the FS insider.DLL crash. I had MCE set to run automatically with FSX so was in a continuous loop....Events viewer identified FSinsider.dll as the culprit. What i did was 'force the issue' by that i mean i would get a box displayed saying something like, FSInsider.DLL is not compatible do you still want to run recommend no" but clicked yes...crashed...restarted computer and ran FSX again and low and behold, they are best of friends now. I have Windows 10, and problem was resolved without drastic intervention. As i say, not very helpful, but the two can co exist.

    Good Luck.

Share this post


Link to post
Share on other sites

Hi Jimble,

Yeah, that pretty much sounds like what I'm going through. I have tried restarting several times, as I've tried a few different things. Thanks.

Share this post


Link to post
Share on other sites
7 hours ago, curlyhair_js said:

Hi Jimble,

Yeah, that pretty much sounds like what I'm going through. I have tried restarting several times, as I've tried a few different things. Thanks.

Keep restarting isn't the solution. Nor is re-installing anything.

This is now understood as a Windows 8 or 10 quirk. You won't see it happen in Windows 7 for instance.

This indicates some of your add-ons isn't shutting down FSX or P3D correctly on exit (not freeing resources or something like that).

As a result, Windows randomly flags up a dll (maybe last loaded), and reminds itself not to load it next time the program starts, out of precaution.

It's important to realize it will eventually flag any dll. Today it's fsInsider.dll, tomorrow, could be FSUIPC.dll, another day, it's a different dll.

Better know about it now. Because you could be scratching your head for a long time, resetting, re-installing, updating. I know we did.:laugh:

For about 4 months, we wrongly assumed something was amiss with our dll, and tried all sorts of things, like using different C++ compilers to generate the file. until Stuart discovered the FSUIPC thread mentioning the same issue with that dll.

Here is an example of another randomly affected perfectly working dll

https://forums.flightsimlabs.com/index.php?/topic/7337-fslsounddll-issue/#comment-55957

You have to run "Regedit" Windows tool. and search for the dll name it flagged. In this case fsInsider.dll

There will be a couple of lines with the keyword to delete. No more. And they aren't critical registry entries either.

Restart FSX, get the prompt and tell it to go -ahead. No more crash.

Suggest you find out what's causing your simulator not to shutdown properly as this is the root cause, and the issue will eventually randomly come back.

 

Share this post


Link to post
Share on other sites

Just reiterate, if FSX does not close properly this error can occur for any dll not unloaded by Windows10. To resolve do the following:

1) start regedit
2) goto key HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
3) delete the key "C:\\Games\\FSX\\fsx.exe"="$~ RUNASADMIN IgnoreFreeLibrary<FSINSIDER.dll>"
4) if you would like to run FSX as an administrator you need to activate that again as you removed that in step 3

It means that freelibrary calls are ignored (calls used to unload a DLL, known as module in FSX). This probably means that one of those calls somehow failed once and the key was added by the MS compatibility 'service' as a service to you...

When you then restart FSX, just accept YES to continue when the error occurs and everything will be ok again..... until the next time FSX crashes or fails to close properly, in which case repeat the above. 

Stuart

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Guys,

Sorry I'm incapable of following instructions, Stuart :biggrin:. I miscounted before when you had said the second reply. It seems to be up and working. Thank you for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now