Sign in to follow this  
flyfed

Changing View w/Saitek Yoke Randomly Increases v4 Sim Rate

Recommended Posts

I have a couple of the switches on my Saitek Pro Yoke set to move through some of the views. Doing so randomly causes P3D v4 to randomly increase the sim rate. This is with the PMDG NGX (current version). I haven't tested this with other aircraft yet, but was wondering if anyone else has this issue, or better yet, knows how to lock the rate at "Normal."

Other stuff: Checked all key bindings in the sim, FSUIPC (v5 and paid), and SPADNext. I'm Using SPAD to integrate a Saitek switch and a multi panel with NO Saitek drivers installed.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Tried a flight with the Carenado CT210M and a generic FSUIPC profile in SPADNext and things were fine. So this could be a bad NGX profile from SPAD, even tho' it had 5 stars. Meanwhile, I'd still like to know if there's a way to disable the sim rate in P3D v4.

Share this post


Link to post

In your p3d control assignments is sim rate assigned to keys you also use for others?

Share this post


Link to post

No. It's one of the first things I checked. Thanks for asking, though.

Share this post


Link to post

this is spad problem.i changed my NGX profile and it went away.

 

 steve :-)

 

Share this post


Link to post

I've come to the same conclusion, Steve. My project for today is making my own profile that solves another SPAD related issue as well. Did you make your own profile or did you use one of the ones available within SPADNext? if the latter, which one?

Share this post


Link to post

for the NGX i use Michael Allens Pmdg737NGX walker605 profile,made on 24/07/17.so far i haven't had any issues with it.

i'm using FSUIPC with simconnect..hardware is a switch panel with a saitek yoke and throttle plus an extra throttle.seems to work ok.

   steve

 

Share this post


Link to post

I just finished altering the Basic FSUIPC to work with my Saitek Pro Yoke, Switch Panel, Multi Panel and an external 737quadrant with the PMDG 737NG for v4. No random rate increases so far, tho' I'll have to give it a longer run tonight to confirm. The last long flight, I was halfway from KSFO to KLAS when switching a view suddenly shot the rate up to 16x and the frames down to 1.7. By the time I got it settled down, I was past Long Beach.

Although mine will probably solve my issue, I'm always open to alternatives and will give the one you suggested a go. Thanks for the suggestion.

Share this post


Link to post

Thanks for the tip on Michael Allen's profile. Mine's OK, but his is the better by far. Much better than the 5-star one in the on-line profiles.

A bad SPADNext profile seems to be responsible for the random rate changes I was getting, and they're gone now, so no real need to lock it at normal. This issue can be closed.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this