theskyisthelimit

Enable Add-on prompt for add-on.xmls that were moved then put back? Suppress prompt?

Recommended Posts

In testing load time issues with my install.. i decided to move most of my folders from the my docs addons folder out.. test.. then move them back in..

As a result.. now i'm being prompted for every single one of my entries and there are tons..

Is there any way to avoid this or auto accept yes?  This occurred in p3dv4 for reference.. im guessing these were in the add-on.cfg in progdata originally.. but once removed they got removed, unsure

 

Thanks in advance

Edit:  I use the lorby tool. Maybe just re running it might fix this automatically. 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi,

In stead of moving your add-on folders you can enable/disable your add-ons in the %PROGRAMDATA%\Lockheed Martin\Prepar3D v4\add-ons.cfg file by setting the Active property for the package to True/False.

Maarten

Share this post


Link to post
13 minutes ago, mawibo said:

Hi,

In stead of moving your add-on folders you can enable/disable your add-ons in the %PROGRAMDATA%\Lockheed Martin\Prepar3D v4\add-ons.cfg file by setting the Active property for the package to True/False.

Maarten

Ah ok.. the odd thing is.. maybe due to the lorby tool.. unsure.. but previously even, i only had like 4 entries in this file, despite having 100+ in the tool and certainly folders in the addons folder..  and thats the biggest issue.. disabling large chunks at a time to rule out scenery issues.. a little tedious by changing the property, if they all existed in there.

Share this post


Link to post

To enable/disable... it's an option in the sim's main menu... you shouldn't be modifying the .cfg files.

Share this post


Link to post
2 hours ago, theskyisthelimit said:

Ah ok.. the odd thing is.. maybe due to the lorby tool.. unsure.. but previously even, i only had like 4 entries in this file, despite having 100+ in the tool and certainly folders in the addons folder..  and thats the biggest issue.. disabling large chunks at a time to rule out scenery issues.. a little tedious by changing the property, if they all existed in there.

There is a second add-ons.cfg file in AppData\Roaming\Lockheed Martin\Prepar3d V4 that contains the packages that were discovered automatically.

In the P4AO v1.09 you can enable/disable multiple entries at the same time.

Best regards

Share this post


Link to post
1 hour ago, Lorby_SI said:

There is a second add-ons.cfg file in AppData\Roaming\Lockheed Martin\Prepar3d V4 that contains the packages that were discovered automatically.

In the P4AO v1.09 you can enable/disable multiple entries at the same time.

Best regards

Ah perfect thanks

Share this post


Link to post
2 hours ago, theskyisthelimit said:

Ah perfect thanks

Make sure to try version 1.10 too. It has a small button to count the files inside the sceneries and determine their size in MByte. That may help you to find those that take too long to load - they will either have many many files or very large ones. For example photo scenery with autogen sometimes has hundreds of thousands of individual files - all of which the simulator has to parse on startup...

Best regards

Share this post


Link to post
On 8/10/2017 at 3:31 AM, Lorby_SI said:

Make sure to try version 1.10 too. It has a small button to count the files inside the sceneries and determine their size in MByte. That may help you to find those that take too long to load - they will either have many many files or very large ones. For example photo scenery with autogen sometimes has hundreds of thousands of individual files - all of which the simulator has to parse on startup...

Best regards

Just a foot note on this.. i did some extensive testing.. When i have NO addons in the my documents addons folder.. and i turn on all of ftx + utx + FMX (lots of ftx).. my load times go from the bare bones 30sec on SSD to around 1min24sec (which isnt bad at all)..

However.. heres where it gets interesting.. if i leave the addons in my documents and use the tool to disable all the addons the time becomes 2min44 sec, about 1min24 sec and that apparently is due to the system probably parsing all the (tons) of addon files in that folder.. (load times get quite immense when these are all turned on, i forget maybe 6 mins)..

So that said.. there might actually be something to say for still using scenery.cfg instead (going to test this via the move to scenery.cfg option, disable them in there and repeat).  One thing that would be nice in the tool would be a select all option.. actually, that and an option to "move to scenery" that is on the main screen, not under individual scenery entries (this will take some time to move over)

I have simstarter.. but i doubt that simstarter will literally "remove" disabled addons in the my documents folder when turned off.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now