BrendanMan33

P3d V3 Crashing after Windows Update

Recommended Posts

For whatever reason, my simulator tonight has been ruthless to me with no near sign of why this is happening. When loading the flight, the moment I reach 100% or shortly after my sim will "stop responding" requiring me to close the application. Looking in events viewer it shows me no leads how ever In one instance it tells me that twinapi.dll was the root of the cause. 

The even stranger part is that I have done nothing to my simulator or computer and I have completed many flights between then and now with no issues. The most recent thing which I did tonight was activate the PMDG 777 which had already been installed, just not activated. It may also be noted that my bitdefender antivirus was renewed and I beleive updated to the 2018 version. But as I will mention I disabled it (I think) and still no joy.

Now I have tried every trick in the book from removing liveries, disabling antivirus, clearing my config, and many more in between. 

The only thing that I have yet to do is reset my scenery.cfg file.

Any thoughts would be greatly appreciated. Hopefully this won't ground me.

Edited by Poppet
edited Topic title to reflect Issue

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

2 hours ago, BrendanMan33 said:

For whatever reason, my simulator tonight has been ruthless to me with no near sign of why this is happening. When loading the flight, the moment I reach 100% or shortly after my sim will "stop responding" requiring me to close the application. Looking in events viewer it shows me no leads how ever In one instance it tells me that twinapi.dll was the root of the cause. 

The even stranger part is that I have done nothing to my simulator or computer and I have completed many flights between then and now with no issues. The most recent thing which I did tonight was activate the PMDG 777 which had already been installed, just not activated. It may also be noted that my bitdefender antivirus was renewed and I beleive updated to the 2018 version. But as I will mention I disabled it (I think) and still no joy.

Now I have tried every trick in the book from removing liveries, disabling antivirus, clearing my config, and many more in between. 

The only thing that I have yet to do is reset my scenery.cfg file.

Any thoughts would be greatly appreciated. Hopefully this won't ground me.

Search the forums for issues caused by the latest Windows 10 Patch/Update (KB4038788). Many users of P3D v3 & v4 have had issues since this latest update and have de-installed it. Maybe your PC performed the update without you noticing.

Share this post


Link to post
Share on other sites
3 hours ago, Peter Webber said:

Search the forums for issues caused by the latest Windows 10 Patch/Update (KB4038788). Many users of P3D v3 & v4 have had issues since this latest update and have de-installed it. Maybe your PC performed the update without you noticing.

Thank you very much! It tottally spaced my mind that I did in fact run an update

Share this post


Link to post
Share on other sites

Hello Brendan 

Topic moved to the Crash to Desktop forums  (CTD)

Please reference the Topic below for more Information 

Topic Locked 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.