ScotFlieger

P3Dv4.1 Compatibility

Recommended Posts

For users considering P3Dv4.1, I can confirm that LINDA 3.0.3 is compatible when used with FSUIPC 5.121b and compatible aircraft.

A2A C172 and C182 owners should note that there is an issue with the steering tiller not working on the ground. Other aircraft tested (ie. default B58 and F35A and PMDG737NGX) work fine.

Please report any issues with LINDA here.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Are you using EzDoc? The reported problems have been recognised by LM and affect A2A and EzDoc Addons. 

Share this post


Link to post
Share on other sites

A2A has issued a 'physics' fix for their aircraft via their support forum. This fixes the nose steering issue with my A182 and C172.

Edited by ScotFlieger
added A2A forum link

Share this post


Link to post
Share on other sites

Hello,

I also encountered two strange problems with Linda and P3DV4:

1. Linda does not start correctly. It seems to start with the sim, in the sim there are several notes that Linda needs to restart and finally it states, that all is correct. But it is not startet. I have to start it again with the sim running and in addition have to click the icon a second time. Than all is o.k.

2. Multiple-Shift-Functions dont work correctly. Sometimes they work, sometimes not.

Any help and advice is appreciatet. Thank's in advance and excuse my bad English.

Michael

Share this post


Link to post
Share on other sites

Hi Michael

Welcome to LINDA. When the Flt Sim starts LINDA will initialise with the prompts LINDA Restarting followed by LINDA Ready in the top line of your Sim screen. For new installations, you need to click on Sync to Sim so aircraft name is outlined in orange for LINDA to communicate with your Flt Sim. Are you starting with a default aircraft or another? There may be an issue when loading a Scenario but I have yet to pin it down.

For the Shift Functions to work correctly, you need to ensure that the SHIFT functions are assigned to unshifted, shifted one and shifted two. If you use LOCAL SHIFT it only applies to the device/joystick it is selected on. GLOBAL SHIFT applies to all devices/joysticks. 

If your problems persist, please follow the Fault Diagnosis thread procedure under LINDA Support and send me your logs.

 

Share this post


Link to post
Share on other sites

Okay, I have been looking all over for the answer to this question, so I will just post it here.

I am a long time Linda user on Linda with FSX. I just purchased and installed P3Dv4.1 and FSUIPC5.
Can I use/copy my Linda assignments from FSX straight in to P3Dv4, or do I have to configure all my assignments from scratch?

Any constructive response will be highly appreciated. 

Share this post


Link to post
Share on other sites

Hi Manfred

There are no changes between FSX and P3D 32 or 64 bit LINDA operation and configuration. LINDA 3.x will detect which version you are using.

After installing FSUIPC5 5.122 (new registration) and the latest version of LINDA 3.0.4 into your P3Dv4.1 modules folder, you can copy your existing setup from FSX to P3Dv4.1. You need to copy the existing /linda/aircrafts/ and /linda-cfg/aircrafts/ to the new location.

Remember that not all aircraft have P3Dv4 compatible versions but the LINDA modules can be copied and will just sit there unused.

Share this post


Link to post
Share on other sites

Thank you Andrew,

That saves me a lot of work. I will go ahead and copy the modules over. 

Share this post


Link to post
Share on other sites

Hi Everybody,

I have just  installed the latest versions of P3D v4, Linda, FSUIPC and Saitek Drivers. The simulation is running very well, except for Linda. When I start Linda, it connects to P3D and chooses the correct aircraft. With an older version I have created or downloaded aircraft cfg files for A2A 172, 182, Real Air and some others. The input devices (joystick, switch panel etc) are recognised by Linda, and the standard input of the devices is transferred correctly to P3D. Unfortunately everything what I have assigned via Linda from my aircarft config files is not ending up in P3D. For example the beacon is turned on, if I use the corresponding button from the switch panel. But when I programme the NAV light function (either A2A or FSX) to the beacon button, then it still turns on the beacon and not the Nav light. What can I do to get the functions working, which I programme via Linda?

Kind regards,

Karsten

Share this post


Link to post
Share on other sites

Hi Karsten

What version of LINDA and FSUIPC5 are you using? On the Joystick page what colour are the assignments? Green is the default configuration which applies to all aircraft. Aircraft specific assignments are Black and override any default settings. You also need to click of Sync FSX/Sync to Sim (aircraft outlined in orange) to ensure buttons work.

Share this post


Link to post
Share on other sites

Hi Andrew,

I am using Linda 3.04.728 and FSUIPC 5.122. Linda starts without any problems, directly finds my plane and circles it in orange. On the P3D page it says Linda ready to go. The aircraft specific assignments are all in black. So the connection between Linda and P3D seems to work.

But when it comes to actually sending buttons nothing at all happens. The device (e.g. Saitek switch panel) behaves as if Linda would not be there at all. As I said, when I hit the beacon button then the beacon turns on. When I programme the beacon button with another assignment, then the beacon still turns on. Whatever assignment I am using, nothing happens, does not matter, if it is airplane specific or plain fsx assignments.

Share this post


Link to post
Share on other sites

I use the Saitek Switch Panel so I know it works. However, it requires a special set up. You are correct that when it is setup correctly the switch line in Joysticks should be highlighted when the switch is moved to the ON position.

For it to work with LINDA you need to ensure you are not using any Saitek software like Spad. Next go to Setup LINDA page and tick Saitek Panels checkbox. The go to Setup Joysticks page and enable the Switch Panel and disable the Radio and Multi Panels (if you have them).

The next thing to note is that the switch panel switches are 2 position. This means you need the ON function assigned to OnPress and the OFF function assigned to OnRelease. Using your example, my A182 Switch Panel setup is as below:

LINDA setup for Saitek Panel for A182

Share this post


Link to post
Share on other sites

Ok, after deactivating the Multi and the Radio Panel it works better now. It is not at 100 pct, but I will keep trying to improve. Thanks a lot for your help.

Share this post


Link to post
Share on other sites

Good news. The LINDA Saitek Radio and Multi Panel implementations are hard-coded at present. The default functions may not work with more sophisticated aircraft. I find the Radio works with most but the Multi panel may not. The Switch Panel is fully user programmable with LINDA functions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now