Sign in to follow this  
YoYo

G-sync and Fall Creators Update Windows 10 (P3Dv4.1)

Recommended Posts

I had Windows 10 update (3-4 November "Fall Creators Update") and after this G-sync stopped to work in myPrepar3D v4.1 (full screen, only on windowed mode it works).

I reinstalled drivers, did clean install of 388.13 drivers (now) and the same. On FULL SCREEN G-sync dosen't work here.

Tested few options - it works now in windowed mode only. Not at Full screen.

Did You notice the same issues after this big update of W10 (if You are user of G-sync monitor)?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

It has been stated on AVSIM and many other places that P3D 4.x NEVER runs full Screen, it is always windowed even though there is a selection under view tab for full screen. G-Sync will only work with P3D using G-Sync windowed mode.

I have an ASUS P279Q, 27", 1440p, G-Sync monitor, and I have G-Sync set to full screen and windowed mode and it works great.

Share this post


Link to post

It works before for me, but with windowed mode (P3Dv4) I see frames (alt+enter), this is not a good solution.... :(

 

It looks really poor as "window", not for me:

uRarKntl.jpg

in this situation G-sync works, with alt+enter (full screen) not

 

Share this post


Link to post

Check in the Nvidia Control Panel that "Enable G-SYNC for windowed and full screen mode" is ticked.

I have not had any problems with G-SYNC either before or after the Fall Creators Update.

Share this post


Link to post
13 minutes ago, kmagelie said:

Check in the Nvidia Control Panel that "Enable G-SYNC for windowed and full screen mode" is ticked.

I have not had any problems with G-SYNC either before or after the Fall Creators Update.

Do You have drivers 388.13 of GeForce?

Maybe the problem is here. For sure I have ticked + the same in NVidia Inspector.

 

Do You have Academic version?

Share this post


Link to post

Btw.

checked 388.00 the same so this Windows update do something with this.

I found interesting post from here: 

Will try Tomorrow.

Share this post


Link to post
10 hours ago, YoYo said:

Do You have drivers 388.13 of GeForce?

Maybe the problem is here. For sure I have ticked + the same in NVidia Inspector.

 

Do You have Academic version?

I'm using 387.92 at the moment, and I have the Pro version, but that should not have anything to do with it.

Share this post


Link to post
9 hours ago, YoYo said:

Btw.

checked 388.00 the same so this Windows update do something with this.

I found interesting post from here: 

Will try Tomorrow.

Tested:

H5iouIwt.jpg

No, it dosen't helps, it's a case of new kind of stutter, nothing more.

 

 

Share this post


Link to post

Hi,
I checked also drivers: 387.92, 388.00 and 388.13.
The problem with G-sync after this W10 FCU update is present still.
So looks like the problem is driver together with Fall Creators Update of Windows 10.

Before this  Fall Creators Update Windows 10 udpate G-sync works fine here!

I did video to show it.
The problem is full screen now and only. 
Refresh rate of monitor is set to 60Hz so max FPS with G-sync on must be 60 (the same like with V-sync, here is off for sure). It works if the title is in windowed mode (what is not acceptable, looks very odd and badly simply!). In this situation G-sync works and no screen tearing. If I change a mode for full screen (Alt+Enter here) G-sync stops work. I see screen tearing, annoying micro stutters and FPS without limit of Hz of refresh rate of monitor. In GeForce panel G-sync is ON as Full screen + windowed. I check also others options with the same result.

https://youtu.be/qTiB4xoUVj8


 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this