ryebred2

Learjet Nav not capturing GTN 750 course

20 posts in this topic

I just purchased the Learjet and tried to take a couple flights with her. I ran into an issue in that the Nav button on the autopilot goes into Arm mode but never captures the GTN 750 course even when flying right on top of the magenta line. The Nav mode is set to GPS and I tried changing it to Nav/Vloc to see if that made any difference but it did not. I had to steer the plan using the heading hold to manually follow the line. The HSI course pointer did switch to the appropriate course heading at each waypoint but it didn't have the horizontal deviation bar at all; just showed I was centered on course no matter if I was or not. The vertical navigation part of the autopilot worked just fine.

 

This is installed on Prepar3D v4.1 on Windows 10 and I have the latest 3.0 version of the Lear. I tried watching some videos of people navigating the Lear with the GTN 750 but they simply selected Nav mode and it capture the course for them. Not sure why mine is not behaving the same way. I tried deleting it and reinstalling to see if that made a difference and it did not.

 

Thanks for the help.

0

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I didn't touch the default settings on the GTN for this plane. I just looked in the GTN configuration tool and the 750 Autopilot is set to Nav and the Radios are Com1/Nav1. One thing I didn't try is using the cockpit with dual GTN's to see if that makes any difference.

0

Share this post


Link to post
Share on other sites

What does your F1GTN.ini file look like? It's in your Learjet folder? It should look similar to this if running 1 GTN750:

[GTN750.1]
Radios=0
Autopilot=1
Mouse=1
Link CRS=1
Auto CRS=1
Fuel=1
Sound=1
Invert Mouse Wheel=0
Active Mouse=1
CPU Core=0
Play Click=1
Airplane=4

0

Share this post


Link to post
Share on other sites

I have all 4 possible GTN's listed in that file. Below is the full contents....

[GTN750.1]
Radios=0
Autopilot=1
Mouse=1
Link CRS=1
Auto CRS=1
Fuel=1
Sound=1
Invert Mouse Wheel=0
Active Mouse=1
CPU Core=0
Play Click=1
Airplane=4
TAWS Voice=1
AVDB=0
Unit Type=1
VC Brightness=6
Color Airplane=0
VFR Code=1200
Fuel Type=0
[GTN750.2]
Radios=1
Autopilot=1
Mouse=1
Link CRS=1
Auto CRS=1
Fuel=1
Sound=1
Invert Mouse Wheel=0
Active Mouse=1
CPU Core=0
Play Click=1
Unit Type=1
VC Brightness=6
Airplane=0
Color Airplane=0
TAWS Voice=2
AVDB=0
VFR Code=1200
Fuel Type=0
[GTN650.1]
Radios=1
Autopilot=1
Mouse=1
Link CRS=1
Auto CRS=1
Fuel=1
Sound=0
Invert Mouse Wheel=0
Active Mouse=1
CPU Core=0
Play Click=1
Unit Type=2
VC Brightness=6
Airplane=0
Color Airplane=0
TAWS Voice=0
AVDB=0
VFR Code=1200
Fuel Type=0
[GTN650.2]
Radios=1
Autopilot=1
Mouse=1
Link CRS=1
Auto CRS=1
Fuel=1
Sound=0
Invert Mouse Wheel=0
Active Mouse=1
CPU Core=0
Play Click=1
Unit Type=2
VC Brightness=6
Airplane=0
Color Airplane=0
TAWS Voice=0
AVDB=0
VFR Code=1200
Fuel Type=0

0

Share this post


Link to post
Share on other sites

Ryebred2,

Does the GTN750 Nav work with any of your other aircraft?

Al

0

Share this post


Link to post
Share on other sites

Try it with just this:

[GTN750.1]
Radios=0
Autopilot=1
Mouse=1
Link CRS=1
Auto CRS=1
Fuel=1
Sound=1
Invert Mouse Wheel=0
Active Mouse=1
CPU Core=0
Play Click=1
Airplane=4

And make sure the AP switch on the lower panel is set to on?

Martin

0

Share this post


Link to post
Share on other sites

I tried what you posted but it still didn't work. I am attaching a screenshot so you can see what it looks like.

 

Just to verify that my GTN was not broken somehow, I loaded up my A2A and Carenado planes that use the GTN 750 also and was able to follow a flight plan and shoot an ILS approach with them.

zSYS4k.jpg

0

Share this post


Link to post
Share on other sites

The HDG should turn off and the NAV CAP change to NAV, try turning off the HDG and reset the Nav by turning it off then on again. You might want to send Mark an e-mail telling him what the issue is? From the picture it looks like you have things setup right, GPS, AP, CDI working. I'm not using 4.1 so something might of changed from earlier versions of P3D.

0

Share this post


Link to post
Share on other sites

Ryebred2,

Put your mouse cursor on the GTN's blue memory card in the upper left corner of the GTN box and make sure the tool tip says the Nav source is GTN 750 Gauge Unit 1, and not GTN 750 Gauge Unit 2 or Flight Simulator GPS (which is the sim's default GPS unit). If you had more than one GTN750/650 installed, this is how you could switch the Nav source between the different GPS units.

(Ref: Pg 16 of the Flight1 GTN Series User's Guide).

Al

0

Share this post


Link to post
Share on other sites

The tool tip says "Active navigation source: GTN750 UNIT 1 (Right click to change)."

 

I uninstalled and reinstalled the learjet but this time I selected the dual GTN cockpit. I right clicked to change the active nav source to the GTN750 Unit 2 and the autopilot Nav was still stuck in Arm. I also tried switching back and forth between nav and gps mode and also disabling heading hold and just enabling nav. Didn't work.

 

I did try an ILS approach and that worked fine. Presumably because it was in VLOC/NAV mode and not GPS mode. I also tried flying the plane with the GNS 530 GPS and the Nav mode worked on that. Maybe I will try reinstalling the GNS750

0

Share this post


Link to post
Share on other sites
9 hours ago, ryebred2 said:

I uninstalled and reinstalled the learjet but this time I selected the dual GTN cockpit. I right clicked to change the active nav source to the GTN750 Unit 2 and the autopilot Nav was still stuck in Arm. I also tried switching back and forth between nav and gps mode and also disabling heading hold and just enabling nav. Didn't work.

Ryebred2,

What version of the GTN750 are you using, and what version of the GTN Configuration tool?

Another thing we can check is the GTN entry in the panel.cfg file.   Using a text editor like Notepad, open the panel.cfg file which is inside the panel.RDR_GTN folder inside your Lear35 directory.  At the top of the file there is a  [Window Titles] section which should have a GTN entry similar to this:

[Window Titles]
Window00=CONTROL_PANEL
Window01=AIRCRAFT_OPTIONS

Window02=Flight1 Garmin GTN750 U1
Window03=WX Advantage Radar
Window04=START_INSTRUCTIONS
Window05=DOOR_INSTRUCTIONS
Window06=PAYLOAD_MANAGER
Window07=WIND_GAUGE
Window08=TEST_PANEL

And then further down the panel.cfg file there should be a corresponding window entry like this

[Window02]
Background_color=0,0,0
size_mm=937,887
VISIBLE=0
ident=14401
window_pos= 0.310, 0.160
window_size= 0.340, 0.580
zorder=99
gauge00=F1GTN!GTN750,  0,0,937,887,UNIT1.POP

These entries are set up by the GTN Configuration tool, which is why I asked what version of the tool you are using. There have been issues where the window entry has been corrupted, and Flight1 has updated the Configuration tool a number of times over the past year or so.

Al

0

Share this post


Link to post
Share on other sites
10 hours ago, ryebred2 said:

Maybe I will try reinstalling the GNS750

If you do decide to try reinstalling the GTN750, I would first uninstall your current GTN750 setup to help make sure all files are updated on the reinstall.

Al

0

Share this post


Link to post
Share on other sites

Reybred2.

If you are still having problems, suggest you read through this thread on the Fligh1 F1 GTN/GNS Series Support Forum at  http://www.simforums.com/forums/gtn-complete-v2-04_topic59024.html.

It seems a number of folks are having some problems similar to yours with the GTN750 and P3Dv4.1 with a variety of different a/c.  Some things to try are suggested throughout the thread by a Flight1 rep (Tiberiu); perhaps you may find something there to try. If not, suggest you post your issue in the thread and I would expect Tiberiu will respond. And of course, you could also open a support ticket directly with Flight1. 

I'm afraid I'm out of ideas on things to try for now.

Al

0

Share this post


Link to post
Share on other sites

Thanks for the suggestions Al. I found that thread earlier and tried deleting the F1GPSGeneral.dat file and was hopeful that it would work but it did not. My window specifications in the panel.cfg look like what you listed above.

 

I did do a reinstall of the GTN but I didn't uninstall it first. Wanted to try the easy route first to see if that worked. I will do a full uninstall and reinstall of it later.

 

Thanks,

 

Ryan

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now