Headley

Sony playstation controller & axis assignments

Recommended Posts

Hi,

I'm using a PS4 controller for my view assignments.

Yesterday i was able to assign some axis to different viewsettings (forward-back, left-right etc...).

Sinds the new update 0.4.99 these axis assignments no longer work, the buttons and keys etc does.  Only Tilt up/down is working.

Is there something changed in these assignment?

 

(Using Win10/64 - P3Dv4.1 - CP experimental current 0.4.99)

edit: the controller reacts OK in windows control panel, and in FSUIPS is works OK aswell ...

 

BTW fade in/out black is a nice feature.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Same problem! Chaseplane was updated today and my playstation controller has lost X/Y axis (which I used to move forward/backward and sideways). Something happened here. 

EDIT

In Chaseplane, I tried to reassign the axis to their previous functions. Chaseplane recognizes the axis when I move them in the assign window, even though they don't function afterwards. 

Share this post


Link to post
Share on other sites

I had the same problem with xbox controller. I exited P3D, rebooted, re-plugged the connector upon restart and everything worked. Hopefully, this can work for you too.

Share this post


Link to post
Share on other sites

For some reason it didn't work for me. I had to go around the issue by assigning buttons to replace those axis. But thanks for your suggestion.

Share this post


Link to post
Share on other sites

Thanks Keven - will this latest fix also work on any upcoming updates that will occur so we don't have to fiddle with controls? (Not a complaint - I realize and accept the fact that CP is work-in-progress).

Share this post


Link to post
Share on other sites
Just now, tamsini said:

Thanks Keven - will this latest fix also work on any upcoming updates that will occur so we don't have to fiddle with controls? (Not a complaint - I realize and accept the fact that CP is work-in-progress).

Not sure to understand what you mean by that

Share this post


Link to post
Share on other sites

Maybe I misunderstood your post. Did the latest update address the issue with loss of control-assignments as noted above? If so, I was wondering if this was the case, will it work when new updates are pushed so we don't have to re-assign controls after the update(s).

Share this post


Link to post
Share on other sites

There was no loss of control assignments here, only a detection loop that failed to detect axis activity. User data was untouched.

Share this post


Link to post
Share on other sites

OK! I have about as much programming skills as I have with open-heart surgery skills. Anyhow - I am one happy CP user.

Share this post


Link to post
Share on other sites

Keven,

The axis are working now! :)

But the X axis is reversed for me. In order to move left and right I had to reverse the axis in the chaseplane assignment window because the left selection makes the POV move right and viceversa. Not sure if it's an issue on my side or yours, though.

 

Edit:

Found out that in outside mode I am now unable to pan left or right or up or down but instead I move in those directions around the aircraft. In the cockpit assignments work as expected. DISREGARD - I had the "track the aircraft" option on! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now