G-YMML1

Crashes when clicking on the pop-up panels

Recommended Posts

Good evening,

I'm having random, but frequent crashes of P3D when I click on T7 pop-up panels in VC. There are no signs of an error in the Event Viewer, P3D just crashes without a sound. The two most recent "incidents" occurred today and yesterday when I clicked on right MFD and right Radio-Stack pop-up panels. Yesterday I completed full T7 reinstall just be sure that I have the most recent version. Such behavior does not occur with ether NGX or 747, it's mere T7 that has been affected. Also, I'm aware that T7 was suffering from left PFD pop-ups crashes in the past and I presume that this problem has been fixed since then. However, in my situation it hasn't been a case.

I have P3D 4.1, Win7Pro, 1080Ti, i7-6700, 2TB EVO SSD. Also, I have FS2Crew enabled, but RAAS disabled.

 

Would really appreciate your thoughts, ideas.

Thank you in advance

Dimitry Toropov

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

17 hours ago, G-YMML1 said:

Also, I'm aware that T7 was suffering from left PFD pop-ups crashes in the past and I presume that this problem has been fixed since then. However, in my situation it hasn't been a case.

Hi Dimitry, the left outboard DU problem you allude to has not been fixed.  Rather, a work around that allows user to disable the 2D popup prevents the event from occurring.  I am one that was always able to recreate that event, and as a beta tester I got my fair share of the testing in trying to solve the problem so I can speak with a little knowledge.  Unfortunately, that problem was specific to only the left outboard PFD and could be triggered in any NGX, 747 or 777 product.  Your problem description is of a different problem.  It is not normal for other DU 2D popups to cause a problem, and this is rarely reported in the forum.

My first thought is to look at your other addons, perhaps you could try to trigger the event with FS2Crew disabled?  Look thorough the addons loaded by either dll.xml or exe.xml in both appdata and programdata locations to see if there is anything suspicious.

Share this post


Link to post
Share on other sites
12 minutes ago, downscc said:

 

My first thought is to look at your other addons, perhaps you could try to trigger the event with FS2Crew disabled?  Look thorough the addons loaded by either dll.xml or exe.xml in both appdata and programdata locations to see if there is anything suspicious.

Thanks Dan,

Disabling FS2Crew iin the T7 will be my first choice for test-run. However, I have also scanned FS2Crew forums and haven't found anything that would reminiscent my problem. Anyway, I will report later

Best regards

 

Share this post


Link to post
Share on other sites

I'm just curious...is uiautomationcore.dll still required for P3D v4.1?

Share this post


Link to post
Share on other sites
1 hour ago, G-YMML1 said:

I'm just curious...is uiautomationcore.dll still required for P3D v4.1?

Dimitry Please make sure you sign all your post with your real name as per forum requirements.

 

To answer your question the uiautomationcore.dl nore required for the P3d.

Share this post


Link to post
Share on other sites

Well, after 3 days of heavy testing without FS2Crew, I have to say that I had zero issues with T7. At this point, I'm relocating myself to FS2Crew department.

Share this post


Link to post
Share on other sites


Well..the issue came back again and this time without FS2Crew, meaning that latter wasn't the issue that Bryan confirmed. Again, P3D closes after I had been clicking on pop-up displays and panels for some time. No info in the EventViewer, nothing in the AppCrashView. Totally confused as I have dedicated clean PC with clean OS just for P3D and NGX and 747 work flawlessly under the heaviest conditions. Also, T7 was the most stable aircraft in both P3D 2.5 and 3.X. The latest FSUIPS, drivers etc have been installed. 

Honestly, I ran out of ideas. Just submitted a ticket.

Would appreciate any thoughts, ideas.

Dmitriy Toropov

Share this post


Link to post
Share on other sites
19 hours ago, G-YMML1 said:

Would appreciate any thoughts, ideas.

Here are specific steps you can take to isolate the problem: http://www.prepar3d.com/forum/viewtopic.php?f=6312&t=123246

You've already done steps 1-4 it appears so backing up or removing the generated files in step 5 might be a good place to start, modified to allow testing with the 777 installed of course.

Share this post


Link to post
Share on other sites

Step 5 sounds like a full reinstall for me. For 17 years of flightsimming I have leaned how to keep my sims clean, never rush with updates, never use shortcuts, etc. I will disable all the pop-ups and try to test this theory first as it is the pop-up, either a panel or display, that triggers crash. 

 

Thanks for the advice anyway,

 

My Best

Dmitriy Toropov

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now