Mrkev

DX9 & DX11 issue

Recommended Posts

Enjoying the 747 however, I have this odd issue with FSX. Since I had a new PC and windows 7 Pro 64bit. It came with DX11. If I use FSX with DX10 checked, all is fine. If I un-check it, then I start having ghost planes and losing textures, especially if I change screens, i.e open up the map page or alt tab into desk top and then back in. It seems to be better than it was but eventually it happens. Trying to research issues with this it seems all the issues are/were the other way round with people losing textures when DX10 is used. I have downloaded DX9 however it doesn't seem to install as I assume the system is seeing that it has a more up to date version???

Apparently DX11 is DX10 and 9 compatible, however this does not seem the case, at least on mine anyhow. It does not matter whether I use an add on i.e PMDG, or fsx own aircraft, I have the same issue. 

Is it a case of uninstalling DX11 and installing DX9 and then DX11 again, or a simple fsx.cfg fix? I know this is not a PMDG issue , however as I am currently really enjoying the 747 (albeit with DX10 and flashing taxiway lines at some airports) I would like to use it w/out DX10 enabled, or at least have that option.

Any useful advice would be much appreciated.

Many Thanks and best wishes to all.

Kevin Jeffery.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks, Ian. I was aware of Steve's DX10 fixer  and I will probably get this at some point anyway, however that is the confusion. I Have to use FSX in  DX10. I want FSX to work with DX10 unchecked. This is the problem because it is then, that I lose textures and get ghost planes etc...The reverse of what others seem to be experiencing??. The DirectX redistributables seems to be more promising so I will try this first when I back home. I appreciate your help. 

Regards

 

Kevin.

Share this post


Link to post
Share on other sites
6 hours ago, Mrkev said:

Is it a case of uninstalling DX11 and installing DX9 and then DX11 again, or a simple fsx.cfg fix?

You're confusing a lot of topics here.

FSX is DX9 only, though it had a DX10 preview mode ('preview' because it was never fully coded into the program as a functional thing). There are 'fixer' programs out there that claim to get it working, but it's not a native fix, so it cannot be guaranteed. Our aircraft are not set up to work in that preview mode ('fixed' or not).

What, exactly, have you done to your FSX install beyond the base install? Shaders? Fixers?

Share this post


Link to post
Share on other sites

 

On 15-12-2017 at 6:17 PM, scandinavian13 said:

There are 'fixer' programs out there that claim to get it working, but it's not a native fix, so it cannot be guaranteed. Our aircraft are not set up to work in that preview mode ('fixed' or not).

 

Speaking for myself, I'm using this 'fixer' for almost a year now and never had any problems with it.

For me, it really is a great "fix" and with the additional "DX10 Cloud Shadows" ... the world looks just breathtaking ...  

 

2017-12-7_18-39-9-295.jpg

 

Also, on my machine it saves about 150 MB of VAS, wich was the main reason why I decided to buy this addon in the first place.

And no...NOT going to switch my entire PMDG hangar to P3D. But that's purely because of financial reasons...  :wink:

 

Screenshot from Taxi2Gate KSEA to Flightbeam Studios KDEN in the PMDG 747 v3

  • Upvote 1

Share this post


Link to post
Share on other sites
15 minutes ago, rheinis said:

Flightbeam Studios KSEA

Do you know something I don't? I didn't think they had a Seattle scenery.

Share this post


Link to post
Share on other sites
2 minutes ago, Captain Kevin said:

Do you know something I don't? I didn't think they had a Seattle scenery.

 

I apologize. I mean Taxi2Gate  :smile:

 

Share this post


Link to post
Share on other sites
On 12/15/2017 at 5:17 PM, scandinavian13 said:

You're confusing a lot of topics here.

FSX is DX9 only, though it had a DX10 preview mode ('preview' because it was never fully coded into the program as a functional thing). There are 'fixer' programs out there that claim to get it working, but it's not a native fix, so it cannot be guaranteed. Our aircraft are not set up to work in that preview mode ('fixed' or not).

What, exactly, have you done to your FSX install beyond the base install? Shaders? Fixers?

Hi Kyle,

Thanks for your reply.

Im probably confusing myself more than a lot of topics so excuse my ignorance!  You say that FSX is DX9 only although it had a DX10 preview mode, That is the problem.....If I have DX10 preview mode checked, then basically FSX is fine. However if I have DX10 preview mode unchecked, so would it be fair to say "then using DX9"?, that is when I have the problems with losing textures. Your aircraft on my system are OK with DX10 preview checked. Not with DX10 unchecked and all other aircraft for that matter. I HAVE to use FSX in DX10 in order for it to work. So if the DX10 fixer is designed to fix issues with DX10 then I dont see how this will help as i don't have an issue with it (other than no progressive taxi and flashing taxiway lines at certain airports).

I have done nothing more than load FSX from disk and then various add ons. The only change from default was setting it C:FSX as recommended instead of loading into 64 directory...if that makes sense. As soon as I started using FSX I would lose textures and get ghost planes etc. Once I then checked DX10 preview and restarted, it was fine.

 

Best regards

 

Kevin.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now