C130FE

ATC Repeating Itself

Recommended Posts

Was doing some touch and goes and after the 3rd or 4th touch and go, it was like they forgot about me.  So I continued to do some touch and goes, then all of a sudden they kept clearing me to do touch and goes.  Must have been about 5 or 6 consecutive calls clearing me for a touch and go.  After that things went back to normal.  Kind of odd.  Also, when I clear the runway, I'm never told to contact ground.  So I try and contact ground on my own, but no answer.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sometimes on my system things seem to get 'backed-up', sort of, and I may issue a request several times until I'm heard and then when things 'catch-up', all of my requests are acknowledged.  In other words the request is repeated as many times as I call for it. I don't know if that is what you are experiencing or not. When I clear a runway and there is no transfer to ground frequency, I do a 'Sayit' command to tower requesting a frequency change to the ground frequency and get it that way.  I could probably call and get it too but I just haven't tried that approach.

 

Bill

Share this post


Link to post
Share on other sites
4 hours ago, Dave-Pilot2ATC said:

Be sure to upgrade to version 2.4.0.2.  It fixes quite a few bugs.

Thanks Dave.  

 

17 hours ago, Bill Griffith said:

Sometimes on my system things seem to get 'backed-up', sort of, and I may issue a request several times until I'm heard and then when things 'catch-up', all of my requests are acknowledged.  In other words the request is repeated as many times as I call for it. I don't know if that is what you are experiencing or not. When I clear a runway and there is no transfer to ground frequency, I do a 'Sayit' command to tower requesting a frequency change to the ground frequency and get it that way.  I could probably call and get it too but I just haven't tried that approach.

 

Bill

Bill, that is pretty much exactly what I was experiencing.

Share this post


Link to post
Share on other sites
41 minutes ago, C130FE said:

Thanks Dave.  

 

Bill, that is pretty much exactly what I was experiencing.

I thought that your problem sounded familiar.  :biggrin:  I see Dave's post that there is a version 2.4.0.2 now.  I have version 2.4.0.0.  When I finish this flight I will try that version.

Bill

 

PS

    Pilot2ATC just keeps getting better.  Thank Dave!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now