Andreas Stangenes

Trying to purchase the DC6 for XP

Recommended Posts

...but the shop cart keep saying it's empty. I did write "yes" in the confirmation box, and verified that there is 1 qty. When I click "checkout" Im taken to the next page that says my cart is empty. When I click purchase via paypal, im taken to my paypal account. After I verify the purchase im taken back to pmdg shop that says my cart is empty... Ive tried with both Chrome and MS Edge, but neither browser does any better.

 

Btw, I already purchased the dc6 for p3d. I don't know if that messes things up?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

14 minutes ago, Andreas Stangenes said:

Btw, I already purchased the dc6 for p3d. I don't know if that messes things up?

It won't.

Have you tried clearing your browser cache?

Share this post


Link to post
Share on other sites

No, but all of a sudden it worked when doing the paypal method again. :)

 

However, Im trying to activate the product, but the normal activation popup im used from other products don't pop up. When I try to click "activate your product" under plugins-> pmdg, the option is greyed out. All options in the pmdg menu are greyed out, including the product activation. Tried reloading the sim a couple of times but it doesn't change. What shall I do?

Share this post


Link to post
Share on other sites
1 minute ago, Andreas Stangenes said:

All options in the pmdg menu are greyed out, including the product activation.

What version of XPL?

Share this post


Link to post
Share on other sites
13 minutes ago, Andreas Stangenes said:

Xplane 11

What version is specified on the product page?

Share this post


Link to post
Share on other sites
1 minute ago, Andreas Stangenes said:

10.45+

Yep. XP10 - somewhere in the XP10 version. I understand that, for some reason, the XPL community has gotten used to a lot of odd compatibility things over the years, but on the MSFS side of things, you were only really guaranteed within-version compatibility. FS2002 add-ons were only for FS2002. FS9 add-ons were for FS9, and 9.1. FSX add-ons are only for FSX.

Submit a ticket and we'll have a look at the situation for you.

Share this post


Link to post
Share on other sites

I dont know if you are trying to patronize me by asking such a question, but I'm gonna give you the benefit of the doubt. I have bought every product PMDG has released, and I've done so across multiple simulators to boot. That makes up quite a lump of money, and as such I would like some respect in return. Your one-line question is at best pedantic and at worst quite insulting. It says 10.45+ which to me implies "Higher than" and not "excluding" xp11. I did a google search before purchasing and the top results were positive about the product working in xp 11 so I thought no more about it. If you are saying that your product is not compatible with xp11 you need to change your minimum spec description so it doesn't just say "xp 10.45+". 70 usd is quite alot of money and you should not be ambiguous about which version it is for. 

If it's not compatible I would like my money back since I dont use xp 10. 

  • Upvote 2

Share this post


Link to post
Share on other sites
1 minute ago, Andreas Stangenes said:

I dont know if you are trying to patronize me by asking such a question, but I'm gonna give you the benefit of the doubt. I have bought every product PMDG has released, and I've done so across multiple simulators to boot. That makes up quite a lump of money, and as such I would like some respect in return. Your one-line question is at best pedantic and at worst quite insulting. It says 10.45+ which to me implies "Higher than" and not "excluding" xp11. I did a google search before purchasing and the top results were positive about the product working in xp 11 so I thought no more about it. If you are saying that your product is not compatible with xp11 you need to change your minimum spec description so it doesn't just say "xp 10.45+". 70 usd is quite alot of money and you should not be ambigous about which version it is for. 

If it's not compatible I would like my money back since I dont use xp 10. 

It isn't patronizing. I wanted to be sure you saw the product specs, because you seemed to have skipped over them, despite having caught the 'yes' box. None of our pages for the DC-6 reference XPL11 in any way, and in fact, the product page in the store is quite heavy handed with the use of X-Plane 10, very specifically, including immediately above the 'yes' box (compatible with any X-Plane 10 license level on Windows).

Similarly, I'll ask that you review my post immediately prior to this one regarding how it is outside of expectations in the software industry - particularly in the sim community - to expect any compatibility in major versions. 10.45+ implies nothing more than 10.45 through 10.99. X-Plane 10's license levels carry you through X-Plane 10. You had to purchase a new license for X-Plane 11, so any XPL10 license level would not apply.

As with my last post, please submit a ticket so that we can look into the issue.

  • Upvote 1

Share this post


Link to post
Share on other sites

A couple of things: We are both into simulation of air transport, and as such we are both familiar with how ambiguity has lead to many a mishap. I did my due dillegence by reading your minimum specs that says "xp10.45" as a minimum spec. That lead me to investigate further to check if that excluded xp11. The first few hits on the google search "pmdg dc6 compatible with xp11" seemed to verify compatability. Where does it say that I have to understand the version history and how products are handled differently across multiple simulator and their respective versions on a per developer practice? Some products (from other developers) work perfectly well in xp11 even though they say xp10 on the store page. It is too much of a burdon to put on your customers, and I can hardly be the first one to make this mistake. I suggest that you even more clearly specify that the product excludes compatibility with xplane 11. 

It was a honest mistake to boot, and a kinder and more welcoming reply would have been better for me, you and PMDG. I  have opened a ticket to resolve this issue. 

  • Upvote 3

Share this post


Link to post
Share on other sites

I saw your post on r/flightsim, and I have to come to Kyle and PMDG's defense here

The product page ONLY says x-plane 10.  It doesn't clearly say "or higher" in the main product page.  Cut/pasted directly from the XP product page:

  • Compatible with any X-Plane 10 License Level on Windows.
  • The PMDG DC-6 Cloudmaster Base Package for X-Plane v10 - Windows*
  • The ultimate simulation of the a Magnificent Douglas Classic, the DC-6 Cloudmaster is now available in Laminar Research's X-Plane 10 on Windows!
  • This is compatible only with Laminar Research's X-Plane 10 run on the WINDOWS platform.
  • *Product tested with X-Plane 10 for Windows.  Compatibility information with X-Plane versions will be updated as new X-Plane versions are made available, and may require software updates depending upon changes made by Laminar Research.

I'm sure there was a reason you misunderstood, but nonetheless, I can't see how XP11 compatibility was implied.  The site makes it perfectly clear that this is for XP10

  • Upvote 3

Share this post


Link to post
Share on other sites
3 hours ago, Andreas Stangenes said:

The first few hits on the google search "pmdg dc6 compatible with xp11" seemed to verify compatability.

Google is all well and good, but according to Google I can stuff a supercharger into my car and it'll work. If I stuff a supercharger in my car and it stops working, does BMW have to honor the fact that I took their product and used it in a way that they did not certify that it would work? No, they do not. As soon as you step outside of the product specs, you're on your own.

Moreover, it used to work in XP11 - unofficially - until an update was released.

3 hours ago, Andreas Stangenes said:

Where does it say that I have to understand the version history and how products are handled differently across multiple simulator and their respective versions on a per developer practice? Some products (from other developers) work perfectly well in xp11 even though they say xp10 on the store page.

I'm not forcing you to understand anything. Understanding things will really help you to avoid mistakes in the future, though, which is why I asked for your interpretation of what the product page told you. Any cursory look around will tell you what industry best practice is: your product works where you say it will work. If someone says Version X.xx+ then it will work within Version X.xx+ up until the X changes to Y. This is the standard just about anywhere. If I have a game for XBOX ONE, I'm not assuming it will work in [whatever the new XBOX will be called]. It might and several do, but that is not guaranteed, and may be unsupported. If I have a product in P3Dv3, it might work in v4, but that is not guaranteed.

Some projects from other devs may work in both platforms, but I'm willing to bet that they aren't of the same complexity that ours is. Moreover, if they don't work and 11 isn't mentioned on the page, they're under no burden - again, industry standard - to provide you a working product there.

I can see some of the confusion, provided you ignore just about any other use case, and also ignore the issue of supported versus unsupported. Even the reddit crowd (usually particularly keen to point out that I'm a bit abrasive and unhelpful, among other things, and that's using their nicest examples) seems to be understanding the fact that there was no implied XP11 support (even while some of them note that I'm still abrasive).

  • Upvote 3

Share this post


Link to post
Share on other sites

Andreas, Kyle means no harm and wasn’t trying to insult you. The website does clearly say XPL10 compatibility, and a quick Google search should have turned up many threads of people asking for the DC-6 for XPL-11 rather than people saying it’s compatible, which as Kyle noted, was true until recently. We all make mistakes and overlook things, but I’m sure Kyle and Company will get you all sorted out via the support system!

  • Upvote 1

Share this post


Link to post
Share on other sites

And to set the record straight, PMDG via Kyle Rodgers and the ticket system did indeed refund my money. And also for the record, my apprehension in this thread was not because I wanted the product to become xp11 compatible when it is not. It was that I just paid 70 bucks for a product that had an ambigous text and PMDG staff not being sensitive towards me. They are an international company (at least in the sense that they provide their products to people all over the world), and that necessitates being able to bridge all the different cultures of the customers that they serve. Pointing out customer stupidity might work where Kyle comes from, but I'm willing to bet that is the exception to the rule of what works in most cultures. If Kyle would have given an inch in regards to the minimum spec being ambiguous and that my mistake is only human, then that would have made the entire conversation much easier. In the end, I guess he did say that in his last post where he says "I can see some of the confusion, provided you ignore just about any other use case, and also ignore the issue of supported versus unsupported. Even the reddit crowd (usually particularly keen to point out that I'm a bit abrasive and unhelpful, among other things, and that's using their nicest examples) seems to be understanding the fact that there was no implied XP11 support (even while some of them note that I'm still abrasive)."

The conclusion is that I got my money back. I got it back quite quick too, so that is a bonus for the company. I would advice PMDG to spend some effort in customer dialogue in the context of a international scene. 

  • Upvote 5

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now