pippin1811

Speech recognition training not working

Recommended Posts

Hi Dave,

I've just installed Pilot2ATC and everything is working as I would expect, but the speech recognition could do with a bit more training. I tried the process described in pages 66-67 of the manual, but clicking the "train" button does nothing. I do see that the current version has some more options than the manual, I have tried each one. I've gone through 2.5, 2.5.0.1 and just now 2.5.0.2 with the same effect. I have done the 2 standard windows speech training sessions and in those cases the "Welcome to speech recognition voice training" window popped up and the following traingin windows did their usual thing of working through the phrases.

The built in practice phrases in grammer help work well, just the odd P2A specific phrase (or part of) that doesn't always trigger.

I've read the manual carefully to see if I need to enable something to get windows training working - I can't see anything but feel free to correct me.

Thanks for your help and the great program.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have multiple languages installed on your PC?

If so, when you go to Control Panel -> Language, English-US should be at the top as the primary language.

 

One user was having trouble getting the training to work and was able to resolve it by going to

Control Panel -> Language -> Advanced Settings

At the bottom of that page, he unchecked Language for web content option "Don't let websites access my language list."

That option is checked on my system and the training works, but apparently his security settings required him to uncheck it to get it to work.

Dave

 

Share this post


Link to post
Share on other sites

Hi Dave,

 

Thanks for the quick resoponse. While I have several SAPI voices installed, US English is the primary default language at the top of the list.

I tried your advanced settings ideas with no joy, i have even tried running the P2A language trainer directly. Clicking the button does nothing, not even an error popup so not easy to debug. I tried a bunch of other settings in windows voice recognition, did the standard training sessions again with no change. I've run out of ideas ! However since it works on your system it must be something on my setup - Windows 10 Pro fully updated.

I've found the training scripts and have been loading them into notepad and making copies, correcting as I go along. I believe that WSR learns as you correct so that may help a little with some of the phrases.

Share this post


Link to post
Share on other sites

Do you have 11 Speech Training scripts in the Grammar Folder?  An older version had 7 and they were too long for the Trainer and didn't work.

Also, did you try all the different controller types and use the Train button in the Left Hand box of the Language Trainer...not the right hand one?

Are you running the program as Admin (Right click the icon or exe file and select Run as Administrator).  There may be an access issue.

If I think of any other possibilities I'll let you know.

Dave

Share this post


Link to post
Share on other sites

Hi Dave,

Thanks for responding. I do have the 11 scripts, and I have been clicking the training button in the LH box. I tried running the trainer as administrator and pretty much everytning else I could think of. Absolutely no joy. P2A is working and generally the interaction is right first time, just a few phrases where my pronounciation/accent is clearly not what WSR is expecting ! If you think of anything else or can add a debug mode in a future update that might identifiy the problem please let me know.

Great program overall.

Share this post


Link to post
Share on other sites

Hi Dave

 

I have the same issue as Pippin. I tried downloading a trial on a new machine (win 10) and when hitting the train button (within Pilot2ATC Language Tainer), nothing happens.

This mirrors my production PC where I have a licensed copy working. As I have just come back to siming after an 12 month homecockpit build; I have the feeling it may not have worked originally [the train aspect].

 

Like Pippin I the software works fine but I have a few pronunciation / accent issues that I would really like to oron out.

In my opinion the issue is trying to start the windows control panel recognition speech engine

 

Any thoughts appreciated.

 

Cheers

Paul

 

 

Edited by paulsharp100
inserted image

Share this post


Link to post
Share on other sites

Have you tried any of the suggestions provided by Dave earlier in this thread?

There is a lot of detail about speech in the user guide that may help.

Are you able to train with just microsoft speech?  Have you gone into windows control 'speech recognition' applet? This will make sure you have a functioning speech system.

When I click Grmr Help, I get the first window and then click Train I get a second window that allows me to train.  Update the callsign you use.   Click on the controller in the Full training and the Train button within this box. (There are too many buttons labelled train),

How does your experience differ?

Dave is unavailable to assist as he is recovering from surgery.

 

Share this post


Link to post
Share on other sites

Hi JeB,

 

Many thanks for the response. Trust Dave will have a speedy recovery.

 

Yes I tried the advice earlier in the tread. I dug around a lot to find a solution. Without Luck.

 

The MS Windows 10 has changed a little presumably on the cosmetic side in respect of Dave guide links (step 11 note article). I can see Dave has an EXE P2ALanguageTrainer that I can run independently. The 'Train' button/s do not execute the MS speech engine. 

I have P2A installed here 'C:\Pilot2ATC_2018_x64'

I believe that MS have installed some sort of  'Contana' routine that Dave may have not trapped, or permission issue on executing the speech prog.

 

Hope that helps..

 

Cheers

Paul

 

 

 

Share this post


Link to post
Share on other sites
8 minutes ago, paulsharp100 said:

Hi JeB,

 

Many thanks for the response. Trust Dave will have a speedy recovery.

 

Yes I tried the advice earlier in the tread. I dug around a lot to find a solution. Without Luck.

 

The MS Windows 10 has changed a little presumably on the cosmetic side in respect of Dave guide links (step 11 note article). I can see Dave has an EXE P2ALanguageTrainer that I can run independently. The 'Train' button/s do not execute the MS speech engine. 

I have P2A installed here 'C:\Pilot2ATC_2018_x64'

I believe that MS have installed some sort of  'Contana' routine that Dave may have not trapped, or permission issue on executing the speech prog.

 

Hope that helps..

 

Cheers

Paul

 

 

 

OK Found a solution...

I followed this video, even tho my Win 10 version is slightly different (due to patches I guess).

Setting up the microphone somehow seemed to rejuvenate the speech engine and the Train button now works when running the P2ALanguageTrainer.exe directly.

I think I recall somewhere in Dave's manual about this.... so my bad!!

Thanks JeB.

 

P2A is a must for flight simmers, keep up the great work.

 

Cheers

Paul

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Changing the speech recognition language from English-UK to English-US solved my problem. I didn't expect that this would make a difference, but it does!

Great program. After the trial period I bought P2A. Speech Recognition really improves after a few practice sessions 🙂.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now