Sign in to follow this  
roarkr

Start a PMDG flight directly from a saved sceanario file

Recommended Posts

Posted (edited)

Starting a saved PMDG flight scenario file directly with a rightclick and open with "Prepar3D" works fine on my setup. This method works fine also for many other simmers, but for many simmers this method does not work. For those that this method does not work, Prepar3D starts and disappear from the screen, but do not close completely. In Task Monitor they will see that Prepa3D is still running as a Background process. You then have to either end Prepar3D in Task Manager or make a PC restart to get Prepar3D running again.

 

As I am working on a program that needs to use this method to start a flight, I am eager to find a solution for this issue.

What is it in the Prepar3D and PMDG settings that cause this issue? Or maybe it is something else that causes this?

If simmers who this method works for and not works for could give the details of their settings or other information, I would be grateful.

 

There must be a reason for this behavior and I like to find out the root cause of this problem.

 

 

Edited by roarkr

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

2 hours ago, roarkr said:

Starting a saved PMDG flight scenario file directly with a rightclick and open with "Prepar3D" works fine on my setup. This method works fine also for many other simmers, but for many simmers this method does not work. For those that this method does not work, Prepar3D starts and disappear from the screen, but do not close completely. In Task Monitor they will see that Prepa3D is still running as a Background process. You then have to either end Prepar3D in Task Manager or make a PC restart to get Prepar3D running again.

 

As I am working on a program that needs to use this method to start a flight, I am eager to find a solution for this issue.

What is it in the Prepar3D and PMDG settings that cause this issue? Or maybe it is something else that causes this?

If simmers who this method works for and not works for could give the details of their settings or other information, I would be grateful.

 

There must be a reason for this behavior and I like to find out the root cause of this problem.

 

 

You need to load p3d with a default flight first and the load the saved situation. This is the proper way. This is how it is from fsx. The reason is simple p3d needs to load its core functionalities first before loading any complex addon, in simple terms. 

Share this post


Link to post
Share on other sites
2 hours ago, Olympic260 said:

You need to load p3d with a default flight first and the load the saved situation. This is the proper way. This is how it is from fsx. The reason is simple p3d needs to load its core functionalities first before loading any complex addon, in simple terms. 

I know that this is the official statment from PMDG. But my question was why does it work for some and not for others? 

Share this post


Link to post
Share on other sites
16 minutes ago, roarkr said:

I know that this is the official statment from PMDG. But my question was why does it work for some and not for others? 

I am not 100% sure that it works flawlessly to others. Even when I try in order to test some other staff it seems to be loading correctly but then I find some details have not loaded correctly. Some times these details might not be apparent 

Share this post


Link to post
Share on other sites
Posted (edited)

Just save the Beechcraft Baron as your default aircraft, and start P3D by loading the Scenario Setup screen. Job done.

Edited by Christopher Low

Share this post


Link to post
Share on other sites

Don‘t think that‘s what he means. It‘s more that when you shut down P3D, intentionally or not, sometimes you have to „kill“ it first in the task manager before you can start it again. Sometimes, after I flew (for example) the Queen and want to change to the A320 (it actually doesn‘t matter which addons) I can‘t restart P3D. Not even if I wait for a couple of minutes. Rather I have to go to the task manager and stop the process. If I just double click P3D again and gain I only start several processes of P3D at the same time but none of them actually loads. This happens to P3D only on my computer but I know that my girlfriend has this problem with Chrome, but only sometimes. 

I assume there is an issue with the programs communicating with windows (I have no idea about windows) rather than an issue with PMDG with P3D...

Share this post


Link to post
Share on other sites
On 5/20/2018 at 12:08 PM, Olympic260 said:

You need to load p3d with a default flight first and the load the saved situation. This is the proper way. This is how it is from fsx. The reason is simple p3d needs to load its core functionalities first before loading any complex addon, in simple terms. 

really? I resumed long haul mid-flight at FL360 without a hitch, with active sky, aivlasoft and chaseplane all running. had to restart P3D to reset audio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this