vp49p3

Cloud ground shadows too dark in v4.2

Recommended Posts

I did a complete install of the latest P3Dv4.2 iteration, from 4.1 where all worked fine.  I also reinstalled ENVTEX, AS4, ASCA, ORBX Base, Vector and Trees, with all required updates, with the recommended middle of the road settings.  I used to fly in v4.1 (same addons) with cloud ground shadows enabled, and they looked fine.  Now, they are very, very dark, so that the ground looks almost black where they are. Everything else looks fine in v4.2. I deleted my shaders file and rebuilt them--no luck.  Deleted my config file and rebuilt it--no luck.  Restored my original textures from ENVTEX backup--no luck.

Any ideas for a fix would be greatly appreciated.

Thanks,

Jay

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I changed the shadow number of cascades to 4 from 7 for the high settings I have set in p3d, that reduced the darkness of the shadows in general as well as gave a significant performance boost with dynamics lights and heavy clouds. Going to low shadow setting would do the same but reduces some other aspects also, that remain preserved with the modified high setting.

  • Upvote 1

Share this post


Link to post
1 hour ago, him225 said:

I changed the shadow number of cascades to 4 from 7 for the high settings I have set in p3d, that reduced the darkness of the shadows in general as well as gave a significant performance boost with dynamics lights and heavy clouds. Going to low shadow setting would do the same but reduces some other aspects also, that remain preserved with the modified high setting.

I too am interested in adjusting shadows. Could you share some details on how to accomplish same? 

Is this an in sim adjustment or something done by editing a config. file?

 

Share this post


Link to post
1 hour ago, Romeo_Tango said:

I too am interested in adjusting shadows. Could you share some details on how to accomplish same? 

Is this an in sim adjustment or something done by editing a config. file?

 

It is in the prepar3d.cfg, change value for the entry SHADOW_NUM_CASCADES_HIGH= or whichever you have selected in menu settings.

Share this post


Link to post
8 hours ago, vp49p3 said:

I did a complete install of the latest P3Dv4.2 iteration, from 4.1 where all worked fine.  I also reinstalled ENVTEX, AS4, ASCA, ORBX Base, Vector and Trees, with all required updates, with the recommended middle of the road settings.  I used to fly in v4.1 (same addons) with cloud ground shadows enabled, and they looked fine.  Now, they are very, very dark, so that the ground looks almost black where they are. 

 

PTA has a setting "Cloud Shadow Depth" that may do what you're looking for.

  • Upvote 1

Share this post


Link to post
9 hours ago, him225 said:

It is in the prepar3d.cfg, change value for the entry SHADOW_NUM_CASCADES_HIGH= or whichever you have selected in menu settings.

Thanks much!  So whatever number there is in the config should be reduced to a lower number which fixes the issue, correct?

Share this post


Link to post
8 hours ago, Mace said:

 

PTA has a setting "Cloud Shadow Depth" that may do what you're looking for.

Thanks, also.  I'll try that after the config change, as I'm not using PTA right now.

Share this post


Link to post
13 hours ago, vp49p3 said:

Thanks much!  So whatever number there is in the config should be reduced to a lower number which fixes the issue, correct?

Yes, lowering the number make the shadows lighter.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now