Sign in to follow this  
arwasairl

DXGI_ERROR_DEVICE_HUNG P3D v3.4

Recommended Posts

When I start the game, P3D gives me a message.

DXGI_ERROR_DEVICE_HUNG

I have a GTX 1070 and I updated the drivers, yet still is crashing.

Other games work properly.

I also didn't make any hardware changes.

Help

Edited by Aaron Kim

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

All day I was trying to fix the same problem..i finally did uninstall the GeForce driver with DDU , reboot and install the latest driver from NVidia Driver Downloads..problem solved.. my graphic card : EVGA GeForce GTX 1060 6GB

George

Share this post


Link to post
Share on other sites

Didn't seem to work, however i have found the faulting addon. It is FSLSpotlights.

Share this post


Link to post
Share on other sites

Nvidia inspector-set frame rate limiter? Causing it for me with latest drivers.

Share this post


Link to post
Share on other sites

Do you have FSL spotlights installed?

EDIT: Disregard, didnt see that you already found the cause 😄

Edited by snapshot21

Share this post


Link to post
Share on other sites

This topic has been discussed dozen of times before P3D4 comes out and the problem is not only limited on FSL. I had it with PMDG as well, others had it with other games. The trigger can be different within one pc to another. 

Short answer is to use P3Dv3.3 or v4.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this