mikesingh

FSX Geometric Squares on Sea! Help!!

Recommended Posts

Posted (edited)

Hi Tom!

This is really frustrating! I'm getting geometric light blue squares while flying over the sea and sometimes the blue bleeds onto land in some sceneries. The water too is a bright light-blue in all streams/rivers. I thought it was ORBX and deleted it from the scenery library in FSX. But the issue still persists. This anomaly is present everywhere in all scenery areas where there is water. 

Is this due to a corrupt water texture files? How do I correct this? Here's a screenshot......

FSX_tex.jpg

Edited by mikesingh

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Did this just start happening or has always been like that since you installed FSX?

If it just started happening then something you installed or changed is most likely the cause as the sim can’t work correctly one day then look like this the next without change taking place.

If I recall from past experiences, it could be due to terrain.cfg issues or shader issues.

 

Share this post


Link to post
Share on other sites
5 hours ago, cmpbellsjc said:

Did this just start happening or has always been like that since you installed FSX?

If it just started happening then something you installed or changed is most likely the cause as the sim can’t work correctly one day then look like this the next without change taking place.

If I recall from past experiences, it could be due to terrain.cfg issues or shader issues.

 

Hi! This started happening recently. FSX was working like a charm earlier but this silly behavior started a few days ago. All my add on sceneries like Aerosoft and ORBX FTX were working fine. I think after I installed an FTX scenery, the nightmare started though I'm not 100% sure. I've unchecked all the ORBX sceneries in FSX scenery library but the problem still persists. Is it a problem with the terrain or texture files? 

Share this post


Link to post
Share on other sites

What was the FTX scenery that you installed immediately before you noticed this? Are you certain you didn't install anything else other than that scenery or, as has already been suggested, might you have changed any settings? Do you have you any weather engine installed that may affect sea textures?

Bill

Share this post


Link to post
Share on other sites

I installed FTX Saanen but it gave up halfway, Tried again, same thing. I couldn't uninstall it as the uninstall button only pops up on a full install. But I removed it manually from FSX scenery library and from the ORBX folder. 

Does a weather engine affect water textures? I have ORBX weather. Should I remove it? How? There's no uninstall for it! But I don't use it in flights. Usually real time or 'fair' weather. ORBX sucks!! Jeeez!

Any files/entries in textures or terrain folders in FSX that can cause this effect? 

Thanks,

Mike

Share this post


Link to post
Share on other sites
15 hours ago, mikesingh said:

 

Does a weather engine affect water textures? I have ORBX weather. Should I remove it? How? There's no uninstall for it! But I don't use it in flights. 

Orbx doesn’t have a weather program, only the theme that they provide and that can’t cause the issue you're having.

 

15 hours ago, mikesingh said:

Any files/entries in textures or terrain folders in FSX that can cause this effect? 

 

What ORBX products do you have? Global, Vector, airports, regions, landclass?

I suspect that it has something to do with your terrain.cfg being corrupted. I use Ultimate Terrain rather than Vector and if the terrain.cfg gets messed up it can cause issues like this. I don’t have ORBX Vector so I don’t know how you can re-run the program to have it fix the terrain.cfg.

I have a feeling that deleting the stuff from your scenery.cfg if that includes Vector and maybe landclass, could be causing the issues. You might want to post the issue at the ORBX support forum on their website to see how to proceed, not the ORBX forum here. They will be able to provide official support. Without seeing your scenery and terrain.cfg it’s hard to know what might be messed up.

Just to be sure, you’re not using any shader modifications or anything are you or using the DX10 preview? You could always try rebuilding the shader cache to see if it helps. Here’s instructions on how to do that?

https://fsxtimes.wordpress.com/2011/07/11/clean-up-shader-cache/

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/21/2018 at 11:21 AM, cmpbellsjc said:

Orbx doesn’t have a weather program, only the theme that they provide and that can’t cause the issue you're having.

 

What ORBX products do you have? Global, Vector, airports, regions, landclass?

I suspect that it has something to do with your terrain.cfg being corrupted. I use Ultimate Terrain rather than Vector and if the terrain.cfg gets messed up it can cause issues like this. I don’t have ORBX Vector so I don’t know how you can re-run the program to have it fix the terrain.cfg.

I have a feeling that deleting the stuff from your scenery.cfg if that includes Vector and maybe landclass, could be causing the issues. You might want to post the issue at the ORBX support forum on their website to see how to proceed, not the ORBX forum here. They will be able to provide official support. Without seeing your scenery and terrain.cfg it’s hard to know what might be messed up.

Just to be sure, you’re not using any shader modifications or anything are you or using the DX10 preview? You could always try rebuilding the shader cache to see if it helps. Here’s instructions on how to do that?

https://fsxtimes.wordpress.com/2011/07/11/clean-up-shader-cache/

Thanks!! I'll try what you linked and get back to you. I have UT Europe but even then I get this anomaly. I have deleted all ORBX entries in terrain.cfg and from the Effects file too but the issue persists. I have Windows 7 Ultimate which shows DX11 installed. Is there anywhere I can get the original texture.cfg instead of reinstalling FSX?

Now off to your link! I hope that works as this issue is getting frustrating!

Cheers!

Mike

 

Edited by mikesingh

Share this post


Link to post
Share on other sites

Hi cmpbellsjc,

As per your instructions and the link you provided about deleting the files in the cache folder, IT WORKED!! I tried several scenery areas and the squares have disappeared! 

Thanks buddy! 

Mike.

Share this post


Link to post
Share on other sites
3 hours ago, mikesingh said:

 Is there anywhere I can get the original texture.cfg instead of reinstalling FSX?

There is no texture.cfg only the FSX.cfg, terrain.cfg and scenery.cfg.

 

1 hour ago, mikesingh said:

Hi cmpbellsjc,

As per your instructions and the link you provided about deleting the files in the cache folder, IT WORKED!! I tried several scenery areas and the squares have disappeared! 

Thanks buddy! 

Mike.

Glad to see it was the shaders that were messed up and rebuilding them fixed the issue.

As far as the DX11 that Windows has installed by default, that also allows older DX versions to work as well, like DX9 and 10. FSX by default uses DX9 but has the DX10 “Preview” feature included. Unless you are using Steve’s DX10 “fixer” program, I’d stick to DX9 as the default DX10 feature can cause various issues.

Anyway, glad to see its fixed. No you can reactive all the scenery you deactivated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now