Jump to content

Sign in to follow this  
NBouc

Reverting to previous build, NGX and B777-200

Recommended Posts

Hi everyone,

Having installed the latest updates (27JUL18) for both the NGX and B777-200 this morning on P3D v4.3 and now having problems interacting with my GoFlight MCP-PRO since those updates, what would be the best way to revert to the previous build (NGX v1.20.8465 and B777 v1.10.8448) ?

- Install on top of the current build v1.20.8869 and 1.10.8871 respectively, or
- Uninstall the aircrafts completely and re-install fresh

The reason I ask is that since the 27JUL18 updates, my GF MCP-PRO is no longer working with my PMDG aircrafts (all I get are dashes, even though GIT status has a green light), while it was working OK before the PMDG updates. Nothing else has changed on my computer, not even Windows 10 updates (I have them blocked). I tried to correct the problem by re-installing the GoFlight software (v2.28.0) and GoFlight Interface Tool (GIT) v3.6.1.1 but to no avail. My MCP-PRO still works fine with  default aircrafts.

I would just like to go back to what was working fine yesterday before the 27JUL18 updates of my PMDG aircrafts.

Thank you for any suggestion,

Edit: Going back to the previous PMDG builds would be part of my troubleshooting routine, to see if the problem remains or not.

Edited by NBouc

Share this post


Link to post

I'm not sure if this is even possible. If you uninstall it and re-install it, you'll wind up with the base version of whatever installer you used. If you then use the Operations Center to update the plane, it'll install the latest update. You can't really install an in-between update as far as I know.

Share this post


Link to post

Hi Kevin,

Fortunately for me, the previous build of each of my PMDG aircrafts is that of the last base installer that I have (NGX v1.20.8465 and B777 v1.10.8448).  There was no other updates issued until the 27JUL18 ones. If I decide to install the previous builds and if everything returns to normal on those builds, I will simply not update them via the Operations Center.

I was wondering if an uninstall of the aircrafts is required or if I could just re-install on top of the current "updated" installation.

Share this post


Link to post
4 hours ago, NBouc said:

Hi Kevin,

Fortunately for me, the previous build of each of my PMDG aircrafts is that of the last base installer that I have (NGX v1.20.8465 and B777 v1.10.8448).  There was no other updates issued until the 27JUL18 ones. If I decide to install the previous builds and if everything returns to normal on those builds, I will simply not update them via the Operations Center.

I was wondering if an uninstall of the aircrafts is required or if I could just re-install on top of the current "updated" installation.

Also you could download and make backups of the installers for each PMDG version so you can re-installer whichever version you want 

Share this post


Link to post

you need  to uninstall,  than  install  the  version  you want

Share this post


Link to post
11 hours ago, NBouc said:

Hi Kevin,

Fortunately for me, the previous build of each of my PMDG aircrafts is that of the last base installer that I have (NGX v1.20.8465 and B777 v1.10.8448).  There was no other updates issued until the 27JUL18 ones. If I decide to install the previous builds and if everything returns to normal on those builds, I will simply not update them via the Operations Center.

I was wondering if an uninstall of the aircrafts is required or if I could just re-install on top of the current "updated" installation.

In that case, you would have to uninstall it, then re-install it.

7 hours ago, captainsazzman said:

Also you could download and make backups of the installers for each PMDG version so you can re-installer whichever version you want 

I'm not sure if the base installer gets updated every time an update is pushed, so I don't know if that would work.

Share this post


Link to post
1 hour ago, Captain Kevin said:

In that case, you would have to uninstall it, then re-install it.

I'm not sure if the base installer gets updated every time an update is pushed, so I don't know if that would work.

 

Re-installing hasn't killed anyone lol, especially when you want to revert to a stale build. Also, yes, big updates tend to have new installers.  You can arrange them by the version on a hard drive just in case. Also, for smaller updates, you can back up the individual files as the Ops centre tells which ones get changed. The latter is highly sensitive and risky, but it's a way to rollback. Or one can just wait and see the feedback from the update before installing it, like many do when a new P3D version is out.

Share this post


Link to post

Thank you Kevin, Pete_auau and Valesius.

I followed your suggestion and did an uninstall / install of the NGX and B777-200.

Step 1: Partial success

I uninstalled both the NGX and the B777-200, and installed the previous build using the latest full installer (NGX v1.20.8465 and B777 v1.10.8448), whithout installing any updates. I regained functionality of my GF MCP PRO with the NGX, but not the B777. I have no idea why.

Step 2: Full success

Seeing that PMDG has published another update (30JUL18) for both aircrafts, I decided to install those updates to see what would happen. I am glad to say that my MCP PRO now works fine with both the NGX and the B777-200.

I still have no idea what got broken initially when I applied the 28JUL18 updates, nor why installing the 30JUL18 B777 update repaired the functionality between the 777 and the MCP-PRO, considering that all the settings and configuration for the MCP PRO are made on GIT. On the PMDG side, the only thing needed is making sure that the "737NGX_Options.ini" and "777X_Options.ini" files contain the section "[SDK] EnableDataBroadcast=1", which they did.

Even if I don't understand what happened, the important thing is that the problem is now solved.

Happy flying to all !

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
×
×
  • Create New...