Bazza744

MAIN BATTERY DISCH

Recommended Posts

Hi guys,

any idea what might be causing this error ? The electrical page looks absolutely fine....

Cheers Baz.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

7 minutes ago, Bazza744 said:

any idea what might be causing this error ?

Whatever power source you are using is insufficient, so your current electrical load is using all of that source, AND some of the battery. What power sources are you using?

Share this post


Link to post
Share on other sites

Hi Kyle,

thanks a lot - I am inflight with engines running stable at 78.8 (obviously no APU) - I've taken a screenshot, but not sure how to attach it....

Cheers Baz

Share this post


Link to post
Share on other sites
4 minutes ago, Bazza744 said:

thanks a lot - I am inflight with engines running stable at 78.8 (obviously no APU) - I've taken a screenshot, but not sure how to attach it....

Will need one of the overhead, too. Sounds like you either have a failure, or something didn't get configured properly.

Share this post


Link to post
Share on other sites
4 minutes ago, Bazza744 said:

Hi Kyle - hope this works, thanks a lot for having a look ! T

Welcome. The earlier "too" was meant to indicate that the overhead was desired in addition to the picture that I'm assuming was the EICAS / main panel.

Share this post


Link to post
Share on other sites

Corrupt panel.  How did you start the session, load the aircraft or load a scenario? Was the flight normal until the EICAS message appeared?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now