Matt Piotrowski

40 fps jittery gameplay

Recommended Posts

I'm getting 35 to 45 fps but my game isn't smooth. When I pan around my camera jitters a little bit and doesn't feel or look smooth at all. X plane 11 is smooth but I can't get p3d v4 smooth for some reason.

Specs: I7 4770k @4.2ghz, gtx 1080 sc, SSD 500gb, 144hz monitor that overclocks to 165hz.

EDIT: Forgot to say what addons i'm using.  PMDG 747,chaseplane, active sky, asca, fsuipc, orbx global.

 

Edited by Matt Piotrowski

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Matt, smoothness in a sim comes from the monitor's refresh rate being as close to that of the framerate of the sim. Try changing your monitor's refresh rate to 30Hz, then lock your framerate inside P3D to 30 or 31 and tick Vsync. Don't use external graphics settings such as Nvidia Inspector, set settings inside P3D, don't use anything higher than 4SSAA.

  • Like 2

Share this post


Link to post
10 hours ago, Rockliffe said:

Hi Matt, smoothness in a sim comes from the monitor's refresh rate being as close to that of the framerate of the sim. Try changing your monitor's refresh rate to 30Hz, then lock your framerate inside P3D to 30 or 31 and tick Vsync. Don't use external graphics settings such as Nvidia Inspector, set settings inside P3D, don't use anything higher than 4SSAA.

I don’t know if I can change my monitor to 30hz though. I will check.

Share this post


Link to post
14 hours ago, Rockliffe said:

Hi Matt, smoothness in a sim comes from the monitor's refresh rate being as close to that of the framerate of the sim. Try changing your monitor's refresh rate to 30Hz, then lock your framerate inside P3D to 30 or 31 and tick Vsync. Don't use external graphics settings such as Nvidia Inspector, set settings inside P3D, don't use anything higher than 4SSAA.

My monitor doesn't go to 30hz. Only 165, 144, 60, and 24.

Share this post


Link to post
6 minutes ago, Matt Piotrowski said:

My monitor doesn't go to 30hz. Only 165, 144, 60, and 24.

Try it at 24hz just for kicks.

Also, under the Nvidia control panel -> Change Resolution -> Customize... you can create a custom refresh rate for your monitor. It may or may not work.

Share this post


Link to post
10 minutes ago, Chapstick said:

Try it at 24hz just for kicks.

Also, under the Nvidia control panel -> Change Resolution -> Customize... you can create a custom refresh rate for your monitor. It may or may not work.

What other settings do I change so it runs good at 24hz? Frame limit?

Share this post


Link to post
1 minute ago, Matt Piotrowski said:

What other settings do I change so it runs good at 24hz? Frame limit?

Frames Unlimited, Vsync and triple buffering on. See if that produces less stuttering. You might not like the frames running that low but it would still be interesting to see if it mitigates stuttering.

Share this post


Link to post
7 minutes ago, Chapstick said:

Frames Unlimited, Vsync and triple buffering on. See if that produces less stuttering. You might not like the frames running that low but it would still be interesting to see if it mitigates stuttering.

That feels a lot worse. When I pan it gets blurry and doesn't feel smooth. How about setting my monitor to 60hz and doing half refresh rate and frame limit?

Share this post


Link to post

I put my monitor to 60hz and frame limited p3d to 30 fps with 1/2 refresh rate and triple buffering on nvidia inspector and stutters are gone. But I get input delay whenever I pan and move around. Any way to fix this.

Edited by Matt Piotrowski

Share this post


Link to post

Please take a look at my post titled Locked Frame Rate. I managed to get a smooth simulation by limiting the FPS to 30 via NVidia Inspector. The internal FPS locker I set to 40 FPS (which will never be achieved because 30 comes first) due to scenery completeness reasons. You should try I'd say.

The screen refresh rate is another approach that gives an as good result as well - but - your mousepointer will be sluggish which may bother you like it bothered me a lot.

Share this post


Link to post
42 minutes ago, Wanthuyr Filho said:

Please take a look at my post titled Locked Frame Rate. I managed to get a smooth simulation by limiting the FPS to 30 via NVidia Inspector. The internal FPS locker I set to 40 FPS (which will never be achieved because 30 comes first) due to scenery completeness reasons. You should try I'd say.

The screen refresh rate is another approach that gives an as good result as well - but - your mousepointer will be sluggish which may bother you like it bothered me a lot.

I will try it. Thank you.

Share this post


Link to post
3 hours ago, Wanthuyr Filho said:

Please take a look at my post titled Locked Frame Rate. I managed to get a smooth simulation by limiting the FPS to 30 via NVidia Inspector. The internal FPS locker I set to 40 FPS (which will never be achieved because 30 comes first) due to scenery completeness reasons. You should try I'd say.

The screen refresh rate is another approach that gives an as good result as well - but - your mousepointer will be sluggish which may bother you like it bothered me a lot.

What HZ monitor do you have?

Share this post


Link to post

Unlimited frames will normally return a smoother flying experience in regards to framerates, but it generally comes at a cost of scenery loading, due to the CPU's priorities being set in favour of frames and not scenery. Setting framerates, will allow any 'overhead' CPU ability for loading scenery. 

Share this post


Link to post
2 hours ago, Matt Piotrowski said:

What HZ monitor do you have?

60 Hz

Share this post


Link to post

I don't know what to do anymore. I tried everything. My game just feels jittery and doesn't feel smooth. X plane is smooth and runs amazing on my computer.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now