Sign in to follow this  
Kitspace

Majestic Dash 8 Q300 Crashes FS9

Recommended Posts

Hello all!

I am a long time fight sim fan, and recently, as I was browsing through my file archives, I found this wonderful aircraft, that I had so much enjoyment with several years ago. Immediately I pulled out my FS9 installation, and tried to put it into the sim.

That is where the problems started. Whenever I try to load the Dash either from the main menu or after loading some other plane, such as the default Skyhawk, it shows up in the preview window, but upon clicking ok, the sim freezes for a few seconds and crashes, with no error messages.

I think, I can remember dealing with this issue before, but I have no idea, what I did back then to fix it.

It looks like it could be related to FSUIPC, because taking that out of the sim makes the plane load. But it is actually a requirement for the model, if I recall correctly, so I am not sure that it works properly, when it loads without it. Plus I need FSUIPC for a ton of other things...

Does anyone know what could be causing this? I would strongly appreciate any help!

Thank you!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have the latest FSUIPC version for FS9?  According to the FSUIPC developer, the FSUIPC is not needed with the Dash 8.  The FSUIPC module will crash any sim if the version is not the correct one.  It appears to me that FS9 is not properly installed or you do not have that 4th CD in your drive. 

Share this post


Link to post
Share on other sites

I do have the very latest version, and it is registered too. The sim itself works just fine, as do all other addon aircraft.

Share this post


Link to post
Share on other sites

I'm going to move this to the FS9 Forum as there are still many FS9 members and they might be able to help you.

Share this post


Link to post
Share on other sites
18 hours ago, Kitspace said:

I do have the very latest version, and it is registered too. The sim itself works just fine, as do all other addon aircraft.

I checked their website and none of the versions on their website (the latest versions) are compatible with FS9.

Share this post


Link to post
Share on other sites
7 hours ago, Jim Young said:

I checked their website and none of the versions on their website (the latest versions) are compatible with FS9.

Scroll down a bit. http://www.schiratti.com/dowson.html 

Latest version for FS9 is FSUIPC 3.999z9

Share this post


Link to post
Share on other sites

I have got the 3.999z9. It is the latest version for FS9. I also tried several older versions from my old files and returned to the current one. The effect is the same, there is no difference.

FSUIPC works fine. FS9 works fine as well.

The problem is somewhere with the MJC Dash 8. Or its incompatibility with something. FSUIPC was just a guess anyway.

Share this post


Link to post
Share on other sites

Anyone knows something about it? Can you help me please? I really love this sim and the old models, do not want to give up FS9

I just checked this on a different computer, and it works perfectly on that computer, but not on the one I normally use for simming. That is just weird... I can not figure out what the difference is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this