Recommended Posts

Been working on this a week...I think its something to do with simconnect. I am running on a network. I can't even get STBto connect. I have done this a thousand times but something very simple is screwing me up. I have a simconnect ini in the p3dv4 files folder.....I have a simconnect xml in apps/p3dv4 etc..I have a simconnect cfg on the client in document and its still not connecting. I have everything properly shared...at a loss. I am using an ip address...would a machine name be better. I am using port 500 for asn.I have formatted and reset up the server and the client and still no go. Attaching my files if anyone could take a looksy. I have responded and sent stuff to hifi support. I also mapped the hard drive from server to client... Pulling my hair out......Thank you for any help.

Sorry to paste: 

Simconnect cfg from Documents on client.. The first one is for STB...which I am working on...

[SimConnect]
Protocol=Ipv4
Address=CAROLINAONE
Port=32123
MaxReceiveSize=4096
DisableNagle=0 

[SimConnect]
Protocol=IPv4
MaxReceiveSize=4096
DisableNagle=0
Address=192.168.1.67
Port=500

Simconnect xml from app/roaming/p3dv4:

  <?xml version="1.0" encoding="Windows-1252" ?>

- <SimBase.Document Type="SimConnect" version="1,0">

  <Descr>SimConnect</Descr>

  <Filename>SimConnect.xml</Filename>

  <Disabled>False</Disabled>

- <SimConnect.Comm>

  <Disabled>False</Disabled>

  <Protocol>IPv4</Protocol>

  <Scope>global</Scope>

  <Address>192.168.1.67</Address>

  <MaxClients>64</MaxClients>

  <Port>500</Port>

  <MaxRecvSize>4096</MaxRecvSize>

  <DisableNagle>False</DisableNagle>

  </SimConnect.Comm>

- <SimConnect.Comm>

  <Disabled>False</Disabled>

  <Protocol>Auto</Protocol>

  <Scope>local</Scope>

  </SimConnect.Comm>

  </SimBase.Document>

Bottom of ASP4 export text if anything here helpful:

AS_P3Dv4_SimConnectionLog.txt
10:08:45 AM:0179-Pre Connect P3D_Connected = False
10:08:45 AM:0187-P3D Connect Pre Attempt: Instantiated = False / mConnected = False
10:08:45 AM:0257-Sim general message:Sim Msg: fsx_simconnect is NOTHING ...
10:09:06 AM:0413-Sim general message:Sim Msg: Failed to connect - Please ensure FS is running: Error HRESULT E_FAIL has been returned from a call to a COM component.
10:09:06 AM:0413-P3D Connect Post Attempt: Instantiated = True / mConnected = False
10:09:06 AM:0429-P3D Connection Attempted
10:09:06 AM:0429-Post Connect P3D_Connected = False
10:09:06 AM:0444-Pre Connect P3D_Connected = False
10:09:06 AM:0444-P3D Connect Pre Attempt: Instantiated = True / mConnected = False
10:09:06 AM:0460-Sim general message:Sim Msg: fsx_simconnect is NOTHING ...
10:09:27 AM:0611-Sim general message:Sim Msg: Failed to connect - Please ensure FS is running: Error HRESULT E_FAIL has been returned from a call to a COM component.
10:09:27 AM:0611-P3D Connect Post Attempt: Instantiated = True / mConnected = False
10:09:27 AM:0611-P3D Connection Attempted
10:09:27 AM:0627-Post Connect P3D_Connected = False
10:09:27 AM:0642-Pre Connect P3D_Connected = False
10:09:27 AM:0642-P3D Connect Pre Attempt: Instantiated = True / mConnected = False
10:09:27 AM:0642-Sim general message:Sim Msg: fsx_simconnect is NOTHING ...
10:09:48 AM:0789-Sim general message:Sim Msg: Failed to connect - Please ensure FS is running: Error HRESULT E_FAIL has been returned from a call to a COM component.
10:09:48 AM:0789-P3D Connect Post Attempt: Instantiated = True / mConnected = False
10:09:48 AM:0805-P3D Connection Attempted
10:09:48 AM:0805-Post Connect P3D_Connected = False
10:09:48 AM:0820-Pre Connect P3D_Connected = False
10:09:48 AM:0820-P3D Connect Pre Attempt: Instantiated = True / mConnected = False
10:09:48 AM:0820-Sim general message:Sim Msg: fsx_simconnect is NOTHING ...
10:10:09 AM:0966-Sim general message:Sim Msg: Failed to connect - Please ensure FS is running: Error HRESULT E_FAIL has been returned from a call to a COM component.
10:10:09 AM:0966-P3D Connect Post Attempt: Instantiated = True / mConnected = False
10:10:09 AM:0981-P3D Connection Attempted
10:10:09 AM:0981-Post Connect P3D_Connected = False
10:10:09 AM:0981-Pre Connect P3D_Connected = False
10:10:09 AM:0981-P3D Connect Pre Attempt: Instantiated = True / mConnected = False
10:10:09 AM:0997-Sim general message:Sim Msg: fsx_simconnect is NOTHING ...

 

Thanks for any help,

Warmest Regards,

Bob M.
 

Edited by unc1rlm

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Bob,

I do not think it is necessary to have the SimConnect.ini in your main P3D root folder. 

Please verify your shared folder permissions are configured correctly on the server.

These paths are:
 The FSX/P3D main installation path (for example: C:\Program Files (x86)\Microsoft Games\Flight Simulator X = default share name: Flight Simulator X)
 The FSX/P3D private application data path (for example: C:\Users\<username>\Appdata\Roaming\Microsoft\FSX = default share name: FSX)
 The FSX/P3D documents path (for example: C:\Users\<username>\Documents\Flight Simulator X Files = default share name: Flight Simulator X Files)

Instructions for setting up proper file sharing permissions:

1: Right Click on the folder and choose properties.

2: Click on the Sharing tab and click on Advanced Sharing.

3: Make sure there is a check in the box that say "Share this Folder"

4: Set your share name in the dropdown box.

5: Click on the Permissions button.

6: Make sure there is an entry for "Everyone" in the Share Permissions field.

7: If there is not an entry for this click on the Add button.

8: Type Everyone in the field box and click on the check names button and hit OK.

9: In the Share Permissions field there should now be an "Everyone" entry. 

10: Highlight Everyone and make sure all the allow boxes below are checked and hit OK.

11: Hit Ok again on the Advanced Sharing box.

12: Go to the Security Tab and highlight Everyone to verify there are check marks in the allow column.
    The Special Permissions does not require a check mark.
    
13: Hit Close.

We have a comprehensive guide to networking and SimConnect in our User Guide. The guide will launch when the question mark on the Active Sky app is pressed.  Please see Networked Configuration.

Robert

Share this post


Link to post
Share on other sites

Thanks Robert.. Jordan contacted me and would you believe it was this:

[SimConnect]
Protocol=IPv4
MaxReceiveSize=4096
DisableNagle=0
Address=192.168.1.67
Port=500
 

As soon as I corrected it on my client...ASN went green after all this for days and I don't believe this is the format suggested in the manuals or anywhere else I have read.

This is what I had

[SimConnect]
Protocol=IPv4
Address=192.168.1.67
Port=500
MaxReceiveSize=4096
DisableNagle=0

Oh well live and learn..maybe someone else can glean something from this 🙂

Best Wishes Robert, Daveo and everybody at HiFi!!!

Bob M.

 

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the reply Bob. Glad that it’s all sorted out now. I’ll check our documentation and test the SimConnect formatting and see if changing the order of things will have an effect.

I will pass the message on to Jordan. 

All the best,

Robert

 

 

Share this post


Link to post
Share on other sites
19 hours ago, unc1rlm said:

Thanks Robert.. Jordan contacted me and would you believe it was this:

[SimConnect]
Protocol=IPv4
MaxReceiveSize=4096
DisableNagle=0
Address=192.168.1.67
Port=500
 

As soon as I corrected it on my client...ASN went green after all this for days and I don't believe this is the format suggested in the manuals or anywhere else I have read.

This is what I had

[SimConnect]
Protocol=IPv4
Address=192.168.1.67
Port=500
MaxReceiveSize=4096
DisableNagle=0

Oh well live and learn..maybe someone else can glean something from this 🙂

Best Wishes Robert, Daveo and everybody at HiFi!!!

Bob M.

 

Thanks for this one. Gamechanger for AS16 and FSX as well. Bought AS16 whenever it came out, never got it to work. Just settled back with ASN until now.

Thanks again!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now