aussibob1

(resolved) GTN750 in A2A C172 Freezes After 15-20 Seconds

Recommended Posts

Problem

RXP GTN750 for P3D4 purchased recently. It seems to have installed properly in A2A C172 - it shows up OK in the VC panel, powers up OK and I can even start clicking "Continue" to which the GTN750 responds by changing pages. However after 15-20 seconds the mouse stops responding and panel/GTN freezes (still showing on monitor). Have tried waiting and waiting in the vain hope that it would un-freeze - it didn't. CTL-ALT-DEL does not work and a hard restart is required to get Windows working again. Identical issues with A2A C182 - appears then freezes.

System

Windows 7 Ultimate
I7 950 4 Core Not overclocked  (this PC is primarily used for VC panel only display and software that must run on the master machine)
8Gb RAM
Nvidia GTX1060 6Gb
Running Prepar3d v4.2
No problem devices or conflicts 
Status of all system drivers shows as OK

Other networked PC is more capable I7 with GTX1080ti driving 3 monitors - all works well with aircraft not having GTN750 installed


Diagnostics (so far)

rxpGTNgau.log

18/11/29 11:36:43.480 05528 -    ] # rxpGTN.dll version 2.5.8.0
18/11/29 11:36:43.480 05528 INFO ] 


rxpGTN__menu.log

18/11/29 08:04:11.111 03052 -    ] # rxpGTN_menu.dll version 2.5.8.0
18/11/29 08:04:11.112 03052 INFO ] edit panel: C:\Users\User\Documents\Prepar3D v4 Add-ons\A2A\SimObjects\Airplanes\A2A_C182\panel\panel.cfg


rxpGtnSim.dll.log

18/11/29 11:36:47.795 05528 -    ] # rxpGtnSim64.dll version 2.5.9.0
18/11/29 11:36:47.794 05528 INFO ] 
18/11/29 11:36:50.619 03444 INFO ] 
18/11/29 11:37:38.902 04392 INFO 

rxpGTN.xpl.log

18/11/27 11:01:05.821 05804 -    ] # win.xpl version 2.5.9.0
18/11/27 11:01:05.821 05804 INFO ]  

............................................................

The Garmin Trainer functions properly stand alone

............................................................

Win7 Reliability Monitor shows
    No Windows Failures
    No Application Failures
    Miscellaneous Failures are only those assoc with hard shutdown and reboot after Sim/GTN Freeze/hang
    All Information events are normal

Win7 Event viewer
    Windows Logs > Application      Information only - nil of interest
    Windows logs > System        Errors and Criticals shown are due to hard shutdown after freeze/hang    

............................................................

SFC /scannow finds no integrity violations

............................................................

No anti-virus or firewall is present on system

............................................................

Performed a Clean Boot in Win7 and ran P3D4.2 - Same problem occurred after 15 seconds or so

............................................................

Hope someone has a solution or something else I might try.


Regards from Melbourne, Australia
Aussibob


P.S. My RXP GTN750-650 combo works flawlessly in X-Plane 11 and that's why I purchased the P3D version of the 750

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

Thank you for the detailed report and the log files in your request for support, this is the most valuable tool to get started with!

Is this with P3D 4.4 or 4.3? It is supposed to automatically support new 4.x versions except for the autopilot functions, but we are working on the update to support 4.4 and it is not released yet (it is coming up, we're targeting releasing the update today).

Nevertheless, the log files show you are using a 2.5.8 gauge with a 2.5.9 GTN simulation. The installer has either failed to overwrite the already installed 2.5.8 gauges, or, you have manually copied the gauges and the simulator is using the copy instead of the original which it finds with the add-on.xml method.

Or it is because you've installed the 2.5.9 X-Plane and the 2.5.8 FltSim.

Can you confirm?

Share this post


Link to post
Share on other sites

Hi Jean-Luc

I'm actually running Prepar3d v4.2. I must say I had some difficulty getting the gauge to run initially and probably messed up the installation in my efforts  to get it going. I guess an un-install and re-install of the GTN is in order. It was on my mind to upgrade to P3D v4.3 (not 4.4 yet) - would you advise this, and is there anything I need to know about the uninstall-reinstall of the GTN to make it go smoothly?

Bob 

Share this post


Link to post
Share on other sites

Hi,

Uninstalling RXP files is not necessary unless you have manually copied gauge files in specific aircraft\panel folders. Otherwise, it is just a matter of running the newest RXP installer over. You might want to reboot the computer prior this just to make sure there is no locked files from a previous FS session, although our installers should offer the possibility to reboot-finish-install in this case.

As for P3D, just hang in there, we're working on the update compatible with P3D4.4. As a matter of fact, it has been ready a couple hours after P3D4.4 release, but we were also already adding a few more features to our products, and we've also had an interesting request from FlySimWare we're implementing, hence a little delay.

Share this post


Link to post
Share on other sites
3 hours ago, RXP said:

As for P3D, just hang in there, we're working on the update compatible with P3D4.4. As a matter of fact, it has been ready a couple hours after P3D4.4 release, but we were also already adding a few more features to our products, and we've also had an interesting request from FlySimWare we're implementing, hence a little delay.

Any chance for an interim release just to get 4.4  compatibility?

Share this post


Link to post
Share on other sites

@notmyidea The GTN and GNS V2 are already compatible with P3D 4.4, except the autopilot. We're almost done with the features though so this is coming up ASAP.

Share this post


Link to post
Share on other sites

Jean-Luc

The issue has not been resolved. As you suggested, I re-installed the GTN750 after I downloaded v2.5.9.0 via the e-commerce installer re-install option. Used the A2A C172 Acft Configurator to put gauge into the C172 panel. Started P3D4.2 - The C172 panel is there with the GTN750 working - I can click through to the map and other functions on the 750 until the panel freezes in about 20 seconds. Hard restart required to get out. Here's the log files.  

rxpGTN.gau.log

18/12/02 02:52:42.940 02276 -    ] # rxpGTN.dll version 2.5.9.0         ((prevoiusly showed as v 2.5.8.0))
18/12/02 02:52:42.939 02276 INFO ] 

rxp.xpl.log

18/11/27 11:01:05.821 05804 -    ] # win.xpl version 2.5.9.0
18/11/27 11:01:05.821 05804 INFO ]

rxpGTN_menu.dll.log

18/11/30 23:39:08.232 01652 -    ] # rxpGTN_menu.dll version 2.5.8.0
18/11/30 23:39:08.233 01652 INFO ] edit panel: C:\Users\User\Documents\Prepar3D v4 Add-ons\A2A\SimObjects\Airplanes\A2A_C182\panel\panel.cfg

I do not know why the menu.dll.log continues to reference the A2A_C182 because that acft has been uninstalled. Also, the file properties for 
rxpGTN_menu.dll in c:/Program Files (x86)/RealityXP/GTNSimulation/FltSim/64 show that file to be v2.5.9.0


rxpGTNSim.dll.log

18/12/02 02:52:47.283 02276 -    ] # rxpGtnSim64.dll version 2.5.9.0
18/12/02 02:52:47.282 02276 INFO ] 
18/12/02 02:52:56.307 01172 INFO ] 

What can I try now?
Bob

Edited by RXP

Share this post


Link to post
Share on other sites

Hi,

The rxpGTN_menu log file updates only when used. You are reading older entries (see the first columns are UTC date time).

As for the 'freeze', please see our updated P3D4.4 announcement at the top of the forum!

TLDR; there is a real bug in the trainer, not our code (more on this in the aforementioned discussion).

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now