frankyfirstt

MakeRwys and ORBX Probs

Recommended Posts

Hey Guys. I have a Problem.

I don't get MakeRwys and the ORBX FTX VECTOR Configuration Tool to work anymore. 

What MakeRwys shows:

Make-Rwys-1.jpg

 

This Programm is run as Administrator. Also the ORBX FTX VECTOR Configuration Tool does not seem to see any Airports anymore. Yesterday everything was fine. Nothing changed on my Config in that time. 

BTW P3D starts just fine.

U guys have any Idea?

Edited by frankyfirstt

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Do you have Lorby_Si's Addon Manager?  Did you run the tool to place all of your addons into the scenery.cfg, then run make runways and then run the tool to put the scenery back into the Addon Manager? 

Share this post


Link to post

Yes, I use it for a long time. All Add-ons work just fine just MakeRwys and Vector Config tool suddenly stoped?

Share this post


Link to post

@frankyfirstt
Are you running MakeRwys.exe in your Prepar3d root directory?

Edited by BillS511

Share this post


Link to post

Maybe something happened to your Microsoft .Net 4.5.1 install

Share this post


Link to post
6 hours ago, jimcarrel said:

Maybe something happened to your Microsoft .Net 4.5.1 install

I tried to reinstall all net framework components but still no luck 😞

Thx for trying to help and ur tip 🙂

Share this post


Link to post

Okay I got it working again 🙂

The problem was the LorbySceneryExport.exe. After removing that file from the P3D directory everything works just fine again.

 

Thx to all!

Share this post


Link to post
2 hours ago, frankyfirstt said:

The problem was the LorbySceneryExport.exe. After removing that file from the P3D directory everything works just fine again.

No it probably doesn't. AFAIK if you remove that tool, Makerunways will only generate files for the scenery.cfg and ignore everything that has been installed with add-on.xml files.

I suggest that you contact MakeRwys support. If there is some systematic issue, Pete should know about that.

Best regards

 

Share this post


Link to post
2 minutes ago, Lorby_SI said:

No it probably doesn't. AFAIK if you remove that tool, Makerunways will only generate files for the scenery.cfg and ignore everything that has been installed with add-on.xml files.

I suggest that you contact MakeRwys support. If there is some systematic issue, Pete should know about that.

Best regards

 

2

Thanks for ur answer. I know it doesn't generate that file because it was stated in the readme. The solution was to remove LorbySceneryExport.exe and then run MakeRwys.exe once. I copied the LorbySceneryExport.exe back then again and now it's working. 

In fact, it was the LorbySceneryExport.exe what made that Problem for me.

Share this post


Link to post

Okay, false alarm. It stopped working again. I followed the Readme. All files are in the P3D Main folder.

Again:

Make-Rwys-1.jpg&key=530f603ef362f7a5b6cd

 

It creates a MakeRwys_Scenery.cfg with the size of 1kb. When I open the file with Notepad++ it shows just following:

 

Quote

[General]
Title=Prepar3D Scenery
Description=Prepar3D Scenery Areas Data
Clean_on_Exit=TRUE
Active=FALSE

[Area.001]
Title=
 

 

My P3D Main Folder shows following:

 

yOjSRc4.jpg

I'm out of Ideas...

Edited by frankyfirstt
Additional Information

Share this post


Link to post

You have an error in your scenery configuration that is tripping up the scenery export process. Where, how, in which file is impossible to tell from here. Could be anything, from the scenery.cfg itself to a broken add-on.xml at layer 1 or 2.

If you delete the empty .cfg and the LorbySceneryExport.exe, then Makerunways should complete - but the result will be missing all the external add-on.xml based sceneries. 

Again, you really should contact Pete Dowson and ask for support. If this is a common problem, he should be familiar with it and maybe have a solution.

But if it is a unique problem with your local configuration, you need to take steps to figure out what it is yourself. If you are using the P4AO tool, then try to create a temporary scenery.cfg file and check if it displays an error of some kind. It uses the same logic as the SceneryExport thing, but it has more options to alert you of possible errors.

That "everything works fine" is often a false perception. The simulator just ignores what it can't make sense of (or it crashes).

Best regards

Edited by Lorby_SI

Share this post


Link to post
1 hour ago, Lorby_SI said:

You have an error in your scenery configuration that is tripping up the scenery export process. Where, how, in which file is impossible to tell from here. Could be anything, from the scenery.cfg itself to a broken add-on.xml at layer 1 or 2.

If you delete the empty .cfg and the LorbySceneryExport.exe, then Makerunways should complete - but the result will be missing all the external add-on.xml based sceneries. 

Again, you really should contact Pete Dowson and ask for support. If this is a common problem, he should be familiar with it and maybe have a solution.

But if it is a unique problem with your local configuration, you need to take steps to figure out what it is yourself. If you are using the P4AO tool, then try to create a temporary scenery.cfg file and check if it displays an error of some kind. It uses the same logic as the SceneryExport thing, but it has more options to alert you of possible errors.

That "everything works fine" is often a false perception. The simulator just ignores what it can't make sense of (or it crashes).

Best regards

Okay but how / where can i contact him?

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now