Howellerman

Cyclic Erratic Behavior in P3DV4.4

Recommended Posts

Hello!

I have been fighting this for a couple of weeks to no avail, so I thought I would try to tap the accumulated wisdom of the AVSIM members to see if they have seen it before.

I am getting cyclic erratic behavior in several of my aircraft models, ranging from simple (Carenado) to complex (A2A and Vertx). There are likely others but they have not been so evident... yet.

  • Carenado B350i has a repetitive altitude warning of FORTY no matter what state the aircraft is in: cold and dark, ready to fly, in the air and flying. It is on a one-second timer and it active even when the simulator is PAUSED!
  • Vertx DA62 has the left engine visually and aurally "stuttering". Instrumentally and physically, I can start the aircraft and fly it, but the visual/aural state the left engine anomaly is consistent. It is also consistent to passenger views! Sean has been very receptive, but is drawing a blank on the cause. This is no surprise since it seems to be endemic to my system, not his aircraft model. Since it is a "stutter" it is impossible to time accurately, but I would not be surprised if it was one second interval.
  • A2A V35 Bonanza. The heading indicator has a consistent "blip" to the right and back, no matter the aircraft state. It is on a one-second timer. Unlike the Carenado, it goes still when the simulator is paused.
  • RealAir Legacy. There is a very pronounced "click" every one second. It sounds like an instrument switch sound, such as SoftKeyPressGPSNew.wav (in Panel Sounds). Only audible in "interior view". 

I clearly have a spurious event/signal from something that is triggering these diverse symptoms, and to date I have:

  1. Uninstalled and reinstalled Prepar3d Client.
  2. Re-calibrated FSUIPC.
  3. Disabled/enabled FSUIPC (multiple times).
  4. Unplugged my Xbox controller.
  5. Disabled all USB attached controls by unplugging the USB switch.

Nothing changes.

It is driving me boog fook! I am trying to figure out what device/instrument would be on a one-second timer that may cause such erratic behavior but I am running out of tails to chase.

Any suggestions?

Thanks!

John Howell

System Specs

  • i7-9700K, 32GB RAM
  • EVGA GTX 1080
  • Samsung C34F791 34" monitor
  • SanDisk SSD boot drive, simulator on Samsung EVO 970 M2 
  • Thrustmaster 1600
  • Logitech Rudder
  • Logitech Yoke and throttles
  • XBox Windows controller
  • P3DV4.4, Active Sky, Sky Force (textures only), Chase Plane, FSUIPC (all up to date)

It is really a nice system to fly GA aircraft (the XBox controller with Chase Plane is terrific), but something is happening and it (or my awareness) seems to be getting worse!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Check *both* dll.xml files, and also both exe.xml files and make sure you don't have something doubled up in there.  If that's not it, try disabling everything and bringing the dll and exe programs back one at a time.  Same thing for any acft/gauge add-ons brought in via the two add-ons.xml files.

The once-per-second rate doesn't sound like an input device (e.g. a stuck key or a phantom axis assignment), but just in case, I'd still look through the axis assignments of every listed input device for unintended axes just to be sure.

Regards

Share this post


Link to post

Heya Bob, 

Thanks for the response. However, I am at a complete loss as to what *both* means. I only have one ..\appdate\roaming\Lockheed Martin\Prepar3d v4 folder which contains one each of dll.xml and exe.xml files. A search of the high-level userid directory also yields only one each.

Good point on bringing things back incrementally. I have only been disabling FSUIPC, although cycling through the other three (Cmeteoxml,  Carenavigraph, and as_connect) does not sound that rewarding.

As frustrated as it has been I am leaning more and more to a complete mind-wipe of P3D and starting over. My original goal was to "curate" every installed component, but my eagerness/impatience got the better of me and I installed my aircraft and Orbx scenery in "batches". Lord knows what may have happened, but impatience is a proving ground for mistakes. 

  • Like 1

Share this post


Link to post
9 hours ago, Howellerman said:

I only have one ..\appdate\roaming\Lockheed Martin\Prepar3d v4 folder which contains one each of dll.xml and exe.xml files.

This is the old default location that some developer's still use (do not delete but rename).  The new default in P3D is in the same folder as the scenery.cfg for P3D.  If this one is deleted or renamed, it is rebuilt with the default.  See the AVSIM CTD Guide for more information.

Share this post


Link to post

One directory where the dll.xml and exe.xml files are found is considered the "traditional" location:

%APPDATA%\Lockheed Martin\Prepar3D v4

The other directory where dll.xml and exe.xml files are to be found is:

%PROGRAMDATA%\Lockheed Martin\Prepar3D v4

In practice, with most P3D installations including even a handful of the more popular add-ons, you'll find both are in use.  Nothing should be referenced in both places.

Regards

Share this post


Link to post

Thank you, Jim and Bob!

I found *both* *.xml files, and there are some duplicates. I will remove one and see what happened.

Interestingly, I observe that both FSUIPC V5 and Chase Plane use the "legacy" xml files. Old habits die hard...

Thanks again - I will let you know what happens. Would love to mark this one as [SOLVED]!

JKH

Share this post


Link to post

Gentlemen, 

Unfortunately, no love - all symptoms remain. 

I am kicking myself more and more for not doing a curated installation, and I think I will take this coming week to do a mind-wipe on my simulator. Being a long time shade-tree mechanic for bikes, cars, and boats this is driving me nuts - it just seems so non-deterministic.

Thanks for the help - I will let you now what I find out during the reinstall.

JKH

Share this post


Link to post

Hello Jim and Bob, 

Just FYI - the mind-wipe worked as expected and I was able to reinstall each of the affected aircraft and now they work just fine.

I will now curate EVERY subsequent install to see if the problem manifests itself again (hopefully not). 

Thanks again for the help!

JKH

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now