ark

GTN MasterDevice ini file setting

Recommended Posts

Posted (edited)

It seems that nothing I do can keep the MasterDevice ini file setting to be true. I am using a single GTN 750 in Win10/P3dv4.4. I have tried using the 2D popup configuration tool, have set MasterDevice = true in the GTN ini file, have even tried locking this setting in the GTN ini file, but for example,  if I reload the plane for some reason the MasterDevice setting is back to false in the ini file -- VERY frustrating.

When using the 2D popup config tool, I click on the  MasterDevice setting to set it to true (light blue) and then click on Accept which closes the 2D popup, but nothing has changed in the sim. Sometime the setting may seem to be OK for a short while, then it is back to false.

What might cause this setting to be reset to false?  What am I missing?

Thx,

Al

Edited by ark

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)
On 2/28/2019 at 9:56 PM, ark said:

if I reload the plane for some reason the MasterDevice setting is back to false in the ini file -- VERY frustrating.

Pending help from RXP it would be helpful for them to know: Is this happening in just one plane model, or in all.  And if its a specific model, is it default or add on.  If add on how is the model otherwise outfitted with avionics.

Edited by fppilot

Share this post


Link to post
Share on other sites
2 hours ago, fppilot said:

Pending help from RXP it would be helpful for them to know: Is this happening in just one plane model, or in all.  And if its a specific model, is it default or add on.  If add on how is the model otherwise outfitted with avionics.

Good point.

I have the aircraft reload resets MasterDevice problem with the Flysimware Lear35 and Falcon50 aircraft -- the only aircraft I use these days.  Both aircraft have the GTN750 installed in the panel. Since as far as I know no one on the Flysimware site, or this site, have reported this particular problem, I assume at this point it is unique to my setup. What I am looking for is some insight or ideas on what might possibly be causing the problem.

Here's one detailed example of what is happening:

1. Opened Win10 P3dv4.4, loaded the Falcon 50.

2. Checked the GTN ini file and the 2D popup, both said MasterDevice=true

3. Hit the aircraft reload key (standard sim reload function), checked the ini file and 2D popup, both said MasterDevice=false

4. Set MasterDevice = true in the 2D popup, hit Accept to close the popup.

5. Immediately reopened the 2D popup, MasterDevice= false again, same for the ini file.

Might be helpful to understand how/when the 2D popup updates the GTN ini file.

I do not seem to have this problem in FSX_SE.

Al

Share this post


Link to post
Share on other sites

RXPs Jean-Luc is suffering from a finger or hand injury that is limiting for now his ability to type.  Looking at your messages and asking you to provide more information is on my part as a fellow end user an attempt to shorten the time to find the cause and a solution for your issue when he is back able.. So bear with me as I continue to ask for more information.  I believe that when provided it may preclude some later back and forth message sequences.

A recent GTN release introduced a new feature for controlling the .ini file.  Would you confirm the release version that you are having this issue with

Would you please read the GTN User Manual section on log files.  For the current version it is on page 18 of the manual. It may help if you look in the specified file locations and see if there are those log files on your system.  If so, be prepared to post them here for evaluation.  Note they may be lengthy. When posting them, it is best to use the "spoiler" feature of the forums here on Avsim.  Just find in the message control section the icon just to the left of the Font button.  It is shaped like an eye.  Click on it and post your file contents in the window that opens.  Once the Reply has been submitted that spoiler section will be in an expandable section of the message.  That way it shortens the initial length of the topic as others scroll it.  The resulting hidden contents are easily opened for review.

 

Share this post


Link to post
Share on other sites
22 hours ago, fppilot said:

 

A recent GTN release introduced a new feature for controlling the .ini file.  Would you confirm the release version that you are having this issue with

 

I have the latest version 2.5.13.

Share this post


Link to post
Share on other sites
Posted (edited)
18 minutes ago, ark said:

I have the latest version 2.5.13.

OK.  Suggest you look for the .log files referenced in the manual. Everything you can have at the ready will be a jumpstart to help RXP support you.

Edited by fppilot

Share this post


Link to post
Share on other sites

Bumping this topic for support review...

Share this post


Link to post
Share on other sites

Hi,

@fppilot thank you for helping out and gathering as much info as possible. This is much appreciated.

@ark you mention it works fine in FSX-SE but not in P3D4, which makes me wonder.

There is no difference in the code handling this between our 32bits and 64bits versions, so I'd suspect something else if playing behind.

Is the master device setting sticky when using the default B58 (or any other default) in P3D4?

Besides, you've also mentioned the 'fuel' issue, therefore I've sent you a PM with new bits. This might also prove working better for the 'Master Device' setting.

Share this post


Link to post
Share on other sites

Jean-Luc,

I'll do some more experimenting  and see how it goes.

Thanks for the support.

Al

Share this post


Link to post
Share on other sites
Posted (edited)

Hi,

we're just released new GTN and GNS V2 updates which may work better.

Edited by RXP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now