Recommended Posts

Hi guys

Didn't know where to post this, so hoping here is ok....

I recently purchased Active Sky for X-Plane 11.  However, I cannot either activate it, nor register for help on their forums, nor create a ticket with HiFi Simulations!!!

Every time I try, I never receive their allegedly sent confirmation email:-(  Obviously, I keep checking my spam folders too, but not getting anything from them:-(

Does anyone perhaps have an email address for support?

OR....  HiFi Sim, if you see this please help

Many thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Posted (edited)

I have no problems with HiFi sky and Active-Sky for X-plane.

This is my latest email adress from HiFi Sky:  support(at)hifisimtech(dot)com

forum: https://hifisimtech.com/forums/

Succes

Jo va Bra

Edited by charliearon
fixed email to prevent spam

Share this post


Link to post
Share on other sites

Are they whitelisted in your AV? I have run into that a few times.

Share this post


Link to post
Share on other sites

Thanks guys will try the email.

Dont use addon AV software so no white list

Share this post


Link to post
Share on other sites
Posted (edited)
59 minutes ago, Jovabra said:

I have no problems with HiFi sky and Active-Sky for X-plane.

This is my latest email adress from HiFi Sky:  support(at)hifisimtech(dot)com

forum: https://hifisimtech.com/forums/

Succes

Jo va Bra

This email address worked. Had an auto response so far. Thanks my friend much appreciated:-)

Edited by charliearon
fixed email to prevent spam

Share this post


Link to post
Share on other sites

Add info: I bought ii by: JustFlight (authorized reseller). So i've got all the information from their.
So look in your e-mail from your reseller.

Success

Share this post


Link to post
Share on other sites

That's interesting....  As soon as I post on here, I've suddenly just received my email verification code from ActiveSky lol

Came in 10 mins ago:-)

Share this post


Link to post
Share on other sites

Thanks for the help guys - looks like im sorted now.  Avsim to the rescue once again:-)

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now