Jump to content

Recommended Posts

Posted (edited)

Hello,

I was wondering: will there be an update for the FFa320? MCE doesn't work anymore and crashes X-plane 

Edited by isaiah

Share this post


Link to post
Share on other sites
1 hour ago, isaiah said:

Hello,

I was wondering: will there be an update for the FFa320? MCE doesn't work anymore and crashes X-plane 

It will be updated once FF releases an official update.

The reason is very simple. The package we have to work with (from Aerosoft) doesn't update to Betas.

Meanwhile, it works with latest FF A320 V 0.9.7

 

See this thread.

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

Sorry but I did a fresh install of FF320 0.9.7 and a fresh install of MCE 1.3.85 with CTD. 

I tried to start the app directly from menue inside XP11 and dirctly via app on desktop. It has failed several times.

Need help or have to de-install MCE which would be a shame.

 

 

Edited by uhecht

Share this post


Link to post
Share on other sites

Sorry but I did a fresh install of FF320 0.9.7 -2267 with CTD. 

I tried to start the app directly from menu inside XP11 and directly via app on desktop. It has failed several times.

 

Will download fresh from the org to see what i get.

 

Share this post


Link to post
Share on other sites

It is really frustrating and I gave MCE another try.

So what did I do:

  1. Deinstallation of MCE,
  2. Hard delete of any remaining files in the core folder of MCE
  3. Fresh install of FF320 via X-Updater to version 0.9.7-2267
  4. Fresh download of MCE V1.3.85
  5. Installing FF320
  6. Starting XP11 with no problems
  7. Installation of MCE
  8. Configuration and registration via license key file
  9. staring XP11, FF320 -all works fine
  10. starting MCE and observing
  11. MCE starts normal until the point when the app is searching for any changes
  12. CTD ->MCE still running but XP11 has crashed down

So what the heck is going on?

Seems to be that version 0.9.7-2267 is really not supported.

On version 0.9.4 everything run fine- pls give the clue!

 

Share this post


Link to post
Share on other sites

With clean FF version 9.7.0 Crash! If I install BSS Soundpack, no crash but MCE is asking for missing DLLs and afterwards there is no respond to voice commands!

Share this post


Link to post
Share on other sites
1 hour ago, delfin8896 said:

With clean FF version 9.7.0 Crash! If I install BSS Soundpack, no crash but MCE is asking for missing DLLs and afterwards there is no respond to voice commands!

OK, this one is different from the issues with Beta.

Most likely cause, incomplete installation of MCE dlls into X-Plane root folder.

Go to X-Plane 11 main installation folder and check yopu have <MCE dlls> folder containing 2 subfolders, with about 21 dlls inside each.

Otherwise you're likely to get a simulator freeze with ANY aircraft. 

If the <MCE dlls> folder is missing or has no dlls inside it, please proceed as follows.

Go back to downloaded unzipped file and look under \Resources\Files\X-Plane\ folder.

Copy entire <MCE dlls> folder and paste it to \X-Plane root folder\

Share this post


Link to post
Share on other sites

This is the first thing I checked! I am not a newbie! The relevant xmcffA3X.dll in 64bit Folder is dated 10th of October 2018.

Share this post


Link to post
Share on other sites
5 hours ago, delfin8896 said:

This is the first thing I checked! I am not a newbie! The relevant xmcffA3X.dll in 64bit Folder is dated 10th of October 2018.

Just in case, if you had to manually copy and paste those dlls, it's important you pay attention to putting the 64 Bit dlls in \X-Plane\MCE dlls\64 Bit\ folder (and copying them from the correct folder too), as there is no way for user to tell them apart.

For instance, if you have the 32 Bit dlls in \64 Bit folder\, although they are right there, 64 Bit X-Plane won't be able to see them as it can only load 64 Bit dlls.

In any case, it will be looked at with latest stable FF A320 0.9.7 and also latest XP-11.30 beta 5 in case you're on that one.

Share this post


Link to post
Share on other sites

The latest X-Plane on steam is XP-11.33 beta 1. This is the version in use here. MCE for now is 1.3.8.5. The files are there from the installation process... no manually copied files. Thanks in advance for looking in that specific problem with the FF320.

Share this post


Link to post
Share on other sites
On 4/25/2019 at 5:33 PM, delfin8896 said:

The latest X-Plane on steam is XP-11.33 beta 1. This is the version in use here. MCE for now is 1.3.8.5. The files are there from the installation process... no manually copied files. Thanks in advance for looking in that specific problem with the FF320.

Could you please contact support via e-mail? Thanks

Share this post


Link to post
Share on other sites

When is this problem going to be solved? Using FFA320 v1.01, X-Plane 11.33, MCE current...

Please fix this!

Share this post


Link to post
Share on other sites

OK guys.

 

Somehow, after re-downloading package from Aerosoft, now have a package that triggers sim CTD when MCE is started.

We should be able to work it out.

Will keep you updated.

 

Share this post


Link to post
Share on other sites

We now have the full picture on this.

After spending about 5 months interfacing the FF A320 using its very complex and unusual SDK interface, it appears, sometime last month, they decided to drop it for a new one.

Only observed the crash first time after getting what seems to be an updated package from Aerosoft.

Therefore can't tell exactly at which point (exact version of the aircraft) the rug was pulled. That's why it works for some and not for others.

You may want to read this thread.

https://forums.x-plane.org/index.php?/forums/topic/176826-difficult-to-make-the-new-version-working/&tab=comments#comment-1637629

The good news is that we can adjust to whatever way they want us to connect to their aircraft.So, it's not the end of FF A320 support.

The new interface is in line with what we are used to with FlightFactor aircraft.

It's just a shame it went unnoticed for so long on our side, as only those eager on Betas were hit initially.

Therefore, unless you go back to a much older version (which has the old SDK), , for now I doubt you can use MCE with that aircraft on its latest Betas.

It will take time to get it going on the new interface (which will then require all users to use the more recent versions of the aircraft, and it will be done as quickly as possible. I mean priority task.

  • Like 3

Share this post


Link to post
Share on other sites

It's now on final approach

  • Like 3

Share this post


Link to post
Share on other sites
1 hour ago, dbrooke said:

Wonderful, it's a bit lonely in the A320 cockpit at the moment.

Thanks for the accolade.

Just landed, co-pilot waiting at the gate for another ride.

He doesn't mind overtime, and is always available. 😋

  • Like 1

Share this post


Link to post
Share on other sites

I have installed the new version.  When I ask for 'Electrical Power with APU' Clive starts the flow.  About halfway through I get a dialog saying I should restart X-Plane and wait for a minute.  I have tried this, it doesn't seem to make a difference. If just click OK on the dialog Clive carries on after a short while.  But upon inspection, I find the APU has not been started.  I would not like Clive to face any disciplinary action.

Share this post


Link to post
Share on other sites
1 hour ago, dbrooke said:

I have installed the new version.  When I ask for 'Electrical Power with APU' Clive starts the flow.  About halfway through I get a dialog saying I should restart X-Plane and wait for a minute.  I have tried this, it doesn't seem to make a difference. If just click OK on the dialog Clive carries on after a short while.  But upon inspection, I find the APU has not been started.  I would not like Clive to face any disciplinary action.

Thanks for the report.

Suggest the following.

Go to <Command> tab in MCE user interface and click <Voxscript>

Select flow"Electrical power with apu" and click <Edit>

In next screen, click <Edit script commands>

You'll then see all command Fo will be executing as part of the script.

Instead of triggering the complete flow, test each command one by one until you eventually get the crash.

Once you know the command that's causing it, remove it from the flow.

It could be that FF has removed the variable the item is linked to in your own aircraft Beta.

Will test on our side too.

 

Share this post


Link to post
Share on other sites
Posted (edited)

It's rather strange, the 'battery on' command is not being obeyed, so he can't switch the APU on.  I get the dialog pop up during the 45 sec pause. I think the 'APU on' command can't be enacted because the batteries aren't on when the command is reached so it assumes the A320 isn't behaving.

Edited by dbrooke

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...