Jump to content

Sign in to follow this  
RXP

[10APR21] GTN Trainer download links

Recommended Posts

Hi,

Garmin is releasing a new GTN trainer, usually every 6 months.

However, our software installer will most likely fail downloading the latest trainer automatically reporting a "404" error (file not found), because Garmin is usually removing the previous GTN trainer all-in-one installer from their servers.

We're doing our best to update our GTN products and make them compatible in a timely manner and we're sorry for this unavoidable inconvenience.

In the meantime, you might be able to download the latest compatible trainer as individual components, or the GTN trainer 6.21 from the link at the end of this post.

NB: Download all the following files, then double click the '.msi' files to install

 

GTN Garmin Trainer 6.62.4

http://download.garmin.com/avtrainer/gtn/6.62.4.0/GTN.Setup.msi

GTN Trainer Launcher 3.0.1.0 with AIRAC 2004

individual components:

http://download.garmin.com/avtrainer/launcher/3.0.1.0/Launcher.Setup.msi
http://download.garmin.com/avtrainer/databases/3.0.0.0/Databases.Setup.msi
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs1.cab
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs2.cab
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs3.cab
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs4.cab
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs5.cab
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs6.cab
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs7.cab
http://download.garmin.com/avtrainer/databases/3.0.0.0/DBs8.cab

 

GTN Trainer 6.62.3 with AIRAC 1909

all-in-one:

http://download.garmin.com/avtrainerfull/2.5.0.0/GarminTrainerSetup_2700.zip

individual components:

http://download.garmin.com/avtrainer/launcher/2.7.0.0/Launcher.Setup.msi
http://download.garmin.com/avtrainer/databases/2.6.0.0/Databases.Setup.msi
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs1.cab
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs2.cab
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs3.cab
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs4.cab
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs5.cab
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs6.cab
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs7.cab
http://download.garmin.com/avtrainer/databases/2.6.0.0/DBs8.cab
http://download.garmin.com/avtrainer/gtn/6.62.3.0/GTN.Setup.msi

 

GTN Trainer 6.50.1

http://download.garmin.com/avtrainer/launcher/2.3.1.0/Launcher.Setup.msi
http://download.garmin.com/avtrainer/gtn/6.50.1.0/GTN.Setup.msi

NB: It runs fine with the latest database (Databases.Setup.msi and DBs#.cab links above).

 

GTN Trainer 6.21

This is the oldest compatible GTN trainer we're currently supporting.

http://download.garmin.com/software/GTN_GDU620PCTrainer_6211.zip

NB: It runs fine with the latest database (Databases.Setup.msi and DBs#.cab links above).

Edited by RXP
  • Like 1

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Hi, 

Always good news: a new version of the Garmin trainer. However I could not find the update in the Garmin site. 

What is new in the latest version? Update of the nav database?

Cheers, Marc.

Share this post


Link to post
Share on other sites

Hi,

The RXP GTN is already compatible with GTN trainer 6.62.1. It is not a new version but the latest, and this post will be updated whenever there is a new version.

This post is to help downloading the latest compatible trainer version whenever Garmin is releasing a new trainer and while waiting we offer an updated RXP GTN.

 


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

@Gixxar Hi, it seems to be working fine on our end. Is this the only file not working on your end?


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

updated with newest DB.

This is the complete database cycle 1909 officially released by Garmin!

Navigation     1909
Basemap       19M1
Obstacle        19B5
SafeTaxi         19S5
Terrain            16T1
FliteCharts      1909  (USA + Canada)

To install the newest db over the existing, download all files listed then double-click the .MSI file.

Edited by RXP

Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Hello, sorry to bother. Just bought the GTN 750 for Xplane 11, I didnt get it to work. Also, when installing, I get the error 404, so I guess I need to install what you posted on this topic. I have already downloaded it, however, would yu mind explaining how to install and where. Thanks.

Share this post


Link to post
Share on other sites

@davidparra2205 Hi, I've added the "all-in-one" download link which should be working for now until we update the installers.


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites

Hi

Re: GTN Database 1909

i have downloaded the 8 x DB zip files (DBs1 to DBs8)  with the .msi application, as at top of this page.

The Databases set up seems to drop off during "Gathering required information......" stage.

How do you point the .msi application to the database zip files?  Do they need to be unzipped first? If so, into what folder should they go into?

Thanks for any help.

Share this post


Link to post
Share on other sites
3 hours ago, Maddoctor said:

Hi

Re: GTN Database 1909

i have downloaded the 8 x DB zip files (DBs1 to DBs8)  with the .msi application, as at top of this page.

The Databases set up seems to drop off during "Gathering required information......" stage.

How do you point the .msi application to the database zip files?  Do they need to be unzipped first? If so, into what folder should they go into?

Thanks for any help.

No unzipping.. just put all 9 files into a temporary folder (together)...

Then execute the msi.

That is it.

  • Like 1

Bert

Share this post


Link to post
Share on other sites

Can someone help me update my software.I have never updated this thing since purchase. says Trainer v v6.62.4 is available. But i do not see a DL link for this version of the Trainer. Only v6.62.3 is listed above.  Should I DL a fresh E-Commerce installer? Do I go into C drive where I have the setup file and just double click that? I looked at the trainer installed and it gives me an option to update to a version not supported by the GTN.. So how should I go about updating this? It's just confusing, cause there are two programs I need to update and one is not supporting the other? 

Thanks. 

Dave. 

Share this post


Link to post
Share on other sites

@Chase1399 I've not updated the links above because these are the links to any previous version so that our customers can still install the latest compatible trainer during the few days we're updating the product to support a newer trainer version. The RXP software installer always checks whether you have the latest trainer installed, as well as whether you have a compatible trainer installed (our product supports a bunch of different trainer versions) and you get prompted to download the latest trainer automatically if needed.

Otherwise the latest trainer is a google search away here:

https://www8.garmin.com/support/download_details.jsp?id=12373


Jean-Luc | reality-xp.com
This message from Reality XP is protected by a disclaimer: reality-xp.com/aboutrealityxp/email.html

Share this post


Link to post
Share on other sites
3 hours ago, RXP said:

The RXP software installer always checks whether you have the latest trainer installed, as well as whether you have a compatible trainer installed

Great. I'll just DL a fresh installer and go from there. Thank you for the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,435.00 of $25,000.00 Donate Now
×
×
  • Create New...