Jump to content

Sign in to follow this  
McCrash

FSX and Anti-aliasing help!

Recommended Posts

Guest TheAmbler

Hi allThe perceived wisdom is Anti aliasing etc should be enabled in the video card not FSX. When I do this my drivers collapse under the strain. I get rubbish on the screen, a big crash, then an error message that the drivers have a serious error. Any idea what's wrong? I have unticked AA in FSX for both monitors and set the filtering to none. In my NVidia 7900gs settings I have set AA and Ansiotrophic filtering to 4x and 8x respectively. I have unticked the Application Controlled box. Could anyone with a similar setup (fairly common) comment: Dell Dimension 9200. Core2Duo e6700, Nvidia 7900gs, 2gb ramMonitors Dell 2007WFP at 1600x1050, driver 1.0.0.0. LG L1717S at 1280x1024 driver 5.1.2001.0 Both drivers recently updated.NVidia driver number 84.40 (this I believe is the latest Dell driver)

Share this post


Link to post
Share on other sites

Don't see anything at all like that here (7800GTX)... I have AA unchecked and filtering set to trilinear. (since AF is something added on top of TL) I made a profile in the Nvidia driver for FSX and set it to 4X AA, 16X AF, Transparency AA Multisampling on, and High Quality mode. Works just fine here.


Ryan Maziarz
devteam.jpg

For fastest support, please submit a ticket at http://support.precisionmanuals.com

Share this post


Link to post
Share on other sites
Guest allcott

YOu can't set filtering to `none`. It's the one setting in the game that overrides anything set outside. Thats the problem. Set it to trilinear and go from there.Allcott

Share this post


Link to post
Share on other sites

I would go to Nvidia site and download drivers 91.47 Sept 14 2006I have my card set up as the others (Dell 7800gtx 256mb)with no problemsGregg D

Share this post


Link to post
Share on other sites
Guest

My settings are set in the driver menu. 2x AA and 4x AF. Anything higher than that on this sim and it chokes. I also have AA disabled in fsx and filtering set to trilinear.

Share this post


Link to post
Share on other sites

I have a nVidia 6800GT with driver 91.47 and if I set AA at the card level the screen flickers while in FSX. No problems in anything else, just FSX. Then, if I set it to application controlled at the card level, and then tick the AA box in options, it works fine.No idea why, but that's how I have to use it.


- Aaron

Share this post


Link to post
Share on other sites

If what you posted is not a typo, you say that you have unticked the option in your 'allow application to control AA' on the video card control panel and unticked it in FSX.To do this would mean that your video card was still processing AA data. You would need to tick the allow application bit on your card's conrtol panel, then switch it off in FSX to stop it happening, if that is what you are trying to do, which you presumably are if it is causing problems.Seems likely that you have also done so, but just in case you forgot, have you checked your drivers are the latest ones available? ATI and NVidia are currently faffing around quite a bit with drivers in order to have stuff up and running for DX10, so they are banging out up to date drivers quite a bit these days.


Alan Bradbury

Check out my youtube flight sim videos: Here

Share this post


Link to post
Share on other sites

On my system, if you try to set AA and AF in the driver settings, it won't work.Why is it different for different people?RhettAMD 3700+ (@2.5 ghz), eVGA 7800GT 256 (94.47), ASUS A8N-E, PC Power 510 SLI, 2 GB Corsair XMS 3-3-3-8, WD 250 gig 7200 rpm SATA2, CoolerMaster Praetorian


Rhett

i7-8700k @ 5.0 ghz, 32 GB G.Skill TridentZ, 1080Ti, 32" BenQ, 4K res

Share this post


Link to post
Share on other sites

What I mean to say is that if I set 4x AA on the card through the nVidia control panel and then UNcheck the AA option in FSX, I have blips on the screen every couple of seconds. The solution for me was to check the AA option in FSX and then set the "application controlled" option in the nVidia control panel. Thus allowing FSX to set the AA, which prevents me from setting the level, but for whatever reason, it solves the screen flickering.I am running the latest official driver, 91.47.


- Aaron

Share this post


Link to post
Share on other sites
Guest TheAmbler

"If what you posted is not a typo, you say that you have unticked the option in your 'allow application to control AA' on the video card control panel and unticked it in FSX.To do this would mean that your video card was still processing AA data. You would need to tick the allow application bit on your card's conrtol panel, then switch it off in FSX to stop it happening, if that is what you are trying to do, which you presumably are if it is causing problems."Not a typo.I want the CARD to do the Anti-aliasing. This is the advice on these forums for better performance. Therefore I UNTICK (UNCHECK for our US friends) the Anti-aliasing box in the FSX display settings. Surely I also UNTICK the Application Controlled box in the Nvidia settings. If this was ticked, we'd be back to FSX doing the Anti-aliasing, right? Also this must be right because if this box is ticked the card's AA controls are greyed out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    49%
    $12,400.00 of $25,000.00 Donate Now
×
×
  • Create New...