Jump to content

Sign in to follow this  
AntonioK

FS2crew can't detect the FSL Airbus

Recommended Posts

Got this message after running the installer for FSL in V5:

 

Quote

The FSLabs Airbus was not found in the default Prepar3D Add-ons folder. 

Please manually point to any panel.cfg file belonging t the FSLabs Airbus in the next window.\

This way FS2Crew can locate the proper path to your FSLabs Airbus.

Please contact FS2Crew support if you require assistance. 

 

Never had to do this before? Even when I select a panel.cfg file (of the root bus and/or any liveries) I get a message that says: "Could not find FSLabs parent directory for given path! Try again."

 

Share this post


Link to post
Share on other sites
On 8/9/2020 at 9:01 AM, AntonioK said:

Got this message after running the installer for FSL in V5:

 

 

Never had to do this before? Even when I select a panel.cfg file (of the root bus and/or any liveries) I get a message that says: "Could not find FSLabs parent directory for given path! Try again."

 

The same thing happens to me, and I just bought and downloaded the latest version 1.7, and I have installed Fslabs A320-X v:5.0.1.105 and Prepar3D v:5.0.31.35253 this in D:\ in which I have redirected the folder Documents, for the reason of having a 128Gb M2, so I do not take up space, only the operating system


fslabs_banner.png

Share this post


Link to post
Share on other sites

The F2Crew config manager should be able to locate your panel.cfg file based on the Addons.xml... but if for some reason it can't, you can add the FS2Crew entries manually to the panel.cfg file.  You can open the panel.cfg with notepad.

 

Here they are:

window09=FS2Crew Main Panel

window10=FS2Crew Secondary Panel
window11=FS2Crew Panel Switcher

 

and at the very bottom of the panel.cfg file goes:

//FS2Crew windows

[Window09]
size_mm=1075, 51
window_size= 0.5599, 0.0425
window_pos=0.00,0.05
visible=0
ident=1000
zorder=100
sizeable=1
gauge00=FS2CrewAirbusLabs64!FS2Crew_MainPanel, 0,0,1075,51
gauge01=FS2CrewAirbusLabs64!FS2Crew_Audio, 20,20,5,5
gauge02=FS2CrewAirbusLabs64!FS2Crew_VoiceMain, 10,10,5,5


[Window10]
size_mm=402, 639
window_size= 0.2093, 0.5325
position=3
visible=0
ident=1001
zorder=105
sizeable=1
gauge00=FS2CrewAirbusLabs64!FS2Crew_SecondaryPanel, 0,0,402,639


[Window11]
size_mm=190, 179
window_size= 0.098, 0.1491
position=6
visible=0
ident=1002
zorder=106
sizeable=1
gauge00=FS2CrewAirbusLabs64!FS2Crew_PanelSwitcher, 0,0,190,179


//FS2Crew windows end

 

 

Share this post


Link to post
Share on other sites
Posted (edited)

Nothing there is not form, it continues leaving the error that it does not find, in the folder of FsLabs in P3d v5 addons, if 3 folders of the airbuses are found,
"D:\Documents\Prepar3D v5 Add-ons\FsLabs\SimObjects\Airplanes\FsLabs A32X"
"D:\Documents\Prepar3D v5 Add-ons\FsLabs\SimObjects\Airplanes\FsLabs A320 CFM"
"D:\Documents\Prepar3D v5 Add-ons\FsLabs\SimObjects\Airplanes\FsLabs A320 IAE"

but the file Panel.cfg only in the A320 CFM and in the A320 IAE in the corresponding folders inside called Panel in those directories, in the base that is to say A32X does not appear, I imagine that you refer to that file.....cfg of the other two.

I have installed the PMDG 737NgXu and the PMDG 747 with the addons Fs2Crew and none has that error... 

 

If from the Configurator I give to ......ENABLE, I close the configurator, and by means of notepad I edit anyone of the Panel.cfg, if it appears what you have put "Copy Paste"" of your PC, when entering P3D and by means of opening manually from the superior bar MENU with a loaded A32X in stage, IT DOES NOT APPEAR ANY WAY TO SELECT THE MAIN PANEL, of Fs2crew. I don't have this problem with PMDG and its corresponding Fs2Crew activated.

If I go back and deactivate Fs2Crew from FsLabs A32X the entries in the cfg file disappear, which for me is like they were never there, .....

 

Edited by MVM55

fslabs_banner.png

Share this post


Link to post
Share on other sites

Please send me a Support Ticket.

I'll send you my panel.cfgs... only the CFM and IAE need to be updated.

This only happened on the Labs because in the Labs they added a new layer of complexity and allowed people to do custom installs of certain files, and sometimes the system gets tripped up by this.

Best,

 

Share this post


Link to post
Share on other sites
On 8/31/2020 at 5:22 PM, byork said:

Please send me a Support Ticket.

I'll send you my panel.cfgs... only the CFM and IAE need to be updated.

This only happened on the Labs because in the Labs they added a new layer of complexity and allowed people to do custom installs of certain files, and sometimes the system gets tripped up by this.

Best,

 

You don't have to open a tiket, the point is that it makes a bad effect or creates a bad opinion of the operation of the Fs2Crew configuration application for FsLabs when the "Error" comes out saying that it doesn't find etc....

I have verified that not making case of the window for, closing this window and without assigning him nothing, the application of configuration opens, if next you do "Click" on ACTIVATE, then inside the simulator with a A32X in track, if you press in my case a key that I have assigned in the Joystick, to open the application this one loads in the top part of the screen, where you can without problem act on the options.

I believe and hope that in future update the appearance of the error message is solved etc...

Anyway thanks.

Translated with www.DeepL.com/Translator (free version)


fslabs_banner.png

Share this post


Link to post
Share on other sites

I suddenly have the same problem.

Without me changing anything, I first noticed that all my keybinding were reset to default in P3Dv5. Okay, strange, but whatever.

Then I started a flight and upon using the first action of Fs2Crew (button control "before start checklist") the sim froze completely. Then crashed.

I quit everything and opened the Fs2Crew Configuration Manager and it told me that it couldn't find the FSLabs in the default location (but it's there, always has been).

So I re-assigned the panel.cfg, as requested, and it "successfully" remapped the location.

But when I start the Config Manager again, it keeps telling me it can't find the FSLabs. 

This happened suddenly, without me changing or adding anything to the sim. I don't know if some windows update in the background messed things up, but even de- and re-installing FS2Crew didn't solve the problem.

Any idea how to fix this? 

 

Edited by disco79stu

Share this post


Link to post
Share on other sites
1 hour ago, disco79stu said:

I suddenly have the same problem.

Without me changing anything, I first noticed that all my keybinding were reset to default in P3Dv5. Okay, strange, but whatever.

Then I started a flight and upon using the first action of Fs2Crew (button control "before start checklist") the sim froze completely. Then crashed.

I quit everything and opened the Fs2Crew Configuration Manager and it told me that it couldn't find the FSLabs in the default location (but it's there, always has been).

So I re-assigned the panel.cfg, as requested, and it "successfully" remapped the location.

But when I start the Config Manager again, it keeps telling me it can't find the FSLabs. 

This happened suddenly, without me changing or adding anything to the sim. I don't know if some windows update in the background messed things up, but even de- and re-installing FS2Crew didn't solve the problem.

Any idea how to fix this? 

 

The keybindings magically going away.... P3D handles all of that.  That's out of our control.  Maybe you accidentally reset them... who knows.

Can you open the FS2Crew Main Panel via the VEHICLES - INSTRUMENT PANEL menu?

 

Share this post


Link to post
Share on other sites
1 minute ago, byork said:

The keybindings magically going away.... P3D handles all of that.  That's out of our control.  Maybe you accidentally reset them... who knows.

Yeah, I didn‘t accuse FS2C, I was just pointing out that something strange was going on that might have affected FS2C as well.

I can access all panels within the sim, I do have to point FS2C to the right folder every time I open the Config Manager though. It‘s not „remembering“ the path anymore, at least so it seems. Admin rights are given. But aparently it is working nevertheless, I‘ll check if it‘s still working after a reboot. 

Share this post


Link to post
Share on other sites

If the FS2Crew panel's are appearing in the sim, then don't worry it about it.  It working.


The Config Manager "reads" where the location of your panel.cfg file is via the Addons.xml file.

I would check there to see if the location of your panel.cfg files is correct.

 

Share this post


Link to post
Share on other sites

"....I would check there to see if the location of your panel.cfg files is correct....."

That and where to locate the file to look, and above all which, because in the SIMULATOR there are many files Panel.cfg etc....., the answers are redundant and we are not all programmers etc....
 


fslabs_banner.png

Share this post


Link to post
Share on other sites
20 minutes ago, MVM55 said:

"....I would check there to see if the location of your panel.cfg files is correct....."

That and where to locate the file to look, and above all which, because in the SIMULATOR there are many files Panel.cfg etc....., the answers are redundant and we are not all programmers etc....
 

The problem is FS Labs decided to give people the power to select custom install locations.

As a result, the panel.cfg can be anywhere.

But, as mentioned if you go to this file:

C:\ProgramData\Lockheed Martin\Prepar3D v5\addons-ons.cfg

You can open it with notepad.

You can see where FS2Crew looks for your panel.cfg file.

On my system, it's here:

PATH=C:\Users\****my user name****\Documents\Prepar3d v5 Add-ons\FSLabs

Then it looks in the sub-folder:

C:\Users\****my user name***\Documents\Prepar3D v5 Add-ons\FSLabs\SimObjects\Airplanes\FSLabs A320 CFM\Panel

and:

C:\Users\****my user name***\Documents\Prepar3D v5 Add-ons\FSLabs\SimObjects\Airplanes\FSLabs A320 IAE\Panel


Under normal circumstances, it should work smoothly.

But there are a lot of files involved in different locations.  People mess their files, things can get thrown out of whack easily.

By giving user the power to select custom install locations, FSLabs added a new a layer of complexity.  The more complex something is, the easier it is to break.

That's why we suggest people use the default install location to save potential hassles.

 

 

Edited by byork

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,170.00 of $25,000.00 Donate Now
×
×
  • Create New...