Sign in to follow this  
pouldam

Well-known graphics issue - Phil Taylor, please comment

Recommended Posts

Hi,I am sorry to bug you Phil (if you read this), but I have posted about this graphics issue before and never found a solution, even though searching on the net suggests that I am far from being alone with this.THE PROBLEMWhen running FSX it seems to only utilize 16 bit colours even though Windows XP as well as FSX is set to use 32 bit. This occurs both in full screen and windowed mode and is mostly apparant at dawn/dusk where the sky shows banding. However, even in the FSX main menu it can be seen as shown below. I have seen glorious screen shots on the net and therefore know that this issue can be solved and that my monitor is able to show smooth transitions without banding.Spending many hours searching (mostly on AVSIM) I can see that I am not alone with this and that it has also been an issue with previous versions of FS. Here are some examples of the same issue...http://forums.avsim.net/dcboard.php?az=sho...81381&mode=fullhttp://forums.avsim.net/dcboard.php?az=sho...13230&mode=fullhttp://forums.avsim.net/dcboard.php?az=sho...03820&mode=fullhttp://forums.avsim.net/dcboard.php?az=sho...76613&mode=fullhttp://forums.nvidia.com/index.php?showtop...5135&hl=bandinghttp://forums.nvidia.com/index.php?showtopic=42964I have included some images to show the issue.http://forums.avsim.net/user_files/178163.jpghttp://forums.avsim.net/user_files/178166.jpghttp://forums.avsim.net/user_files/178165.jpgWHAT I HAVE TRIEDEverything - or so it feels. I am running a plain vanilla FSX with SP1 and no addons installed on recent PC (Core 2 Duo, 2 GB RAM, NVidia 7900GS w. 256 MB RAM) running at stock speed. I have tried to:- reinstall Windows and FSX from scrath- apply all updates available on windowsupdate- install the newest drivers for everything- install older graphic drivers (using DriverCleaner etc.)- install the newest DirectX 9.0c runtime (August)- switch between DVI and sub-d on my monitor- tried another (older) LCD monitor- use different resolutions- shutting Windows services on and off- mess with the graphic settings in FSX- mess with graphic profiles in NVidia control panel and using nHancer- even throw in an ATI X1950PRO graphic cardBut alas, this changes absolutely nothing...Any ideas what to try next?Do any of you guys on Vista experience the same?Is it possible that the changes to the graphics engine in SP2 will address this well-known issue - implicit or explicit?Any input is highly appreciated, not just from Mr. Taylor :-)/ Regards, PoulWinXP Pro SP2, ASUS P5B-E Plus, Intel E6600, 2 GB Kingston, LG L226WT monitor

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

That appears to me as a scaling problem with your video device driver and/or flat panel monitor, not the bitmap images. I believe I read this is one of the problems with the NVIDIA display drivers. It may be a problem with ATI/AMD drivers too.Best regards,Jim

Share this post


Link to post
Share on other sites

Its very hard to tell what is going on here, since so many of these threads no longer have any images.It certainly isnt something that is explicitly on the table for SP2. And the feature list for SP2 closed months ago.

Share this post


Link to post
Share on other sites

Thanks for answering Phil, although it was not what I hoped to hear.Anyway, I wonder if some of you Vista users could try to take a look at the default 737 2D panel at dawn and see how it compares to my shot above.And please also take a look at the airplane in the menu (also shown above) -- do you also get the sky depicted using fewer colours than what the image file really contains?Once again -- any help is really appreciated as this is starting to drive me nuts.../ Regards, Poul

Share this post


Link to post
Share on other sites

I just looked at the 737 2d panel and I think I see what you are seeing. It seems to affect 2d panels on most planes, but not as obvious on all. It sort of looks like the image has been posterized to a degree.I don't see any problem in the sky or the scenery and the VC looks good also.RonQ6600 Kentsfield @3.0GhzGigabyte GA-P35-DQ6 Motherboard2GB Corsair Dominator DDR2 1066 MemoryEVGA Geforce 8800GTX 768MB Graphics500GB Raid 1 System320GB Raid 1 DataCoolMax 700 watt power supplyVista Ultimate 32bitAntec 900 MidTower

Share this post


Link to post
Share on other sites

The menu interface of FSX is indeed using 16-bit color with the rotating aircraft preview showing clear signs of dithering, so the colors here are supposed to look bad. :(However, the main simulator is using the full 32-bit color depth. Bear in mind that most (but not all) instrument panels are using old 256-color palettes which make them look rather bland. There shouldn't be any banding in the sky gradients though...Have you double-checked your display settings in FSX to make sure you haven't accidentally set it to a depth of, for example, 1280x1024x16 rather than *x32 like it's supposed to be?

Share this post


Link to post
Share on other sites

Yup, I have checked that (a zillion times). It's set at 32 bit, but even changing it to 16 bit does not show a difference. I prefer to run in windowed mode though.But it is really odd, as my desktop seems to run perfectly in 32 bit...Keep the suggestions coming :-)

Share this post


Link to post
Share on other sites

known issue, no known fix in FSX. its an issue with how the 2D panels are handled as compared to the VC.

Share this post


Link to post
Share on other sites

OK, thanks for clearing that Phil. Lucky for me I always fly in VC mode (with a TrackIR that can't be beat), but this also shows signs of pixelation/banding/reduced colour depth.Here is a screen shot from the Level-D 767. Depending on the light, time of day etc. it can actually look a lot worse than shown here.http://forums.avsim.net/user_files/178311.jpgHowever, I am starting to wonder whether we all have this issue and it is just me being too picky??/ Regards, Poul

Share this post


Link to post
Share on other sites

Have you tried first deleting your current video drivers and then installing the most recent version?Or maybe it is the something odd with the 7900GS. As I said earlier I don't have the problem in the sky or scenery and I am using the 8800GTX. I am using the 163.69 drivers, but I have never had a problem with previous drivers and FSX.Ron

Share this post


Link to post
Share on other sites

Hi Ron,Yes, I have tried different drivers and am currently using the latest beta from NVidia and have done all the cumbersome install stuff (uninstalling old driver, booting into Safe Mode, using DriverCleaner, rebooting and installing new driver).I have also tried to install an ATI X1950Pro card and to my surprise it gave the same result. This hints that it is not a graphic card issue nor a (graphic card) driver issue. I am wondering if it is a DirectX issue...In the FSX main menu on your computer -- do the little static image of the floatplane also have to banding in the sky as shown in the above screenshot?Are you on Vista or XP?/ Thanks for helping, Poul

Share this post


Link to post
Share on other sites

Poul, I am running Vista Ultimate; see earlier post above for my specs.I see very faint banding in the menu screen but I have to look for it as it does not really slap you in the face. I also looked at the opening splash screen and it has obvious banding. However, I see absolutely no banding in the sky or scenery as I am flying. I am using Active Sky X and X Graphics and the sky looks remarkable.Ron

Share this post


Link to post
Share on other sites

Hi Pouldam,One mistake I have made before when installing new drivers is to forget to remove the old driver reference from the FSX.cfg. Might double check that you don't have more than one Display section.Bob

Share this post


Link to post
Share on other sites

One thing to remember with this issue as well is that 90% of LCD monitors are not true 24 bit, they're 18 bit, 666 rgb values.I'd never seen banding in FSX before on my old CRT monitor, but when it finally kicked the bucket and I replaced it with a new LCD widescreen, instant banding, especially in dawn and dusk skies. I didn't change my videocard or drivers, just the monitor.There are two flavours of LCD out there, true 24 bit 888 rgb versions, and 18 bit ones. The 24 bit ones are generally much more expensive and have a slower refresh time, around 8-10 ms per pixel so they tend to have a lot of ghosting when the image changes rapidly, not really useful for gaming. The 18 bit ones have 3-5 ms refresh, much better in that regard, but they can only display 260,000 colours, and have to downgrade the 24 bit image, hence the banding. With LCDs you can't currently have your cake and eat it too, but in a year or so when FED monitors start hitting the market you might. Space consumption of an LCD, but the refresh and colour depth of a CRT.Sucks I know. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this