Sign in to follow this  
dokelly07

VSync in FSX Acceleration DX9 ?

Recommended Posts

Anyone have vSync working in FSX Acceleration DX9?It worked fine in SP1, but now even if forced on in nVidia control panel I'm getting waves in fast moving images, really takes away from the sim?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm using Acceleration (ie SP2) with WinXP and DX9 and a 8800GT.I use nHancer to tune the card settings.VSync works great.

Share this post


Link to post
Share on other sites

>I'm using Acceleration (ie SP2) with WinXP and DX9 and a>8800GT.>>I use nHancer to tune the card settings.>>VSync works great. I'm using Vista seems to be an issue, what settings are you using with nHancer and in FSX, I'll try the same...

Share this post


Link to post
Share on other sites

I had the same problem. But I was able to force it on with my NVidia Control Panel... 169.01 Drivers in Vista 32. The waves went away. Steve

Share this post


Link to post
Share on other sites

I have DX9 with XP. I cannot run FSX with vsync on, even with my box (see specs in my sig.) I am running Nhancer, and lock frames at 35, if I enable Vsync it is smooth for a bit, then I get surges or stutters I guess you could say, but long dragging stutters. Its smooth for about 10 seconds, and then a drag, FPS is 35 locked, and then drops to 19 or so just for a bit. Either way, I cant stand it - so I opt for vsync off. Im on an LCD btw... any tips??danon -

Share this post


Link to post
Share on other sites

Danon, LCD screens have a normal refresh rate of 60hz, so for Vsync to work properly you have to lock your FPS to an evenly divisible factor of 60. 'Evenly' divisible is the key there. Your options are 10, 15, 20, 30, or 60 fps. If you're able to hit 35 fps consistently when running unlimited, then lock your fps to 30. The stutter you're seeing is from an uneven number of screen refreshes per game frame.It may stutter now and then a little anyway since FSX's framerate lock isn't exactly stable, it will fluctuate by 0.1 - 0.5 fps depending on load, but it should be a lot better than trying to run it at 35. Running at even 29 or 31 fps locked will guarantee stutter on an LCD screen with Vsync on, so give 30 a shot and see how it goes. Just remember if your fps falls below 30 it's going to stutter. I tune my scenery settings to allow 30 fps no matter the situation, including multiplayer with many aircraft in front of me.If your LCD is capable of refreshing at 70hz (some can do this at lower resolutions) then 35 would be an ok framerate lock value as it divides evenly into 70.Hope that helps.

Share this post


Link to post
Share on other sites

thanks for the tips...I jumped in the sim to try it out.With Vsync forced "on" in Nhancer, and frames locked at 30....I get drags. I counted the space between smooth and stutter/drag to be 3 seconds. Three seconds smooth, then a drag, over and over again unless I was out over the ocean. My FPS goes from 30 locked to 12 during the drags. My test bed was Dillingham Hawaii.Perhaps there is some other setting I have wrong in Nhancer somewhere?? I am running Aniso at 8x, with AA supersampling at 4x. Other than that its all basic and default. No tweaks in my cfg, without vsync my frames will lock at anything up to 40 and never drop....this strange beast...danon - -

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this