Sign in to follow this  
ABE

LAX INTENSIVE FLYING

Recommended Posts

I flew intensively around LA doing takeoff and landings and sightseeing for about 2 hours when 'OUT OF MEMORY' flashed prompting me to exit FSX, and then rerun it.I have 4 gigs of ram and 4 gigs of page file placed in another drive partition.....what gives? I realize that XP pro does not see more than 3 gigs of ram. I have Q6850, I ran cores 1,2, and 3 for FSX exclusively and 0 for the rest of applications......hardly any used.Did I do something wrong? Can it be corrected?Thanks.Abe

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks Dave.I think I may have changed around.....do not remember all the specifics.Abe

Share this post


Link to post
Share on other sites

If this is in Vista, and you have a Nvidia card, go to the download driver page on their website, on the left is a link pointing to MS hot fixes for Nvidia cards in Vista.

Share this post


Link to post
Share on other sites

Abe,This is a paste of an earlier post. (If you run XP, you may need to edit your boot.ini file)"I was battling the dreaded out of memory "OOM" error on Vista 64 with 4Gb of memory and the august vista patch.With the PMDG 700X and Ultimate Terrain, there was no way with FSX SP1: I couldn't last more than 2 minutes in flight before being kicked out.I solved my problem by modifying my fsx.exe to use the large address space using this tool: http://ntcore.com/4gb_patch.php. Apply it to fsx.exe after you make a backup, and presto, no more OOM (for now).There is another tool on the same site that sets the "large address space" flag on the exe (CFF Explorer).Hope this helps.Etienne"Here's a copy of my boot.ini [boot loader]timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /userva=2560Stu.

Share this post


Link to post
Share on other sites

Thanks Stu.1. My boot.ini is very much like yours, I just added "/fastdetect /3GB /userva=2560"In total my boot.ini is this:timeout=30default=multi(0)disk(0)rdisk(0)partition(1)WINDOWS[operating systems]multi(0)disk(0)rdisk(0)partition(1)WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB /userva=2560C:CMDCONSBOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdconsIt's fairly late right now, I'll give it a shot tomorrow. If it doesn't work, I'll revert to the other suggestion about modifying the FSX file.One more related question. I noticed that my task manager reaches a level of 2 gigs before it crashes. Would this new boot.ini show the task manager reaching beyond 2 gigs, and FSX is still operational?Thanks again Stu.Abe

Share this post


Link to post
Share on other sites

If you have acceleration /sp2, then fsx is already large memory aware.On my old clunker (4 years old- 1 GB ram) I have not had a single OOM with Acceleration.Last night I flew from Boston to Honolulu without issues.

Share this post


Link to post
Share on other sites

I have 3 instances of FSX:1. New XP PRO acceleration - sp22. New Vista 643. OLD XP PRO.....NO SP1 or SP2........that's the one that crashed. The reason I use it, is because I have everything installed.....aircrafts, sceneries, utilities, etc.........Eventurally I'll be transferring my stuff little by little to BOTH: the new XP and the NEW VistaAbe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this