Sign in to follow this  
jordanal

FSX - AI Spawning in massive groups (mid-flight)

Recommended Posts

I finally got a chance to test my FSXsp2/UTX/GEX enviornment with the default Baron taking off from my little hometown last night. About 10 minutes after takeoff, I saw numerous (maybe a hundred?) AI spawning all around me, in the near distance, near my flight-level or higher. In the FSC map on my WideFS PC, I could see them spawning over two main areas tightly packed together.It got so bad, that my FPS went from a solid 25 (locked) to 2, and stayed there, resulting in a Ctrl-C to end the session. I've had this happen a couple of times now and I don't know what is causing it. I'm sure it's AI related but I'm at a loss at the moment. I searched the forum this morning but couldn't find anything with a similar experience, at least not in mid-flight.AI Specs:Many EVAI flightplans used with MRAI instllerA few small PAI packages (FedEx Regionals & the C-17)Most of the WoAI packages (except those superceded by MRAI airlinesMost poplular models including AIA, EVAI, PAI, FSP, AIM, etc...All Traffic BGL's converted with AIFPC (with _FSX.bgl) appendedDefault FSX traffic disabled (renamed dll to zzz)AI planes in custom "Aircraft" folder under SimobjectsFS9 BGL's relocated to an inactive subfolder under SceneryWorldSceneryAilines @ 100%, GAI @ 20%, and Cars @ 25%ACA2005 and 2007 indicate all traffic files are good to go with no duplicate titles or missing textures.Has anyone else seen these similar goups of spawning aircraft? Any idea what it could be? The same AI files and packages are used simultaniously in my FS9 setup without issue. Except for the fact that they are not recompiled into the FSX format with AIFPC.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Al,I use a similar arrangement to yours, with al the ai models in a custom SimObjects folder, airplanes_ai, and all flightplans converted, with suffix, using AIFPC. I have not seen the spawning of ai you describe even at 100% settings. Have you tried reducing ai to 70%? I did read somewhere that ai could become unstable at 100% in FSX. Rod.

Share this post


Link to post
Share on other sites

I have done literally probably 100+ hours of AI testing since FSX came out, and I can tell you that I have never, ever observed AI "spawning".If you observed it, then it is a first I have ever heard anyone ever reporting.Since AI are always 100% controlled by traffic bgl files, I can't imagine what could be causing the behavior, except for heat/memory stick issue.If the problem never occurs again, I would chalk it up to being "just one of those things", and never worry about it again.If you can duplicate the problem, then please, report back how you're doing it.RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

One more thing, I just thought of: Possibly an erroneous traffic bgl file could be causing the problem. I've seen FS9 bgl's run through a converter do strange things...Again though, if it never happens again, I wouldn't lose any sleep over it.RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

Thanks guys, really appreciate your thoughts. I've also e-mailed Reggie to this post to hopefully gather his thoughts too.While sitting here pondering your replies and a few more of my own thoughts, it almost seems as if the AI subroutine gets cought in a loop and keeps kicking off more AI. Really weird. I wonder if it's not something to do with any of the following:FS Commander over WideFS, live MAP viewing all Aircraft, including AI.FSUIPC - Maybe the Autosave feature (think its set to 5 or 10 mintues) causing FS to cycle AI funny?ASX Weather - doubt it, but it was connected over simmconnect client putting a load on it.Simmconnect - Networked to client PC - stepping on memory, maybe?FS Real Time - sets the FS clock every few miutes to true time - maybe losing sync with AI status during FS recycling?I'll duplicate the session tonight, just to see if I can't reproduce it.The other weird thing is, when it happened, there was some sort of screen flash or pause (hard to describe), like something in FS was reset, or recycled. Then the invasion of AI he11 was upon me.Since no other folks seem to ever see this with converted AI BGL's, then I don't think that is the culprit, as it would have been more prevelant by now. That's a good thing, as I can deal with the applications and integration issues.I'll report more tonight...

Share this post


Link to post
Share on other sites

FS Real Time - sets the FS clock every few miutes to true time - maybe losing sync with AI status during FS recycling?My bet is on this program. It's great - but the way it messes with the clock causes a lot of stuff with critical timing to get screwy.And AI as critical timing.

Share this post


Link to post
Share on other sites

>FS9 BGL's relocated to an inactive subfolder under>SceneryWorldScenery I can't give you any useful input concerning your observed problem but I did notice something in your post that you might want to look at. FSX, when starting up and perhaps later on too, scans ALL folders that are located beneath the root FSX installation folder. Including any you might use for temporary or "inactive" storage. I've seen this occur usinf FileMon. I don't know what effect it might have on FSX when it sees your "inactive" BGL's as I didn't look any further into it when I observed the file searchread activities. I, too, have added a "Aircraft" folder under SimObjects to hold all my FS9 imported aircraft. Further, I have added a "FSX AI Aircraft" folder on my D: drive ( FSX is on my I: drive ) and a "Addon Scenery 2" folder, also on my D: drive. I've not observed any events that are as disruptive as yours appears to be but I do see periodic drops in FPS occasionally but they are brief and I've not taken the time to trace the cause(s). I'd suggest that you place all your "Inactive" folders OUTSIDE the FSX file structre, just to be certain that FSX doesn't "see" them. Paul

Share this post


Link to post
Share on other sites

>>The other weird thing is, when it happened, there was some>sort of screen flash or pause (hard to describe), like>something in FS was reset, or recycled. Then the invasion of>AI he11 was upon me.>Ah ha, now I know it. That "screen flash" has to be a quick AI refresh. FSUIPC has some clock sync features that can do that. I don't know about FS Real Time but it too, is a possibility.Another user *recently* reported FSUIPC clock sync feature reloading the AI. You might look for that thread.What you are seeing is the AI getting refreshed over and over. Those AI are not "spawning". What is happening is your AI is getting reset. It's an oversimplification on my part, but the AI will appear at the location specified in their flight plan, at the time specified.I've noticed sometimes when AI get reset, you will get doubles and triples, and also jetways behaving strangely. Some things seem to get stuck in memory. I have observed abominations like an AI DC-10 on top of/within an AI 737 at the airport after a refresh. Talk about a weird looking aircraft.Reggie has said the best way to reload AI is to load Map View, and change your heading by 1 degree. If you reload AI by just accelerating time to 8x, that works most of the time but is not foolproof. You can sometimes get the weird anomalies I mention, above.RhettAMD 3700+ (@2585 mhz), eVGA 7800GT 256 (Guru3D 93.71), ASUS A8N-E, PC Power 510 SLI, 2gb Corsair XMS 3-3-3-8 (1T), WD 150 gig 10000rpm Raptor, WD 250gig 7200rpm SATA2, Seagate 120gb 5400 rpm external HD, CoolerMaster Praetorian

Share this post


Link to post
Share on other sites

Hopefully reducing your AI slider to 60-70% might help. I had a somewhat similar experience with Ultimate Traffic, in that if you have planes arriving and departing on a real-world schedule, they will form up in "constellations". My constellations were usually about a dozen aircraft in a group or so, and although they looked kind of silly in the air, around airports,= they would get clogged up on approach, and some would get "disappeared" by FSX. Reducing the amount of AI planes cleared up the constellations, although you might have more issues regarding FSX timekeeping and aircraft schedules. Jeff ShylukAssistant Managing EditorSenior Staff ReviewerAVSIM

Share this post


Link to post
Share on other sites

Well Gents, I reflew the same hour-long flight across NW PA and just finished a very successful flight with no AI Invasions from he11. I'm really starting to like the results of the integration of ASX/XGraphics/UTX/GEX/AI making a very nice flight at dusk on a wintery evening. Even had snow squals on the approach. :)I had all the same add-ons running and did't change a thing since my experience yesterday. Lots of low ceilings, ovc, winds, and all my AI properly spread out, doing their thing according to my FSC map. I agree with Reggie, the frequent clock adjustement by FS Real Time is more than likely the culprit but it behaved today so I'll have to keep and eye on it.I really do appreciate all the thought provoking feedback and I'll be sure to post back here if I can figure it out in the neare future.Regards,

Share this post


Link to post
Share on other sites

Thanks Rhett,Good to know how to get AI to recycle becuase I do like FSRealTime for the long-hual flights whereby not sync'ing the clock can cuase a large time difference.When this invasion happened, I tried to change my AI percentage to 0 which worked, but I could still see a few straglers in my near airspace. So AI stuck in memory fits your scenario whereby I could still see a few even with the traffic sliders zero'd. When I attempted to take the AI back to 100%, FSX locked up at about 30% reload and never reocoverd.I wonder if various update-rate settings within FSRealTime could prevent this. I think the default is 10 minutes. I have used 3 minutes for years. I vaguely remember some statement in the early days of FS Realtime whereby a long update rate could affect AI upon refresh. I think we're on to something here...Does anyone else use FS Realtime with lots of AI in FSX? What is your prefered update rate?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this