Sign in to follow this  
haldir

rolling line up the screen, with 30 fps bow wave ?

Recommended Posts

HI all: Sorry if I do not know what this effect is called.I can maintain a steady 30 fps over most terrain and cities. However I see a very annoying rolling line that progresses up the screen depending on my view.This is not a distinct line, it is more like a margin of texture detail progressing upwards, or outwards away from the aircraft. Flying the 172 I see the followingLooking out the fwd windshield, the rolling line starts at the bottom of screen and rolls forward or to the top as I fly along. If I look out the left window, the line starts at the bottom of window near the door/window frame, and rolls upwards in my viewpoint, until progressing above the wing and going out of view. If I look aft behind me at around a 7 o clock angle, I see the line start at the front edge of the left window, and scroll backwards aft, kind of at an angle to the airframe.In Nhancer they talk about an effect called a bow wave, and if I had to guess, this is what I have going on. I do not have any of the options turned on that cause a bow wave according to Nhancer however.I swear I never had this before, but.. after all the tweaks I made attempting to get rid of the shimmering trees, I think this wave effect may have now snuck in on me. Of course :( I never got rid of the shimmering tree's either. I do not think anybody has. How many YEARS does a person have to tweak FSX to get it right? I tried setting all FSX in game settings to minimums, traffic off, global texture resolution to minimum, everything scaled to lowest point, and this rolling wave still occurs, so... I do not think it is caused by my hardware not being able to keep up with the graphics. I apologize if my discription of this problem is not the best. I would be happy to search on the forum, but... what the devil would I search under?Thank you to everyone.-Stampee

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Sounds like you need to enable V-Sync in your video card settings. What you're seeing is "screen tearing".

Share this post


Link to post
Share on other sites

Right, But can Vsync be enabled? I still can't figure out how to enable it with my 8800GTX card unless there is a recent driver that causes it. Does anyone know?Steve

Share this post


Link to post
Share on other sites

It will be in your nvidia display properties, under performance. Change it from 'application controlled' to 'on'. Or you can use nhancer to set it specifically for FSX. Driver revision is not a factor, all nvidia drivers have this capability.

Share this post


Link to post
Share on other sites

Thank you very much, Haldir ...I tried this and I still get tearing under SP-2 DX-10. DX-9 looks very nice, however.Steve

Share this post


Link to post
Share on other sites

Vsync can only be controlled by the application itself in DX10, which you just discovered, and which is something that was sadly overlooked in the DX10 preview. There is no way at all to force it on in that mode currently, via drivers or nhancer or anything else. I simply can't use DX10 for that reason alone, screen tearing gives me a migraine within minutes haha.Glad you got it working in DX9 though. That's thrown a lot of people off since SP2 broke FSX's internal Vsync control.

Share this post


Link to post
Share on other sites

The bow wave you describe sounds more like a filtering setting rather than vsync, and you will get it to some degree unless your using anisotropic filtering and all the optimisations relating to filtering are turned off either in the drivers control panel or through nhancer.

Share this post


Link to post
Share on other sites

Hi all: I am pretty sure now this is Vertical sync. If I set a FPS of 25 or 35 or 42 or anything other than exactly 30 the problem is barely notecable if even there. I swear it is gone above 30 FPS, just... I also have some tiny microstutters so.. its hard to say what I am seeing at times.The rolling line is very obvious at 30 FPS however. I picked 30 FPS because... I read someplace to use a fps setting that is an easily divided multiple of your refresh rate, mine being 60HZ. SHEESHIf I turn on vertical sync in Nhancer, it says the following" If the game doesn't have a Triple-Buffer option, the framerate can only change between whole-numbered fractions of the refresh rate (e.g. 60, 30, 20, 15... fps in case of a 60Hz monitor)."It does not act like FSX has an internal triple buffer. I see no improvement by forcing it on, or by selecting application controlled. As I understand it, an LCD monitor should always be run at 60HZ only. I have read that on numerous websites. I am afraid to try any other higher LCD refresh rate. Any more advice would be appreciated._Stampee

Share this post


Link to post
Share on other sites

The triple buffering option you see in the nvidia driver and in nhancer is only applied for opengl games. DirectX wasn't designed for that, though it can be forced to work with it by using DXTweaker. However FSX doesn't particularly like being forced to triple buffer and it will produce lots of artifacts as well as a blank screen in aircraft selection etc. The only problem with Vsync in FSX is that FSX's framerate lock isn't very precise. If you cap FSX at 30 fps you're really getting anything between 29-30 in 0.1 fps increments. That means you're going to get a little rhythmic stuttering here and there with it on. Your choices are either that, or screen tearing, neither of them great, but I prefer a solid image at the expense of a little stutter.The LCD refresh information you read is correct though, the best fps caps for a 60hz monitor are 10,15,20,30,60. You'll probably see fewer stutters at a 20fps cap than 30 since you have 3 monitor refresh cycles per game frame and they will synchronize more easily. You probably can slightly overdrive your LCD's refresh by creating a custom resolution but I don't advise it, and at most you'll only get 1 or 2 hz more out of it with likely increased stutters.Some LCD monitors are capable of 75hz at much lower resolutions, you'd have to check your manual. Locking FSX to 25 fps in that case would be the best mix. At native resolution though you're pretty much stuck with 60.Cheers,

Share this post


Link to post
Share on other sites

Thank you to everyone. Nvidia control panel had settings for 60,70,75,85 fps so I picked 75 refresh and set fps lock to 25. I dont see that darn rolling line anymore. I would rather have a bit faster fps, but... whatcha gonna do.I appreciate all of the assistance.-Stampee

Share this post


Link to post
Share on other sites

I never saw vsync working in FSX DX10. Furthermore it is broken in FSX DX9 with every driver after 163.75 whql - that one worked for DX9.Heiko

Share this post


Link to post
Share on other sites

> Furthermore it is broken in FSX DX9 with every driver after 163.75 >whql - that one worked for DX9.>>HeikoMango,I have got 169.25 working fine here in DX9. DX10 has never worked. Although in order to get Vsync working with the 169.25 driver, I'm using nHancer and have Vsync forced on globally in nHancer and in the FSX profile in nHancer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this