Archived

This topic is now archived and is closed to further replies.

Paul J

Annoying little stutter with high FPS HELP!

Recommended Posts

My FPS are good but I get a constant slight stutter in level flight. It s more noticeable in turns tho. I have adjusted every slider in FSX and tweeked the FSX.CFG per all instructions to no avail.Is this a DX10 issue as one person suggested? Or can I make another adjustment to fix this? I did the "BUFFERPOOL" deal in FSX also and it is[bUFFERPOOLS] Poolsize=5000000Is this correct?TurnipSPECS:VISTA Home Basic 580 WATT Sunbeam PowerCrucial Ballistix 4GB(2 x 2GB) 240-Pin DDR2 SDRAMASUS P5N-E SLI LGA 775 NVIDIA nForce 650i SLI ATX Intel Motherboard Intel Core 2 Duo E6550 Conroe 2.33GHz LGA 775 65W Dual-Core Processor Model BX80557E6550MSI nVidia NX8800GT 512 PCI-E 2.0SB LIVE 24250 GB WD SATA HD 120 GB WD IDE HDftxsupporter.gif[/url]

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You may have a piece of software outside of FSX hogging either CPU or disk IO.Have you spent any time looking at Task Manager while you're flying?My bet is that your disk IO is dropping on a regular basis; suggests maybe a virus scanner is scanning your texture directories in FSX perhaps.

Share this post


Link to post
Share on other sites

Mine does the same thing when I force Vsync on. It will show high FPS, smooth as glass, and then a rythmic stutter every 5 seconds or so.Check and see if you are forcing Vsync "on" in your video driver applet. If it is, force it off - and see if that took the stutter with it.The downfall is screen-tearing. But...I would rather the occasional screen tear, than the rythmic stutter. Btw..no tweak in the world will get rid of that stutter, even forcing triple buffer with Vsync on did nothing for me. I spent hours trying. I even thought about purchasing an ATI card, thinking it was Nvidia drivers causing it. I'm still in that boat...waiting to see if anyone holding an ATI has the stutter with Vsync on problem. Hope that helped.D - -

Share this post


Link to post
Share on other sites

FWIW, I have found that locking the frame rate at an even divisor of the screen refresh rate helps with the stuttering -- e.g. if your screen refresh rate is 60 Hz (like most LCDs) you would lock the frame rate at 20 or even better 30 FPS./ Cheers, Poul

Share this post


Link to post
Share on other sites

Turnip,One of the major reasons that I do not run DX10 Preview is that it constantly stutters and there is nothing that I have found to stop it.dokelley07,Youn cannot force Vsync on under DX10 Preview it is always forced off by FSX no matter what your try to force it on with. RivaTuner, nHancer, or the Nvidia control panel will have zero affect on Vsync under DX10 Preview. I always run with Vsync enabled for FSX under DX9 and I have no stutter what so ever. I have not heard of any other Nvidia users having such a stutter under DX9 only DX10 Preview. Are you experiencing your stuttering under DX10 Preview or DX9? If you are experiencing the stutter under DX9, what do you have your framerate slider set to, and what is your monitor refresh rate?

Share this post


Link to post
Share on other sites

I am having the stutter under DX9. I have added the force vysnc on, lines in the config, and forced vsync on within nhancer as well. I have tried unlocked frames, and frame rates of 20-60 (locked) in single digit increments (took hours). I have an LCD, so im at 60 refresh. Most people would not notice the stutter I am getting, its more like a drag, every few seconds. I have spoken with many people that have the same thing, they threw the towel in as I have. If you have any other suggestion, im all for it. I have tried earlier drivers, and just tonight, beta drivers - all to no avail.Danon - -

Share this post


Link to post
Share on other sites

Sounds like you definitely went the right way about it. The optimal framerate lock for your LCD would be 30FPS or 20FPS whichever is closest to the framerate you normally maintain. Just fishing...are you running SP2??

Share this post


Link to post
Share on other sites

>Mine does the same thing when I force Vsync on. It will show>high FPS, smooth as glass, and then a rythmic stutter every 5>seconds or so.>>Same problem for me cured by forcing V-sync off in Nvidia control panel. Very minor screen tearing now, but better still, no stuttering.

Share this post


Link to post
Share on other sites

I tried SP2 five times - for about a week each time - and I had a similar, sort of "vibration", or a constant "micro screen-refresh" - not so much "stuttering" or hesitation, but a hesitation in turns for sure, as you say. SP2 certainly allowed bloom and a higher water setting, but so many other features are degraded or lost. When I went back to SP1 she was smooth as silk, and so that's where I am now.

Share this post


Link to post
Share on other sites