Archived

This topic is now archived and is closed to further replies.

Guest RichardL

direct X 10 Preview? disables lots of stuff booo!

Recommended Posts

with my card 9600gt 512mbthe direct X 10 preview???? Disables:tool tipsprogressive taxicauses weird bugs with atc windowweird bugs sometimes with VC buttons not working(like they are there but not showing in the right position according to the mouse)anybody else experience this?and why the Direct X 10 preview?? wasn't this supposed to be a "for real" deal?;(

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yes, these are all well known except I haven't heard or seen "weird bugs with atc window" and "weird bugs sometimes with VC buttons not working". The VC button issue occurs on my system whether I have DX10 turned on or off. It is extremely difficult to find the "click spot" in the VC, especially in heavy weather and the aircraft is moving in all different ways. I usually go the the 2d cockpit, make the adjustments, then return to the VC.You missed the flickering on several runways/taxiways (KFHR for instance) when DX10 is enabled. It has been reported several times on this forum (and other forums) that these problems are caused by a NVIDIA driver issue. NVIDIA has been informed about the problem by the FSX developers and several members of this forum, including me. It is extremely doubtful NVIDIA will fix this problem but one can only be hopeful.The reason for the naming of DX10 Preview has been disclosed on the Phil Taylor blog - http://blogs.msdn.com/ptaylor/default.aspx. Just click on the DX10 tags for the info. Basically the Aces Team did not want consumers to think DX10 in FSX is as great as originally advertised.Best regards,Jim

Share this post


Link to post
Share on other sites

It has also been reported here by MS that nvidia cannot duplicate crashing problems on there lab testing systems. So you are right in writing that these types of problems will never be fixed.Richard (A non-SP2 user)

Share this post


Link to post
Share on other sites

havent noticed too much flickering on the runways.I have notice the shadow is sometimes cutoff.why are you a non sp2 user richard?

Share this post


Link to post
Share on other sites

Hi Craig,I installed SP2 when it was released. I then suffered with constant FSX crashes. Un-installed SP2, no more crashes. What more can I write?Richard

Share this post


Link to post
Share on other sites

Sorry Craig but there has been enough threads about that.Please use the Search function.Some users are very satisfied with SP2, some are not.It seems that the majority warmly recommand to install it.Let's not open a new polemical thread again.Thanks

Share this post


Link to post
Share on other sites

Well what exactly are we suppose to do??? I just installed the brand new 174 drivers with no change to any of the graphical bugs yet again. Nvidia always have application fixes in every driver update. Just take a look at the release notes. Why on Earth would they be ignoring the FSX issues when they are very common and widespread, yet they address issues in almost every major game out there, even going so far as to mention if its a known issue they've yet to resolve, or specifying if its an application issue. I haven't seen a single comment about FSX from them yet. Do we need to get a freakin petition going or something? Or is it really even a driver issue at all? I've never seen a driver related bug go unchecked for this long. Heck, Crysis got like 3 or 4 driver updates in the first 48 hours it was out. Something just seems all-around shady about this to me.

Share this post


Link to post
Share on other sites

>Well what exactly are we suppose to do??? I just installed>the brand new 174 drivers with no change to any of the>graphical bugs yet again. Nvidia always have application fixes>in every driver update. Just take a look at the release notes.>Why on Earth would they be ignoring the FSX issues when they>are very common and widespread, yet they address issues in>almost every major game out there, even going so far as to>mention if its a known issue they've yet to resolve, or>specifying if its an application issue. I haven't seen a>single comment about FSX from them yet. Do we need to get a>freakin petition going or something? Or is it really even a>driver issue at all? I've never seen a driver related bug go>unchecked for this long. Heck, Crysis got like 3 or 4 driver>updates in the first 48 hours it was out. Something just seems>all-around shady about this to me.Simple, we live in a shootem up world. Simulations is still a relatively small segment of the market. So we get ignored!

Share this post


Link to post
Share on other sites

Yes, but isn't FS the longest running piece of software MS has ever developed? Around twenty-five years.

Share this post


Link to post
Share on other sites

"Do we need to get a freakin petition going or something? Or is it really even a driver issue at all?"Over in the hardware forum I recently started a thread requesting everyone send a bug report to Nvidia. I even had a sample form completed and the direct link to the bug report. Not many people responded that they sent a bug report but hopefully many did. It's called the DX10 Preview, Vista, Nvidia Video Card Problem and currently on Page 12 (here's a possible direct link - http://forums.avsim.net/dcboard.php?az=sho...=35520&page=12)."I just installed the brand new 174 drivers with no change to any of the graphical bugs yet again."The 174 drivers are still in beta. I'm hoping a WHQL version will have some fixes.Best regards,Jim

Share this post


Link to post
Share on other sites

Awesome, thanks,I didn't know they had that bug reporting tool.Please everyone with graphic problems report to Nvidia!

Share this post


Link to post
Share on other sites

After reading this thread, I tried FSX with the DX10 preview checked. I did not experience the runway/taxiway texture flashing reported by others but did notice the missing progressive taxi path, some flashing of object textures, and chainlink fences lost their transparency in the forward view from the virtual cockpit (okay out side windows). I was unable to detect any improvements in DX10, so I see no reason to request any bug fixes from nVidia (I don't seem too be losing anything by staying with DX9). I'm currently operating with the nVidia 169.44 beta driver.

Share this post


Link to post
Share on other sites

It seems that not all video cards are impacted alike. My 8800 goes nuts with DX10 enabled (30% faster but taxi markings and lights go bunkers), and the drivers, what can I say, are not helping much. The latest beta for Vista 64 help quite a bit with the taxi texture issue, but of course must break another title I use frequently as well. Argh. I'm in agreement that the flight sim sector is likely at a disadvantage for tender loving care from the hardware manufacturer compared to other titles that probably sell more hardware... Cheers,Etienne

Share this post


Link to post
Share on other sites

"I did not experience the runway/taxiway texture flashing reported by others...."Actually that's good news because it indicates the FSX/Display Driver/Vista configuration for those who DO see runway/taxiway texture flashing, including me, is somehow messed up because you're using Nvidia drivers. Now we just have to figure out what config setting is causing the flashing. I tried the 169.44 beta drivers once but uninstalled them because it did not fix anything. I currently have the latest beta (as of this exact second) the 174.74 drivers and they do not fix any problems either but appear more stable so will keep them for a few more days.Perhaps you are running FSX at a lower resolution with a higher refresh rate of 60 Hz? I have the Dell 30" 3007WFP monitor at 2560x1600 resolution and the best refresh rate is only 60Hz. My display drivers and monitor will not allow a higher refresh rate and I'm guessing that's part of the problem. Oh well, it will get worked out one way or the other eventually.Best regards,Jim

Share this post


Link to post
Share on other sites

Due to a problem that cropped up with resolution of multi-displays, I had to reinstall the nVidia driver for my 8800GTS-320MB video card. I went back to 169.25 when I did the reinstall, and there are no apparent differences. One other thing with either driver that I failed to mention is that the full screen display does not fill the screen under DX10. I had to go to windowed mode.Art

Share this post


Link to post
Share on other sites