Archived

This topic is now archived and is closed to further replies.

ulisses

Snapping.

Recommended Posts

Hi all, havent fired FSX up since July, thought id give it another go! Wiped my CFg and let it buld a new one, defragged, all the usual stuff! From what I recall, much much better this time around. Only one issue...Snapping ground textures! Which in turn cause minor stuttering every 4 seconds or so.Any way around this? System specs below, settings on dense autogen and dense scenery, All traffic 4%. I use acceleration. p.s I forgot to ask, when I set frames to unlimited, my frames shoot way way up! Only issue is there is like a skipping on the screen if they go above 100? I have VSYNC turned on and max refresh rate is 60%. Does this mean I must lock below 60?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I don't know about the snapping textures-do you have all the patches applied?I leave my fps at unlimited and get better results and last time I checked nvidia (if you have one) recommends unlimited for fsx.GeofaMy blog:http://geofageofa.spaces.live.com/

Share this post


Link to post
Share on other sites

I get the terrain texture jumping if I set fps too high - plus my video card heats up REAL fast when unlocked. I have my slider set to 35 - runs quite smooth there, keeps the snapping and stuttering to a minimum.

Share this post


Link to post
Share on other sites

i have nvidia 8800GT...only problkem is with unlimited frames the screen skips when it goes between 60fps and 100+fps....? But If i lock then I get the snapping...its very frustrating!

Share this post


Link to post
Share on other sites

I have turned all traffic to 0%, and autogen off. The snapping is still there! Its when I fly over the terrain, the textures snap into place as my plane flies over them, causing the stutter. Going from part blurred textures to full sharpness. Its so annoying. Does anyone else have this issue?

Share this post


Link to post
Share on other sites

Ive tried with it turned off and teh entire service shutdown too, same issue :(

Share this post


Link to post
Share on other sites

What settings should I be changing? do you fly airliners in FSX or just GA?

Share this post


Link to post
Share on other sites

Although it is very location-specific, and this is a very generic statement, I'd guess that Dense autogen is hurting you, for starters.You need to pull back sliders until you cannot replicate the snap/stutter. I start with all sliders left (yes, that is not a typo) and frame lock unlimited when I am trying to dial-in what the problem is with a config.That way, when I move a slider on notch at a time, I can get a good idea about what is causing the problem, what is most impacting my performance, and what is not.Also, the search function is your friend...on this site and other major FS sites. Others have had the same issue you describe, and have solved it.After you do that, you can start tweaking BufferPools and TEXTURE_BANDWIDTH_MULT, which you will probably have to do at some point if you really want to dial it in right.Also your AA and AF settings--both in the driver and in the sim--these would have to be gone through to ensure that you do not have something going on there. (another thing known to cause snap/stutter problems).RhettFS box: E8500 (@ 3.80 ghz), AC Freezer 7 Pro, ASUS P5E3 Premium, BFG 8800GTX 756 (nVidia 169 WHQL), 4gb DDR3 1600 Patriot Cas7 7-7-7-20 (2T), PC Power 750, WD 150gb 10000rpm Raptor, Seagate 500gb, Silverstone TJ09 case, Vista Ultimate 64ASX Client: AMD 3700+ (@ 2.6 ghz), 7800GT

Share this post


Link to post
Share on other sites

I have a few things for you to try. Set your PRE RENDER limt to 1 from 3. That helped me ALOT with the skipping you talk about. I also have found that by leaving LET THE 3D APPLICATION DECIDE setting on also helped me equally as well. Try the pre render 1st and see what happens. The default is 3. This will limit the number of frames to be processed by the CPU before they are sent to the GPU.

Share this post


Link to post
Share on other sites

Try turning v-sync off. This gives the most frames/smoothest quality for me.

Share this post


Link to post
Share on other sites

Search the Avsim library for "FSX Dynamic Benchmark Package." Install this to get a preset run to bench from. I have ~ the same rig. On this bench run I get a smooth 20FPS with frame rate LoCked at 20, with the following settings. (Note, a new Nvidia driver is out today. Get that installed first. It seemed to help with my 9800GTX+)nHancer will not provide a FPS improvement. You can use Nvidia's control panel with the same effect. However I use nHancer to cleanup some stuff in the PMDG Vcockpit. In any case use 8x AA, 16AF, Vsync on / etc. I run a res of 19x10 on a 40" monitor. My 98 is currently driving 2 of these 40 inch monitors. Resolution is not an issue. The Vcard is NoT the bottleneck. The 88/98GTs are plenty of Vcard for FSX.Experiment with full screen vs full windowed vs reduced window modes. This can make a Huge difference in FPS. It's system dependent. FSX setting tabs setup:Graphics: Frame target 20, Res, 19x10x32. Trilinear/AA off. Global Tex 100%. Lens Flare/Adv Anim on. Bloom/DX10, off.Aircraft: Vcockpit. Hi-res on. Exterior Settings, all on.Scenery: Left side (These are all Vcard related except water). All sliders 100% except water at 2xLow, Land detail on. Right side (These are all CPU related. Play with these for FPS dial-in). Scenery Complex 100%, AG 100%, Ground shadow off, SE 100%.Weather: 60mi clouds. Traffic: (These are all CPU related. Play with these for FPS dial-in): All Off.Installed scenery: UTX/GEX/FSG/FEX-HD scenerys.From the Vcockpit.FPS hopping (i.e., The Stutters) and scenery snap-ins are CPU related. Use the autogen slider to dial-in a smooth, locked 20FPS. You may need to drop it back a notch or 2. Once things smooth out, it becomes a trade off. If you want traffic, you must trade it for less AG (or anything on the right side of the Scenery tab.) As a final dial in try tweaking your FSX.cfg file line: {DISPLAY}TEXTURE_BANDWIDTH_MULT=xx between 20 and 100. No more or less. I run at 70. I guess it helps. Also if you are getting stutters as you pan views, add this line: {BUFFERPOOLS}Poolsize=50000000You are stealing Vcard memory to hold in reserve as a cashe, so easy here. 50M is 10% of your total memory. That's about all you want to go.You have a good system. It'll run the default airplanes just fine. With AG at 25% and a bit of traffic, PMDG's new MD11 can maintain 15FPS on a urban final. There is no stuttering, so it's usable, barely. Make sure you lock frame at 20 in these highly dense Autogen areas. Unlock (if you want) once you are clear of the city. These little 30% (Nehalam) bumps in CPU horsepower or (subjective) 10% bumps memory provision are really pretty irrelevant. 20 FPS goes to 22 or 25, but still at seriously reduced settings. We need some 3X-bumps . . . several. http://forums.avsim.net/user_files/194526.jpg

Share this post


Link to post
Share on other sites

I just fired up FS9 and im getting the same snapping with that, Im thinking of buying a new hard drive for fsx/fs9 dedicated and having OS on the other drive. What you think?

Share this post


Link to post
Share on other sites

Forgot to ask, what is the best, fastest hard drive out there SATA2 style...Samsung spinpoint with 32mb cache?

Share this post


Link to post
Share on other sites

Any modern 7200RPM SATA HD will do. Transfer rates are ~ 100MB/sec with access times of ~ 10ms. Their performance will be indistinguishable. I like the seagates because of their 5 year warranty. There's a very expensive 10,000 RPM drive, but its performance advantage is limited to bragging rights. It won't help FS. The 7200s provide more that enough performance capacity for in-game scenery loading. Those 1TB Seagates for $100 look amazing. Once you have a modern drive, the next trick is to properly defrag. I use Ultimate defrag. It lets me put the FSX directory on the outer edge of the hard drive's disk. Those performance numbers (above) are averages. Performance is better at the outer edge the disk, worse toward the center. You want your FS files on the outer edge. And yes, the Samsung has upper-par performance. Check out Hitachi too.

Share this post


Link to post
Share on other sites

I recently read that one of the fastest drive out there for raw SATA (from about a month ago) was an 80Gb WD velociraptor 10K RPM drive, OEM edition. That probably has changed by now. The definition of fast is always a sure topic of discussion, as opinions vary as much as the number of available models, plus it varies from one day to the next. For example, the same drive in the 160Gb capacity is slower.The larger, slower rpm drives can easily make up actual performance by having more data in the high speed areas of the disk (the outside, because data reads/writes are faster are you get away from the center of the spindle).Speed comes in FSX when you are loading scenery (after the sim has loaded), especially if you fly a high speed bird like the F16. Fly a Sopwith and you can probably hand crank the disk and still get good FPS :)There are so many factors though, disk is usually the least of your concerns when it comes to FPS in FSX.Cheers,Etienne

Share this post


Link to post
Share on other sites

Ok, so im really now considering getting a new hard drive. Ive dialled all the settings back in FSX and still the stutter appears. Even in FS9 with default aircraft! Its got to be teh hard drive. i have all services closed in vista 64. I wonder if getting a new hard drive and putting FSX and FS9 on it will eliminate this problem. All my other games seem to work fine and vista 64 flies on this drive though?I have it partitioned, so that C: is part 1 with everything on, and D: is part 2 with just FSX and FS9 on. What you guys think?

Share this post


Link to post
Share on other sites

What HDs are you using now? Services won't effect game play if adequate ram is available (2G+). Don't shut 'em down. It can cause problems. Partitioning won't help either, nor will putting programs on a separate drive. Actually, that partitioned game drive might be causing the problem. If everything is on a single drive/partition, the defrag program can use the entire physical disk to reposition data. FS directories need to be at the physical outside edge of the drive's disk. The partition may have the program locked onto the slower part of the HD. When defraging a partition, the defrag program may not be allowed full (physical) disk access to move directories out of a partitioned HD section. The best install is to simply put everything (op system, programs, the works) on a single (and single partitioned), modern 7200RPM drive. Then degrag the FS directory to the outside track. The transfer rate/access time of any single, modern 7200RPM harddrive is entirely adequate to fully support all aspects of FS in-gameplay.

Share this post


Link to post
Share on other sites

I started getting "RAID Access Fail" messages at various times. I decided to follow NickN suggestions and get rid of RAID 0.I tried the last 2 NV drivers but had to go back to 169.25. Had tearing textures and vert black bars when external panning.FPS ~50 away and 23 at KSEA. Locked at 30 and everything is smooth. Sliders full right and water low 2X, DX9, Traffic 60% and others 20%. DX10 gives me >100 FPS away but has flashing textures and Non-FSX aircraft are all white, so I use DX9. Setup your video as NickN suggests. Uncheck AA in FSX (It must be checked for DX10). In driver: AF 16, AA 8xQ, Supersample, LOD Clamp, VSync Force On.I have one 160GB HD dedicated to (bare) install of Vista Prem. and FSX. This was recommended by NickN and works great for me. I have the other 160GB HD with XP for internet, MS Office, and older flight sims. Having no software on Vista that wants to communicate with the mother ship, and no AV, makes FSX run very smooth. If you only use Vista one HD is enough.Works for me!DaveSystem:Dell XPS 720 H2CIntel Quad Core Extreme QX6800 @ 3.73GHz2GB Corsair Dominator EPP 8500C5D 800MHz FSB 1066 MHz2x160GB WD SATA Raptors, Sound Blaster X-FiNvidia 2x8800GTX 768MB SLI, Dell 2407WFP PanelXP driver: 169.21, Vista driver: 169.25Logitech Z680 5.1 Speakers, G5 Mouse, Saitek X52WinXP Media Edition SP2 on C: (SATA 0)Vista SP1 on D: (SATA 1) (Dual Boot)3DMark06: 17,018/6992/7123/5667

Share this post


Link to post
Share on other sites

Ok, so I done a bare install of Vista 64, stopped all uneccessary services etc...Just installed FSX with Acceleration pack. NO CFG tweaks, sensible slider settings, Defragged by O&O name setiing. And still the same problem.....Now im on the verge of giving up!

Share this post


Link to post
Share on other sites

Install the latest Nvidia driver. Then delete the FSX.cfg. It will rebuild on the first FS restart. Now take Bloom/DX10 off. Don't use these ever. On the scenery tab, take water to low, and all right side sliders to off. Then all traffic off too. Do not stop services. That will get the frames up. Now bring water to 2xlow. Frame should survive this. Start bring up Complexity and SE, leave AG for last. The hopping is your system's slider-limit.

Share this post


Link to post
Share on other sites

Ok so i moved all sliders to the far left and loaded the default flight but used the extra plane....the stutter is not as bad, BUT it is still there!? this snapping is really annoying...it must be a dodgy hard drive that I have? or is there something else causing this? I get no stutters in any other games? hmmmmm

Share this post


Link to post
Share on other sites