Archived

This topic is now archived and is closed to further replies.

scruffyduck

FSX won't refresh using ADE,FSXKML etc.

Recommended Posts

Hi again, sorry but have searched and can't find out why FSX won't refresh the updated scenery after I have modified the airport using ADE (and FSX KML). I compile the .bgl and let FSX rebuild the scenery config but there are no changes. I am connected via simconnect. Also, When I first started my airfield by modifying the stock, ADE displayed and allowed me to move and manipulate the stock hangers, but now they won't display in ADE,. Why is this? And while I'm here.....what's the best way to do parking lots with cars in them? Many thanks.EDIT: I guess one needs to close out the "flight", then do a refresh and reload the "flight"? I thought you could refresh the scenery cfg while the flight was loaded?? Regards, Kendall#1: E6750@3.2GHZ/Coolermaster HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - 174.74 beta Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Which version of ADE are you using? I assume the latest version. When you say nothing changes can you tell me what you are referring to? Is it buildings and objects or is it aiport features such as runways and aprons.From your Edit are you saying that you have not closed FSX before compiling? Generally the only safe way to ensure that the scenery database gets updated and any in memory scenery is flushed is to compile with FSX closed down and then re-load it. You need to see the progress bars that say FSX is updating the scenery database to be sure that it is updating.If some objects like hangars are not appearing please make sure that the Scenery Complexity (Drop down box on the menu bar) is set to EXTREMELY_DENSE. If not you may not see everything since at other settings ADE displays what would be visible in FSX at that setting.

Share this post


Link to post
Share on other sites

Hi again Jon,1. Yes I am fully updated to the latest version - 1.22. 2. When nothing changes after I complile the BGL I mean everything.3. Yes, the changes will occur after I close/restart FSX and flush memory. I was under the assumption (erroneous?) that with FSX one needed only to refresh the scenery.cfg and the changes would be reflected without exiting the "flight" or the sim. Is that true? If memory serves, sometimes it has seemed to work this way with various utilities - others times, not. 4. If have been designing from the start with all scenery sliders maxed. What's strange is that when I first began, the stock hangers showed in ADE and I actually moved them to their present locations. Now, they don't even appear in ADE - they do appear in the scenery, though. Since I began the project, I have added some files generated by FSX-KML and also have modified some earlier object placements using Whisaplacer. Maybe in doing so I upset some sort of "balance" somewhere? Just speculating, of course. I hope I am clear for you and anyone else as to what's occuring, thanks again for the help.EDIT: After double checking things, I discovered that I had, in fact, dropped the FSX autogen scenery slider to "dense". After maxing it both in FSX and in ADE, I now have the hangars appearing in ADE and can move them, sorry. Still interested in the other questions though.Regards, Kendall#1: E6750@3.2GHZ/Coolermaster HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - 174.74 beta Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites

Can you please check that you have the scenery complexity set to EXTREMELY_DENSE in ADE - this is the drop box on the menu bar next to settings. If this is not at extremely dense then some objects and buildings may not appear. These are not the sliders in FSX but the drop box in ADE. If this is set to a lesser value than the slider in FSX then objects and buildings will appear in FSX and not in ADE. They are still in the ADE file and will be compiled but will not show up on the display. Also make sure in the View Menu that you have Display Only Objects ticked otherwise you may again get some objects show in FSX that do not show in ADE. If none of this works then send me the .ade file (jon AT scruffyduck.co.uk) and I will look at it here.

Share this post


Link to post
Share on other sites

Hi I'm having the same problem, ( the reason I am on this forum, I cannot get on the ADE forum this morning for some reason )I delete things from fsx in ADE, and they show up in fsx. I even made a polygon and excluded the whole airport ,in fsx the area was covered with autogen trees ,but the airport was still there in the trees.If I open up the xml file should there be some true notations as well as false?.If I exclude with EB-fsx they are gone in fsx. Thanks.:-hmmm

Share this post


Link to post
Share on other sites

Are you talking about trees or specific buildings? or airport elements. Please explain a bit more about what is happening. You seems to be talking about several different things here that are handled differently. It is not very easy for us to work out what is happening if we just get a fairly general explanation.Perhaps you can email me the .ADE file that you are having the problem with and tell me which objects are not being deleted? jon AT scruffyduck.co.uk

Share this post


Link to post
Share on other sites

>Hi I'm having the same problem, ( the reason I am on this>forum, I cannot get on the ADE forum this morning for some>reason )I delete things from fsx in ADE, and they show up in>fsx. I even made a polygon and excluded the whole airport ,in>fsx the area was covered with autogen trees ,but the airport>was still there in the trees.If I open up the xml file should>there be some true notations as well as false?.If I exclude>with EB-fsx they are gone in fsx. Thanks.:-hmmm Do you understand what "made a polygon and excluded the whole airport" means within FSX?The polygon you made that you thought was going to do one thing, doesn't. It takes out the airport background area, which is the flattened area and the textures on that flattened area, that also restrict the display of autogen trees. It does not control whether airport buildings are shown, or whether taxiways and runways are shown. It handles a specific function within FSX.If you haven't spent some time, even a minimal amount, looking at the SDK instructions, please do. Scenery design in FSX isn't quick and easy. The relationship between ground, objects, airports, traffic and many other areas means there must be a little time spent understanding the process. It will also mean we don't claim a program doesn't work properly, when it's not the program that isn't producing the desired end results.

Share this post


Link to post
Share on other sites

OK here is an experiment that I just carried out. This assumes that you want to remove buildings and objects from the airport itself and not trees or buildings around the airport. Perhaps you can try it and tell us if this works for oyu or not. Open ADE and select a stock airport (In my case EGMC). Make sure that View > Display Only Objects is checked. Make sure that the Scenery Complexity box (next to Settings in the main menu) says EXTREMELY_COMPLEX. Each object on the airport is a yellow rectangle, each generic building is a blue rectangle each windsock is a circle with a W in it. Click each one in turn and delete it. When all the different objects are gone Compile the Airport in ADE making sure that the resultant bgl file goes into an active scenery folder in FSX. Run FSX making sure that you see the Scenery Database Update progress and then load your airport. In my case with all the scenery sliders maxed every single building, object and windsock is gone - it is a flat airport. If this is what you are trying to do and it is not working after you follow the same steps as I did then let us know. If you are trying to do something else and not remove these buildings but remove autogen etc then let us know.

Share this post


Link to post
Share on other sites

Hi, I'm sorry if i confused you, I have done all what you suggested, and still the building show up.( If i exclude something with EB-fsx it doesnot show up in fsx. this is just a matter of interest ) This is what I do.in ADE. View drop down menue, select only objects. scenery extremely dense. In both ade and fsx. Stock airport, KFRR.select all generic objects ( blue turn yellow ). Delete one at a time. Compile ok, open fsx show scenery bar, go to to KFRR buildings still there? After that I made the polygon in ADE. In the property menue i selected type: exclude, Tag everything and expected to see everything gone, the airport was still there, with the autogen trees allover the place. This morning i reinstalled my window xp and fsx . If i am doing something wrong i have no idea what it is. It is not my intent to say that the program is not working, i know better than that. Thanks. :(

Share this post


Link to post
Share on other sites

>Can you please check that you have the scenery complexity set>to EXTREMELY_DENSE in ADE - this is the drop box on the menu>bar next to settings. If this is not at extremely dense then>some objects and buildings may not appear. These are not the>sliders in FSX but the drop box in ADE. Yep, discovered a mismatch between the two and that solved that issue - sorry, I should taken a break and thought things through first.In regards to my other main question, to see the changes I've made after compiling the bgl, do I need to exit the slew "flight" and refresh the scenery.cfg and then re-load the "flight? Or should I be able to just do a scenery.cfg refresh? Regards, Kendall#1: E6750@3.2GHZ/Coolermaster HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - 174.74 beta Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites

>Hi, I'm sorry if i confused you, I have done all what you>suggested, and still the building show up.( If i exclude>something with EB-fsx it doesnot show up in fsx. this is just>a matter of interest )>> This is what I do.in ADE. View drop down menue, select only>objects.> scenery extremely dense. In both ade and fsx.> Stock airport, KFRR.select all generic objects ( blue turn>yellow ).> Delete one at a time. Compile ok, open fsx show scenery>bar, go to to KFRR buildings still there? After that I made>the polygon in ADE. In the property menue i selected type:>exclude, Tag everything and expected to see everything gone,>the airport was still there, with the autogen trees allover>the place. This morning i reinstalled my window xp and fsx .>If i am doing something wrong i have no idea what it is. It is>not my intent to say that the program is not working, i know>better than that. Thanks. :( OK so the problem seems to be with deleting generic buildings at KFRR. I will check that here. The Exclude tag for a terrain polygon does exactly what you saw and probably deleted the airport background. With that gone you will get all the trees etc on the airport. This is not the right thing to delete generic buildings or library objects on the airport. Let me look at the airport you mention

Share this post


Link to post
Share on other sites

>In regards to my other main question, to see the changes I've>made after compiling the bgl, do I need to exit the slew>"flight" and refresh the scenery.cfg and then re-load the>"flight? Or should I be able to just do a scenery.cfg>refresh? >>>Regards, KendallYou need to go further than that to be sure. The only way we have found that guarantees to work is to shut FSX down before compiling and then load it again after compile. A real PITA but otherwise it may not work.

Share this post


Link to post
Share on other sites

I did a test with KFRR and this is what happened here. This is ADE showing the generic buildingsScreenHunter_139.jpgThis is ADE after I deleted the 7 generic buildings and the small control towerScreenHunter_138.jpgAnd this is the airport in FSXScreenHunter_137.jpgAs you can see there are no buildings on the airport. Are you sure that you do not have more than one copy of the airport bgl file in FSX in different places? One with the buildings in perhaps? Or is there some thrid party cenery of the area installed?

Share this post


Link to post
Share on other sites

Jon, I only tried the polygon route to see the result. I have tried three dif. airports all with the same results KOKV, KFRR and KMRB .I will check to see if there are other BGL files. I mentioned earlier that my game computer never goes on the web, so everything I dl. must be carried over to the other comp. maybe something got lost in the transfer?.THanks.

Share this post


Link to post
Share on other sites

>> The only way we have found that guarantees to work is to shut FSX down before compiling and then load it again after compile. A real PITA but otherwise it may not work." I agree a PITA - I thought this was supposed to be changed with this version but, oh well, a restart it is then. Thanks again Jon! Regards, Kendall#1: E6750@3.2GHZ/Coolermaster HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - 174.74 beta Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites

>I agree a PITA - I thought this was supposed to be changed>with this version but, oh well, a restart it is then. Thanks>again Jon! Yikes. Just wanted to clarify that I meant the changes were supposed to be in this version of FSX, not ADE. ;-) :-)Regards, Kendall#1: E6750@3.2GHZ/Coolermaster HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - 174.74 beta Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites

>>Yikes. Just wanted to clarify that I meant the changes were>supposed to be in this version of FSX, not ADE. ;-) :-)No problem :-)

Share this post


Link to post
Share on other sites