Sign in to follow this  
Roger Over

FLED strikes again!!!

Recommended Posts

Hi folks,Again I write because of a problem with FLED, no doubt caused by me :-( My problem is that for some inane reason as soon as I try and run FLED in my Oz region, it crashes to desktop, accompanied by of course the usual full and detailed explanation of why it crashed. :-roll It is OK on Sanfran and Seattle.There are no packages. Models have been removed (no change). Airports folders have been removed (no change). There is no AI (as far as I'm aware)Has anyone else had this wee problem? Running Filemon doesn't throw up anything suspicious.Cheers :-wave Bruce H

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Bruce,Bad start in the year with FLED ;-)FU3 is working ? just FLED not ?Look at the last file access with filemon, then do the same with Seattle and look which file is coming next at FLED start. This will give a hint to a missing or corrupted. Caution by removing airport folder, FU3 start without airport folder all mod files are reset to a new elevation ! Strange behavior but I got this at a Seattle08 test. You will then note a high disk activity and very low framerate during about 1 minute. :-(I can just advise: never start a flight without the airport folder with a couple of airports in it.compare file structure, Geos, maps... and the region.cfggood luck :-wave Andre

Share this post


Link to post
Share on other sites

While I really don't much about this it's always a good idea to check what you've changed since last time it worked. I hope you have several generations of working backup? A crash will involve a call for some file or action that can't be resolved (file corrupt, doesn't exist, dividing by zero etc).Hope you get it right since I would love to take an FU3 trip to Australia some day :-}Hans Petter

Share this post


Link to post
Share on other sites

Thanks Andre and Hans,FU is working fine, no problems with airports etc. Just FLED :-( I will try the Filemon approach you suggest Andre, although I find it a bit difficult to narrow the results down to anything meaningful.I may also try moving parts of Sanfran back across to OZ and see if that resolves anything.Probably won't get to do much for a few days as I will be away.I hope you will be able to have a fly around Oz soon Hans. Already there is base scenery for around 186,000 square kilometres. Great for bush flying! Take care,Bruce H :-wave

Share this post


Link to post
Share on other sites

Hi Bruce :-waveMy holidays up north were interrupted by a lot of rain, as you and at least half of the world must know about by now ;) We turned up the Oxley and headed inland but the rain followed us every day, so we headed south from Tamworth and spent a few days in Canberra instead!But no flying at all and we had to come back today :-rollDid you get the FLED problem sorted? I have had this happen years ago but I just copied files across from my 'reference' version until it worked. It wasn't 'fled.exe', nor any of the other circa-1999 files. I suspect that it was the bookmark file, which was HUGE! Lost all my bookmarks though :-(Try deleting 'flbookmk.dat' and see if that helps. Maybe there's a maximum size for it? I used to have most of Seattle and Sanfran in the old one but that's gone now. My current one has much of Seattle in it but not all. It's included in the ZIP attached. *** Chris, if you are reading this, would you be able to zip-up your Sanfran bookmark file? It'll save me creating it again from scratch ;) ***I've also been having problems with my LG2 again (i.e. won't run - after several reinstalls I still get the missing file problem). I redid ALL of the N2 TGAs after another review of the airports in Seattle'08. Some of them still had some rogue lights and a couple were upside-down :-lolI've deleted all of the redone nitemaps and am just using standard ones for now but I need to regenerate the lot again - although I'd like to be able to do this from TGAs in each level somehow, even just the N2-N5s (standard N6&7s aren't too bad really). Whilst the batching capability of LG2 simplifies generating the other levels, I can just as easily do this with Corel - and I have more control. Maybe I can overcome the N4-N5 'step' in brightness?Anyway, I'll leave you to your holidays (don't get washed away and watch for trucks...) and I'll see if I can get these N2s happening again. It USED to work ;)Regards,Jon Point

Share this post


Link to post
Share on other sites

Hi Jon,yes bookmark file can be a problem, and if you want save and managed it so my FLED Bookmark Manager can help here :-)You can convert from the FLED bookmark file to a POI file or vice versa.An old tool from 2003 :-)here it is:

Share this post


Link to post
Share on other sites

Andre,Thanks for that - I'd forgotten all about it. Wish I had backed-up my previous one :-rollI have had some success with the nightlights tonight after cleaning-out the registry and reinstalling but it still won't 'batch'. In any case, I've proven to myself that successive downsizing is a major issue because as soon as I put any of the LG2-generated N5-N7s (generated on 'low') in the mix I get rows of lights in the distance. At the N2-N4 level (on 'high') it looks great, except that the LGS N5s are too bright. Hopefully when Bruce gets back I can finish it off ;)Thanks again ;)Regards,Jon Point

Share this post


Link to post
Share on other sites

Hi folks,Back from a short break (nice and dry up on the tablelands Jon :-) , sounds like you should have tried up there!) Certainly traveling through the upper reaches of the Clarence etc. you could see where the water had been. Unfortunately lots of erosion to deal with now.For our overseas listeners, the area around where I live (north NSW) received about 600mm of rain over about a week. Given that the country has been in drought for years, it was a two edged sword, filling the dams but doing lots of damage as well.Now... FLED. :-mad When I got back I started copying back Sanfran into the OZ region, and lo and behold FLED started working again. It appears that the culprit was something to do with the GEN or GENPILE folder, but when I checked the OZ versions they were unchanged from the Sanfran version.Anyway, I copied the complete OZ region back into my working folder and FLED still worked :-roll . So..... I dunno. FLED gives me the heabies sometimes, I know it was probably only meant for in-house LG use initially, but I don't think I have ever come across a more bug ridden piece of "soft"ware. Unless of course it's something I've written :7 Jon. Good to hear you got your lights happening again. I still can't duplicate the problem with the L6-L7 tiles. Could you zip me your N2's when you get a chance. Or the .tga's would be even better.I will email you a later version of LG2 which allows you to selectively turn the levels on/off.What do you mean by "it still won't batch"?Cheers :-wave Bruce H

Share this post


Link to post
Share on other sites

Bruce,Yes, we almost went west but when the rain followed us inland past Walcha, we thought there'd be little point going north :-rollI have a hodge-podge of night lighting running now - my N2s, N3&4 generated on high, mixed with N5s generated with the N3, 4 & 5 on low, topped-off with LGS N6 & 7s :-lol The problem is that the levels switch at the wrong distance, with N5s coming on too early and staying on too late. N6s fade out before the N5s come on.I also noticed when using your little utility to extract the other levels, that LGS used anti-aliasing on the different levels. I wasn't doing that as it made the N2s go wild, but maybe at the other levels it's the right idea. Either way, If I had a utility that could build each level from TGAs ...?As to the 'won't batch', it starts to run then:http://forums.avsim.net/user_files/183173.jpgHere's the batch file:http://forums.avsim.net/user_files/183174.jpgI can slavishly build N2-4s OK and it does N5-7s but the results aren't that good yet. I might wait for the next version and send you the TGAs in the meantime ;) Regards,Jon Point

Share this post


Link to post
Share on other sites

Jon,Can you send me the litegen2.log file please? It is probably in your ../maps folder.CheersBruce H

Share this post


Link to post
Share on other sites

Jon, you can create TGA maps level 0 to 4 using GenQuadrant.exe After loading of L0xxyy.tga you can select each level or all to export L0.tga, L1.tga, L2.tga, L3.tga and l4.tgaNight level are different in level number, but just look at the size and rename it to night level and tile name.:-waveAndre

Share this post


Link to post
Share on other sites

Hi Andre,You can't use Genquadrant to generate night tiles (unless you have modified it). The tile shape, size and internal layout are different to normal maps.As soon as we sort Jon's issues out I will get a copy of Lightgen2.exe to you.Cheers :-wave Bruce H

Share this post


Link to post
Share on other sites

Bruce,It's attached. Doesn't say much though...Chris,It's in your flight3 folder. I'm assuming that you used a lot of bookmarks for Sanfran 2006 - I did ;) My bookmark file was trashed and without remembering that Andre had a neat application for editing them, I deleted it and lost all of my Sanfran bookmarks :-(Andre, it seems to be possible to improve on the standard textures as they did not use the whole 4m/pixel. E.G. Swanson:http://forums.avsim.net/user_files/183230.jpgHarvey with the grass and paved strips in the right places (and a heap of buildings...):http://forums.avsim.net/user_files/183228.jpghttp://forums.avsim.net/user_files/183229.jpgJust wish I could make those stupid white lines about 1/4 as thick :-rollRegards,Jon Point

Share this post


Link to post
Share on other sites

Jon,I have absolutely no idea what you're talking about. I do not have any "bookmark" file in my FLIGHT3 folder, and I'm not aware that I used anything like that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this